summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-10 21:56:13 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-10 21:56:13 +0000
commit4b90da38a1aa6c781bcaabf417c503013e4874c5 (patch)
tree0dd085fbfaaba407bbe2cb667f70a80688868852 /media-libs/libraw
parentRemove old; dont use invalid useflag xine, bug 378155 (diff)
downloadgentoo-2-4b90da38a1aa6c781bcaabf417c503013e4874c5.tar.gz
gentoo-2-4b90da38a1aa6c781bcaabf417c503013e4874c5.tar.bz2
gentoo-2-4b90da38a1aa6c781bcaabf417c503013e4874c5.zip
Version bump
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libraw')
-rw-r--r--media-libs/libraw/ChangeLog7
-rw-r--r--media-libs/libraw/libraw-0.13.8.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/media-libs/libraw/ChangeLog b/media-libs/libraw/ChangeLog
index 50b4756b83e5..3d76ab702729 100644
--- a/media-libs/libraw/ChangeLog
+++ b/media-libs/libraw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libraw
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.7 2011/07/16 19:20:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.8 2011/08/10 21:56:13 radhermit Exp $
+
+*libraw-0.13.8 (10 Aug 2011)
+
+ 10 Aug 2011; Tim Harder <radhermit@gentoo.org> +libraw-0.13.8.ebuild:
+ Version bump
*libraw-0.13.7 (16 Jul 2011)
diff --git a/media-libs/libraw/libraw-0.13.8.ebuild b/media-libs/libraw/libraw-0.13.8.ebuild
new file mode 100644
index 000000000000..04d1e48e8194
--- /dev/null
+++ b/media-libs/libraw/libraw-0.13.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/libraw-0.13.8.ebuild,v 1.1 2011/08/10 21:56:13 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+MY_P="LibRaw-${PV}"
+DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
+HOMEPAGE="http://www.libraw.org/"
+SRC_URI="http://www.libraw.org/data/${MY_P}.tar.gz
+ demosaic? ( https://github.com/LibRaw/LibRaw-demosaic-pack-GPL2/tarball/${PV} -> LibRaw-demosaic-pack-GPL2-${PV}.tar.gz
+ https://github.com/LibRaw/LibRaw-demosaic-pack-GPL3/tarball/${PV} -> LibRaw-demosaic-pack-GPL3-${PV}.tar.gz )"
+
+# Libraw also has it's own license, which is a pdf file and
+# can be obtained from here:
+# http://www.libraw.org/data/LICENSE.LibRaw.pdf
+LICENSE="LGPL-2.1 CDDL GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="demosaic examples +lcms +openmp static-libs"
+
+DEPEND="lcms? ( media-libs/lcms:2 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( Changelog.txt README )
+
+src_unpack() {
+ unpack ${A}
+ if use demosaic ; then
+ mv *LibRaw-demosaic*GPL2* LibRaw-demosaic-pack-GPL2-${PV}
+ mv *LibRaw-demosaic*GPL3* LibRaw-demosaic-pack-GPL3-${PV}
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.4-docs.patch
+ eautomake
+}
+
+src_configure() {
+ econf \
+ $(use_enable demosaic demosaic-pack-gpl2) \
+ $(use_enable demosaic demosaic-pack-gpl3) \
+ $(use_enable examples) \
+ $(use_enable lcms) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove useless .la files
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}