summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-09 15:19:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-09 15:19:39 +0000
commitfa5992b27befd08e797daa7a18e6f0acd9c22fbc (patch)
treee550ea8d9fb43d167582500756b184274af89960 /media-libs/libtiger
parentmarking zip-3.0-r1 ~ppc for bug 349393 (diff)
downloadgentoo-2-fa5992b27befd08e797daa7a18e6f0acd9c22fbc.tar.gz
gentoo-2-fa5992b27befd08e797daa7a18e6f0acd9c22fbc.tar.bz2
gentoo-2-fa5992b27befd08e797daa7a18e6f0acd9c22fbc.zip
version bump
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libtiger')
-rw-r--r--media-libs/libtiger/ChangeLog9
-rw-r--r--media-libs/libtiger/libtiger-0.3.4.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/media-libs/libtiger/ChangeLog b/media-libs/libtiger/ChangeLog
index 215f902731e3..82dccbcd36f9 100644
--- a/media-libs/libtiger/ChangeLog
+++ b/media-libs/libtiger/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libtiger
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtiger/ChangeLog,v 1.14 2009/11/13 00:36:20 josejx Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtiger/ChangeLog,v 1.15 2011/01/09 15:19:39 aballier Exp $
+
+*libtiger-0.3.4 (09 Jan 2011)
+
+ 09 Jan 2011; Alexis Ballier <aballier@gentoo.org> +libtiger-0.3.4.ebuild:
+ version bump
13 Nov 2009; Joseph Jezak <josejx@gentoo.org> libtiger-0.3.3.ebuild:
Marked ppc64 stable.
diff --git a/media-libs/libtiger/libtiger-0.3.4.ebuild b/media-libs/libtiger/libtiger-0.3.4.ebuild
new file mode 100644
index 000000000000..0d1d05c595c1
--- /dev/null
+++ b/media-libs/libtiger/libtiger-0.3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtiger/libtiger-0.3.4.ebuild,v 1.1 2011/01/09 15:19:39 aballier Exp $
+
+EAPI=2
+
+inherit libtool
+
+DESCRIPTION="A rendering library for Kate streams using Pango and Cairo"
+HOMEPAGE="http://code.google.com/p/libtiger/"
+SRC_URI="http://libtiger.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="x11-libs/pango
+ >=media-libs/libkate-0.2.0
+ x11-libs/cairo"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable doc) --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc THANKS README ChangeLog AUTHORS || die
+ find "${D}" -name '*.la' -delete
+}