summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-06 22:45:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-06 22:45:54 +0000
commit5801a6815b8c445882d035ae0418f01785528c33 (patch)
tree0e1fb7ba3e3a9efb37c48e32e4743d83f400592a /media-libs/libungif
parentdigest fix (diff)
downloadgentoo-2-5801a6815b8c445882d035ae0418f01785528c33.tar.gz
gentoo-2-5801a6815b8c445882d035ae0418f01785528c33.tar.bz2
gentoo-2-5801a6815b8c445882d035ae0418f01785528c33.zip
old
Diffstat (limited to 'media-libs/libungif')
-rw-r--r--media-libs/libungif/files/digest-libungif-4.1.0.1b1
-rw-r--r--media-libs/libungif/files/libungif-4.1.0-stdarg.patch22
-rw-r--r--media-libs/libungif/files/libungif-CVS.patch142
-rw-r--r--media-libs/libungif/libungif-4.1.0.1b.ebuild81
4 files changed, 0 insertions, 246 deletions
diff --git a/media-libs/libungif/files/digest-libungif-4.1.0.1b b/media-libs/libungif/files/digest-libungif-4.1.0.1b
deleted file mode 100644
index 26129c3be58f..000000000000
--- a/media-libs/libungif/files/digest-libungif-4.1.0.1b
+++ /dev/null
@@ -1 +0,0 @@
-MD5 323e5243f848823c57bb5d8a876daf89 libungif-4.1.0b1.tar.bz2 312668
diff --git a/media-libs/libungif/files/libungif-4.1.0-stdarg.patch b/media-libs/libungif/files/libungif-4.1.0-stdarg.patch
deleted file mode 100644
index 1a5de27cf152..000000000000
--- a/media-libs/libungif/files/libungif-4.1.0-stdarg.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- libungif-4.1.0b1/configure.in.varg Thu Jul 27 14:28:17 2000
-+++ libungif-4.1.0b1/configure.in Thu Jul 27 14:28:38 2000
-@@ -48,7 +48,7 @@
- dnl Checks for header files.
- AC_HEADER_STDC
- AC_CHECK_HEADERS(fcntl.h)
--AC_CHECK_HEADERS(varargs.h)
-+AC_CHECK_HEADERS(stdarg.h)
-
- dnl Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
---- libungif-4.1.0b1/configure.varg Thu Jul 27 14:28:21 2000
-+++ libungif-4.1.0b1/configure Thu Jul 27 14:28:41 2000
-@@ -3247,7 +3247,7 @@
- fi
- done
-
--for ac_hdr in varargs.h
-+for ac_hdr in stdarg.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
diff --git a/media-libs/libungif/files/libungif-CVS.patch b/media-libs/libungif/files/libungif-CVS.patch
deleted file mode 100644
index a0cf25c42a1f..000000000000
--- a/media-libs/libungif/files/libungif-CVS.patch
+++ /dev/null
@@ -1,142 +0,0 @@
-diff -urN --exclude CVS --exclude .cvsignore libungif-4.1.0b1/TODO libungif/TODO
---- libungif-4.1.0b1/TODO Sat Feb 12 14:21:11 2000
-+++ libungif/TODO Thu Feb 24 16:36:36 2000
-@@ -1,6 +1,10 @@
-+Make sure all malloc calls check their return value.
-+
-+=======
- Merge in all the changes that accumulated while I was gone.
- (Point your mail reader at libungif.mail to see these messages.)
-
-+=======
- Besides fixing bugs, what's really needed is for someone to work out how to
- calculate a colormap for writing gifs from rgb sources. Right now, an rgb
- source that has only two colors (b/w) is being converted into an 8 bit gif....
-diff -urN --exclude CVS --exclude .cvsignore libungif-4.1.0b1/lib/dgif_lib.c libungif/lib/dgif_lib.c
---- libungif-4.1.0b1/lib/dgif_lib.c Tue Feb 8 02:00:26 2000
-+++ libungif/lib/dgif_lib.c Thu Mar 9 19:05:48 2000
-@@ -24,6 +24,10 @@
- #include <sys/stat.h>
- #endif /* __MSDOS__ */
-
-+#ifdef HAVE_IO_H
-+#include <io.h>
-+#endif
-+
- #ifndef __MSDOS__
- #include <stdlib.h>
- #endif
-@@ -61,9 +65,9 @@
- GifFileType *GifFile;
-
- if ((FileHandle = open(FileName, O_RDONLY
--#ifdef __MSDOS__
-+#if defined(__MSDOS__) || defined(_OPEN_BINARY)
- | O_BINARY
--#endif /* __MSDOS__ */
-+#endif /* __MSDOS__ || _OPEN_BINARY */
- )) == -1) {
- _GifError = D_GIF_ERR_OPEN_FAILED;
- return NULL;
-@@ -87,15 +91,16 @@
- GifFilePrivateType *Private;
- FILE *f;
-
-- if ((GifFile = (GifFileType *) malloc(sizeof(GifFileType))) == NULL) {
-+ GifFile = (GifFileType *) malloc(sizeof(GifFileType));
-+ if (GifFile == NULL) {
- _GifError = D_GIF_ERR_NOT_ENOUGH_MEM;
- return NULL;
- }
-
- memset(GifFile, '\0', sizeof(GifFileType));
-
-- if ((Private = (GifFilePrivateType *) malloc(sizeof(GifFilePrivateType)))
-- == NULL) {
-+ Private = (GifFilePrivateType *) malloc(sizeof(GifFilePrivateType));
-+ if (Private == NULL) {
- _GifError = D_GIF_ERR_NOT_ENOUGH_MEM;
- free((char *) GifFile);
- return NULL;
-@@ -160,15 +165,16 @@
- GifFileType *GifFile;
- GifFilePrivateType *Private;
-
--
-- if ((GifFile = (GifFileType *) malloc(sizeof(GifFileType))) == NULL) {
-+ GifFile = (GifFileType *) malloc(sizeof(GifFileType));
-+ if (GifFile == NULL) {
- _GifError = D_GIF_ERR_NOT_ENOUGH_MEM;
- return NULL;
- }
-
- memset(GifFile, '\0', sizeof(GifFileType));
-
-- if (!(Private = (GifFilePrivateType*) malloc(sizeof(GifFilePrivateType)))){
-+ Private = (GifFilePrivateType*) malloc(sizeof(GifFilePrivateType));
-+ if (!Private){
- _GifError = D_GIF_ERR_NOT_ENOUGH_MEM;
- free((char *) GifFile);
- return NULL;
-@@ -342,6 +348,11 @@
- GifFile->Image.ColorMap->Colors[i].Blue = Buf[2];
- }
- }
-+ else if (GifFile->Image.ColorMap)
-+ {
-+ FreeMapObject(GifFile->Image.ColorMap);
-+ GifFile->Image.ColorMap = NULL;
-+ }
-
- if (GifFile->SavedImages) {
- if ((GifFile->SavedImages = (SavedImage *)realloc(GifFile->SavedImages,
-@@ -554,7 +565,7 @@
- if (GifFile->SavedImages)
- {
- FreeSavedImages(GifFile);
-- GifFile = NULL;
-+ GifFile->SavedImages = NULL;
- }
-
- free(GifFile);
-diff -urN --exclude CVS --exclude .cvsignore libungif-4.1.0b1/lib/egif_lib.c libungif/lib/egif_lib.c
---- libungif-4.1.0b1/lib/egif_lib.c Tue Feb 8 02:00:26 2000
-+++ libungif/lib/egif_lib.c Thu Mar 9 00:18:35 2000
-@@ -30,6 +30,10 @@
- #endif
- #endif /* __MSDOS__ */
-
-+#ifdef HAVE_IO_H
-+#include <io.h>
-+#endif
-+
- #include <fcntl.h>
- #include <stdlib.h>
- #include <stdio.h>
-diff -urN --exclude CVS --exclude .cvsignore libungif-4.1.0b1/lib/gif_font.c libungif/lib/gif_font.c
---- libungif-4.1.0b1/lib/gif_font.c Sun Feb 6 17:45:07 2000
-+++ libungif/lib/gif_font.c Thu Mar 9 00:17:40 2000
-@@ -255,8 +255,8 @@
- x + border + (leadspace * GIF_FONT_WIDTH),
- y + border + (GIF_FONT_HEIGHT * i++),
- cp, fg);
-- } while
-- (cp = strtok((char *)NULL, "\r\n"));
-+ cp = strtok((char *)NULL, "\r\n");
-+ } while (cp);
-
- /* outline the box */
- DrawBox(Image,
-diff -urN --exclude CVS --exclude .cvsignore libungif-4.1.0b1/lib/gifalloc.c libungif/lib/gifalloc.c
---- libungif-4.1.0b1/lib/gifalloc.c Sun Feb 6 17:45:07 2000
-+++ libungif/lib/gifalloc.c Sat Dec 16 01:03:14 2000
-@@ -138,7 +138,7 @@
- */
- while (ColorIn1->Colors[CrntSlot-1].Red == 0
- && ColorIn1->Colors[CrntSlot-1].Green == 0
-- && ColorIn1->Colors[CrntSlot-1].Red == 0)
-+ && ColorIn1->Colors[CrntSlot-1].Blue == 0)
- CrntSlot--;
-
- /* Copy ColorIn2 to ColorUnionSize (use old colors if they exist): */
-
diff --git a/media-libs/libungif/libungif-4.1.0.1b.ebuild b/media-libs/libungif/libungif-4.1.0.1b.ebuild
deleted file mode 100644
index 797bb57195c7..000000000000
--- a/media-libs/libungif/libungif-4.1.0.1b.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libungif/libungif-4.1.0.1b.ebuild,v 1.18 2005/02/03 21:06:22 tgall Exp $
-
-inherit eutils libtool
-
-REAL_P=${P/.1b/b1}
-DESCRIPTION="A library for reading and writing gif images without LZW compression"
-HOMEPAGE="http://prtr-13.ucsc.edu/~badger/software/libungif/index.shtml"
-SRC_URI="mirror://gentoo/${REAL_P}.tar.bz2"
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64"
-IUSE="X gif"
-
-RDEPEND="X? ( virtual/x11 )"
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.58"
-
-S=${WORKDIR}/${REAL_P}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/libungif-CVS.patch
- epatch ${FILESDIR}/libungif-4.1.0-stdarg.patch
-
- automake --add-missing
-}
-
-src_compile() {
- elibtoolize || die
-
- local myconf
- use alpha && myconf="${myconf} --host=alpha-unknown-linux-gnu"
- export WANT_AUTOCONF=2.5
- econf `use_with X x` ${myconf} || die
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-
- use gif && rm -rf ${D}/usr/bin
-
- dodoc AUTHORS BUGS COPYING ChangeLog NEWS ONEWS UNCOMPRESSED_GIF \
- README TODO doc/*.txt || die "dodoc failed"
- dohtml -r doc || die "dohtml failed"
-}
-
-pkg_postinst() {
- if use gif ; then
- einfo "You had the gif USE flag set, so it is assumed that you want"
- einfo "the binary from giflib instead. Please make sure you have"
- einfo "giflib emerged. Otherwise, unset the gif flag and remerge this"
- else
- einfo "You did not have the gif USE flag, so your gif binary is being"
- einfo "provided by this package. If you would rather use the binary"
- einfo "from giflib, please set the gif USE flag, and re-emerge both"
- einfo "this and giflib"
- fi
-}
-
-src_test() {
- if has_version 'media-gfx/xv' ; then
- if [ -z "$DISPLAY" ] || ! (/usr/X11R6/bin/xhost &>/dev/null) ; then
- ewarn
- ewarn "You are not authorised to conntect to X server to make check."
- ewarn "Disabling make check."
- ewarn
- epause; ebeep; epause
- else
- make check || die "make check failed"
- fi
- else
- ewarn
- ewarn "You need media-gfx/xv to run src_test for this package."
- ewarn
- epause; ebeep; epause
- fi
-}