summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2007-11-11 20:38:43 +0000
committerNed Ludd <solar@gentoo.org>2007-11-11 20:38:43 +0000
commit06a7f0ac1c4899b4b82e0d39f3a588fc7dba9146 (patch)
tree87b9ce9e877e3ba18f85f5829bc11d3e1355003a /media-libs/mesa/mesa-6.5.2-r1.ebuild
parentDisable makeinfo version checking #198182. (diff)
downloadgentoo-2-06a7f0ac1c4899b4b82e0d39f3a588fc7dba9146.tar.gz
gentoo-2-06a7f0ac1c4899b4b82e0d39f3a588fc7dba9146.tar.bz2
gentoo-2-06a7f0ac1c4899b4b82e0d39f3a588fc7dba9146.zip
- The use of the hardened flag to control the building of position independent code was incorrect. mesa ebuilds now use pic USE flag
(Portage version: 2.1.3.9)
Diffstat (limited to 'media-libs/mesa/mesa-6.5.2-r1.ebuild')
-rw-r--r--media-libs/mesa/mesa-6.5.2-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/mesa/mesa-6.5.2-r1.ebuild b/media-libs/mesa/mesa-6.5.2-r1.ebuild
index 36c187632706..6f2d36f2f26b 100644
--- a/media-libs/mesa/mesa-6.5.2-r1.ebuild
+++ b/media-libs/mesa/mesa-6.5.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5.2-r1.ebuild,v 1.16 2007/11/03 17:01:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5.2-r1.ebuild,v 1.17 2007/11/11 20:38:43 solar Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability
@@ -32,7 +32,7 @@ IUSE_VIDEO_CARDS="
IUSE="${IUSE_VIDEO_CARDS}
debug
doc
- hardened
+ pic
motif
nptl
xcb
@@ -180,8 +180,8 @@ src_unpack() {
# Set drivers to everything on which we ran add_drivers()
echo "DRI_DIRS = ${DRI_DRIVERS}" >> "${HOSTCONF}"
- if use hardened; then
- einfo "Deactivating assembly code for hardened build"
+ if use pic; then
+ einfo "Deactivating assembly code for pic build"
echo "ASM_FLAGS =" >> "${HOSTCONF}"
echo "ASM_SOURCES =" >> "${HOSTCONF}"
echo "ASM_API =" >> "${HOSTCONF}"