summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-11-28 13:35:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-11-28 13:35:24 +0000
commit5456b3cbb6c331c5c28a26f5eef9745f1b2fed3a (patch)
tree48ccb0b8ccbac4280ef4aeb944ee9cbbb4236258 /media-libs/mlt
parentVersion bumped. #377129 (diff)
downloadgentoo-2-5456b3cbb6c331c5c28a26f5eef9745f1b2fed3a.tar.gz
gentoo-2-5456b3cbb6c331c5c28a26f5eef9745f1b2fed3a.tar.bz2
gentoo-2-5456b3cbb6c331c5c28a26f5eef9745f1b2fed3a.zip
fix build with ffmpeg git: do not use internal symbols
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/mlt')
-rw-r--r--media-libs/mlt/ChangeLog6
-rw-r--r--media-libs/mlt/files/mlt-0.7.6-ffmpeg.patch33
-rw-r--r--media-libs/mlt/mlt-0.7.6.ebuild5
3 files changed, 41 insertions, 3 deletions
diff --git a/media-libs/mlt/ChangeLog b/media-libs/mlt/ChangeLog
index 5bc97b2967b9..cab7dea40d59 100644
--- a/media-libs/mlt/ChangeLog
+++ b/media-libs/mlt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mlt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.74 2011/10/31 21:55:14 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.75 2011/11/28 13:35:24 aballier Exp $
+
+ 28 Nov 2011; Alexis Ballier <aballier@gentoo.org> mlt-0.7.6.ebuild,
+ +files/mlt-0.7.6-ffmpeg.patch:
+ fix build with ffmpeg git: do not use internal symbols
*mlt-0.7.6 (31 Oct 2011)
diff --git a/media-libs/mlt/files/mlt-0.7.6-ffmpeg.patch b/media-libs/mlt/files/mlt-0.7.6-ffmpeg.patch
new file mode 100644
index 000000000000..2fb45d52b723
--- /dev/null
+++ b/media-libs/mlt/files/mlt-0.7.6-ffmpeg.patch
@@ -0,0 +1,33 @@
+Do not use ffmpeg internal symbols.
+
+Index: mlt-0.7.6/src/modules/avformat/filter_avdeinterlace.c
+===================================================================
+--- mlt-0.7.6.orig/src/modules/avformat/filter_avdeinterlace.c
++++ mlt-0.7.6/src/modules/avformat/filter_avdeinterlace.c
+@@ -26,7 +26,9 @@
+
+ // ffmpeg Header files
+ #include <libavformat/avformat.h>
++#include <libavcodec/avcodec.h>
+
++#if 0
+ #ifdef USE_MMX
+ #include "mmx.h"
+ #else
+@@ -293,6 +295,7 @@ static int mlt_avpicture_deinterlace(AVP
+ #endif
+ return 0;
+ }
++#endif
+
+ /** Do it :-).
+ */
+@@ -318,7 +321,7 @@ static int filter_get_image( mlt_frame f
+
+ // Fill the picture
+ avpicture_fill( output, *image, PIX_FMT_YUYV422, *width, *height );
+- mlt_avpicture_deinterlace( output, output, PIX_FMT_YUYV422, *width, *height );
++ avpicture_deinterlace( output, output, PIX_FMT_YUYV422, *width, *height );
+
+ // Free the picture
+ mlt_pool_release( output );
diff --git a/media-libs/mlt/mlt-0.7.6.ebuild b/media-libs/mlt/mlt-0.7.6.ebuild
index 255677ac92be..06acef739fb2 100644
--- a/media-libs/mlt/mlt-0.7.6.ebuild
+++ b/media-libs/mlt/mlt-0.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.7.6.ebuild,v 1.1 2011/10/31 21:55:14 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.7.6.ebuild,v 1.2 2011/11/28 13:35:24 aballier Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.6"
@@ -60,7 +60,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.7.2-ruby-link.patch
+ epatch "${FILESDIR}"/${PN}-0.7.2-ruby-link.patch \
+ "${FILESDIR}"/${PN}-0.7.6-ffmpeg.patch
# respect CFLAGS LDFLAGS when building shared libraries. Bug #308873
for x in python lua; do
sed -i "/mlt.so/s: -lmlt++ :& ${CFLAGS} ${LDFLAGS} :" src/swig/$x/build