summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-18 15:41:24 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-18 15:41:24 +0000
commitd1c90d37aa789ea2bdc496dcf2963e4bf42d1ea2 (patch)
tree6d2bfb90f745b457bd0abcb5fe48895d230f477d /media-libs/mutagen
parentVersion bump and remove old (diff)
downloadgentoo-2-d1c90d37aa789ea2bdc496dcf2963e4bf42d1ea2.tar.gz
gentoo-2-d1c90d37aa789ea2bdc496dcf2963e4bf42d1ea2.tar.bz2
gentoo-2-d1c90d37aa789ea2bdc496dcf2963e4bf42d1ea2.zip
Fix the test phase properly.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'media-libs/mutagen')
-rw-r--r--media-libs/mutagen/ChangeLog6
-rw-r--r--media-libs/mutagen/mutagen-1.21.ebuild10
2 files changed, 12 insertions, 4 deletions
diff --git a/media-libs/mutagen/ChangeLog b/media-libs/mutagen/ChangeLog
index e5143d4201bb..bace6167d00e 100644
--- a/media-libs/mutagen/ChangeLog
+++ b/media-libs/mutagen/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/mutagen
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mutagen/ChangeLog,v 1.93 2013/02/18 15:02:53 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mutagen/ChangeLog,v 1.94 2013/02/18 15:41:24 floppym Exp $
+
+ 18 Feb 2013; Mike Gilbert <floppym@gentoo.org> mutagen-1.21.ebuild:
+ Fix the test phase properly.
18 Feb 2013; Samuli Suominen <ssuominen@gentoo.org> mutagen-1.21.ebuild:
Restore eyeD3 test dependency and run ./setup.py test again by overriding
@@ -343,4 +346,3 @@
+mutagen-1.0.ebuild:
Initial Commit. Slightly modified from the original ebuild by Kai Huuhko
<kai.huuhko@gmail.com> attached to Bug #128482.
-
diff --git a/media-libs/mutagen/mutagen-1.21.ebuild b/media-libs/mutagen/mutagen-1.21.ebuild
index bcf679c4ef0a..0ec85ca31aa3 100644
--- a/media-libs/mutagen/mutagen-1.21.ebuild
+++ b/media-libs/mutagen/mutagen-1.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mutagen/mutagen-1.21.ebuild,v 1.2 2013/02/18 15:02:53 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mutagen/mutagen-1.21.ebuild,v 1.3 2013/02/18 15:41:24 floppym Exp $
EAPI=5
@@ -23,5 +23,11 @@ DEPEND="test? ( dev-python/eyeD3 )"
DOCS=( API-NOTES NEWS README TODO TUTORIAL )
src_test() {
- "${PYTHON:-python2.7}" setup.py test
+ # tests/test_flac.py uses temp files with a constant path.
+ # If we had multiple python implementations, we would hit a race.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
}