summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-02-08 05:49:19 +0000
committerMichael Weber <xmw@gentoo.org>2012-02-08 05:49:19 +0000
commitf676215794264a05f44eb6dfa57437d1ee5dfbd1 (patch)
treed8699f63950fdde8c7ac8f4a3e31464d11d59a4a /media-libs/oyranos
parentInitial import (diff)
downloadgentoo-2-f676215794264a05f44eb6dfa57437d1ee5dfbd1.tar.gz
gentoo-2-f676215794264a05f44eb6dfa57437d1ee5dfbd1.tar.bz2
gentoo-2-f676215794264a05f44eb6dfa57437d1ee5dfbd1.zip
Fix tests (bug 402623)
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/oyranos')
-rw-r--r--media-libs/oyranos/ChangeLog6
-rw-r--r--media-libs/oyranos/files/oyranos-0.3.2-test.patch11
-rw-r--r--media-libs/oyranos/oyranos-0.3.2.ebuild18
3 files changed, 27 insertions, 8 deletions
diff --git a/media-libs/oyranos/ChangeLog b/media-libs/oyranos/ChangeLog
index da0070eb3654..3baf004851a2 100644
--- a/media-libs/oyranos/ChangeLog
+++ b/media-libs/oyranos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/oyranos
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/oyranos/ChangeLog,v 1.1 2012/02/06 02:33:55 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/oyranos/ChangeLog,v 1.2 2012/02/08 05:49:19 xmw Exp $
+
+ 08 Feb 2012; Michael Weber <xmw@gentoo.org> oyranos-0.3.2.ebuild,
+ +files/oyranos-0.3.2-test.patch:
+ Fix tests (bug 402623)
*oyranos-0.3.2 (05 Feb 2012)
diff --git a/media-libs/oyranos/files/oyranos-0.3.2-test.patch b/media-libs/oyranos/files/oyranos-0.3.2-test.patch
new file mode 100644
index 000000000000..6e9b495a963a
--- /dev/null
+++ b/media-libs/oyranos/files/oyranos-0.3.2-test.patch
@@ -0,0 +1,11 @@
+--- oyranos-0.3.2/makefile.in
++++ oyranos-0.3.2/makefile.in
+@@ -995,7 +995,7 @@
+ echo current git version is:
+ n=0; for i in `cd $(SRCDIR); git rev-list master`; do if [ $${n} -eq 0 ]; then echo git id:$${i}; fi; n=1; done
+ echo run tests/test_oyranos
+- OY_MODULE_PATHS=. LD_LIBRARY_PATH=./:$(libdir):$${LD_LIBRARY_PATH} tests/test_oyranos
++ OY_MODULE_PATHS=. LD_LIBRARY_PATH=./:$(libdir):$${LD_LIBRARY_PATH} tests/test_oyranos "Version matching" "Internationalisation" "Elektra" "basic oyOption_s" "default oyOptions_s settings" "Profiles reading" "Registration matching" "Generic Object Observation"
+
+ examples: all
+ cd examples && ($(MAKE) clean; PATH="$(PATH):$(bindir):.." LD_LIBRARY_PATH=./:$(libdir):$${LD_LIBRARY_PATH} PKG_CONFIG_PATH="$(PKG_CONFIG_PATH):$(DESTDIR)$(libdir)/pkgconfig:.." INCLUDE="-I$(includedir) -I$(SRCDIR) -I../ -I$(SRCDIR)/$(GENDIR)" SRCDIR=$(SRCDIR)/examples/ CFLAGS="$(CFLAGS)" LIBS="-L$(libdir) -L../" intl="$(intl)" $(MAKE))
diff --git a/media-libs/oyranos/oyranos-0.3.2.ebuild b/media-libs/oyranos/oyranos-0.3.2.ebuild
index ca47e9b2f777..96e6371c7cb3 100644
--- a/media-libs/oyranos/oyranos-0.3.2.ebuild
+++ b/media-libs/oyranos/oyranos-0.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/oyranos/oyranos-0.3.2.ebuild,v 1.2 2012/02/06 05:49:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/oyranos/oyranos-0.3.2.ebuild,v 1.3 2012/02/08 05:49:19 xmw Exp $
EAPI=4
@@ -23,27 +23,31 @@ RDEPEND="app-admin/elektra
media-libs/libpng:0
media-libs/libraw
media-libs/libXcm
- X? (
- x11-libs/fltk:1
+ X? ( x11-libs/fltk:1
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/libXxf86vm
- xinerama? ( x11-libs/libXinerama )
- )"
+ xinerama? ( x11-libs/libXinerama ) )"
DEPEND="${RDEPEND}
- app-doc/doxygen"
+ app-doc/doxygen
+ test? ( media-libs/icc-profiles-basiccolor-printing2009
+ media-libs/icc-profiles-openicc )"
src_prepare() {
einfo remove bundled elektra yajl
rm -rf elektra* yajl || die
#keep bundled libXNVCtrl
- epatch "${FILESDIR}"/${P}-buildsystem.patch
+ epatch "${FILESDIR}"/${P}-buildsystem.patch \
+ "${FILESDIR}"/${P}-test.patch
if ! use X ; then
sed -e '/FLTK_GUI =/s:=.*:=:' \
-i makefile.in || die
fi
+
+ sed -e '/#include/s:alpha/oyranos_alpha.h:oyranos_alpha.h:' \
+ -i examples/libraw/oyranos_file.cpp || die
}
src_configure() {