summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-05-22 01:27:07 +0000
committerPeter Gavin <pete@gentoo.org>2001-05-22 01:27:07 +0000
commit925f1f2c04852a5bbe22312ebca1e37605b459a6 (patch)
treef613acc1f5b33fe25ab645afaacfaba3ec403121 /media-libs/sdl-net
parentAdded the --autoclean parameter (diff)
downloadgentoo-2-925f1f2c04852a5bbe22312ebca1e37605b459a6.tar.gz
gentoo-2-925f1f2c04852a5bbe22312ebca1e37605b459a6.tar.bz2
gentoo-2-925f1f2c04852a5bbe22312ebca1e37605b459a6.zip
added media-libs/libsdl-1.2.0, media-libs/sdl-mixer-1.2.0, media-libs/sdl-net-1.2.0
Diffstat (limited to 'media-libs/sdl-net')
-rw-r--r--media-libs/sdl-net/files/digest-sdl-net-1.2.01
-rw-r--r--media-libs/sdl-net/sdl-net-1.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/sdl-net/files/digest-sdl-net-1.2.0 b/media-libs/sdl-net/files/digest-sdl-net-1.2.0
new file mode 100644
index 000000000000..187cc685b8f7
--- /dev/null
+++ b/media-libs/sdl-net/files/digest-sdl-net-1.2.0
@@ -0,0 +1 @@
+MD5 c8d4452f58c457b6f3dd6ca04bf3f071 SDL_net-1.2.0.tar.gz
diff --git a/media-libs/sdl-net/sdl-net-1.2.0.ebuild b/media-libs/sdl-net/sdl-net-1.2.0.ebuild
new file mode 100644
index 000000000000..29c9a75efe1d
--- /dev/null
+++ b/media-libs/sdl-net/sdl-net-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-net/sdl-net-1.2.0.ebuild,v 1.1 2001/05/22 01:27:07 pete Exp $
+
+A=SDL_net-${PV}.tar.gz
+S=${WORKDIR}/SDL_net-${PV}
+DESCRIPTION="Simple Direct Media Layer Network Support Library"
+SRC_URI="http://www.libsdl.org/projects/SDL_net/release/${A}"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_net/index.html"
+
+DEPEND="virtual/glibc
+ >=media-libs/libsdl-1.2.0"
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ preplib /usr
+ dodoc CHANGES COPYING README
+}
+
+pkg_postinst() {
+ ldconfig -r ${ROOT}
+}
+
+
+