summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-08-31 11:51:16 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-08-31 11:51:16 +0000
commitd6c1b8ee3fa46ec0c01a98784f3e6d2828934c57 (patch)
tree2580257982417a383e55f6ab170c3bc07c4fd705 /media-libs/sdl-ttf
parentAdded fix for new java system. Thank Caster and Tichoj for fix and Jan Callew... (diff)
downloadgentoo-2-d6c1b8ee3fa46ec0c01a98784f3e6d2828934c57.tar.gz
gentoo-2-d6c1b8ee3fa46ec0c01a98784f3e6d2828934c57.tar.bz2
gentoo-2-d6c1b8ee3fa46ec0c01a98784f3e6d2828934c57.zip
Fix freetype-2.2 build problems with freetypes recommended patch thanks to foser in bug 145642
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'media-libs/sdl-ttf')
-rw-r--r--media-libs/sdl-ttf/ChangeLog7
-rw-r--r--media-libs/sdl-ttf/files/sdl-ttf-2.0.8-noftinternals.patch29
-rw-r--r--media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild14
3 files changed, 46 insertions, 4 deletions
diff --git a/media-libs/sdl-ttf/ChangeLog b/media-libs/sdl-ttf/ChangeLog
index 5920b46c9b05..df7dd2a651bf 100644
--- a/media-libs/sdl-ttf/ChangeLog
+++ b/media-libs/sdl-ttf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sdl-ttf
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/ChangeLog,v 1.27 2006/07/28 20:08:31 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/ChangeLog,v 1.28 2006/08/31 11:51:16 genstef Exp $
+
+ 31 Aug 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/sdl-ttf-2.0.8-noftinternals.patch, sdl-ttf-2.0.8.ebuild:
+ Fix freetype-2.2 build problems with freetypes recommended patch thanks to
+ foser in bug 145642
28 Jul 2006; Javier Villavicencio <the_paya@gentoo.org>
sdl-ttf-2.0.8.ebuild:
diff --git a/media-libs/sdl-ttf/files/sdl-ttf-2.0.8-noftinternals.patch b/media-libs/sdl-ttf/files/sdl-ttf-2.0.8-noftinternals.patch
new file mode 100644
index 000000000000..bc066eb31c7b
--- /dev/null
+++ b/media-libs/sdl-ttf/files/sdl-ttf-2.0.8-noftinternals.patch
@@ -0,0 +1,29 @@
+diff -ur SDL_ttf-2.0.8.orig/SDL_ttf.c SDL_ttf-2.0.8/SDL_ttf.c
+--- SDL_ttf-2.0.8.orig/SDL_ttf.c 2006-08-31 13:44:21.000000000 +0200
++++ SDL_ttf-2.0.8/SDL_ttf.c 2006-08-31 13:44:34.000000000 +0200
+@@ -43,16 +43,6 @@
+ #include FT_FREETYPE_H
+ #include FT_OUTLINE_H
+ #include FT_TRUETYPE_IDS_H
+-/*
+-#include <freetype/freetype.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
+-*/
+-#include <freetype/internal/ftobjs.h>
+-
+-#ifndef FT_OPEN_STREAM
+-#define FT_OPEN_STREAM ft_open_stream
+-#endif
+
+ #include "SDL.h"
+ #include "SDL_endian.h"
+@@ -278,7 +268,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = library->memory;
++ stream->memory = NULL; /* set by FT_Open_Face */
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;
diff --git a/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild b/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild
index 6a6f902b987b..88a12abd67bf 100644
--- a/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild
+++ b/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild,v 1.3 2006/07/28 20:08:31 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/sdl-ttf-2.0.8.ebuild,v 1.4 2006/08/31 11:51:16 genstef Exp $
+
+inherit eutils
MY_P="${P/sdl-/SDL_}"
DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
@@ -18,12 +20,18 @@ DEPEND="X? ( || ( x11-libs/libXt virtual/x11 ) )
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/sdl-ttf-2.0.8-noftinternals.patch
+}
+
src_compile() {
- econf $(use_with X x) || die
+ econf $(use_with X x) || die "econf failed"
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc CHANGES README
}