summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
commitc8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d (patch)
treede46edaa6630baa8b7d0d425cb6ddf761dd7d2c2 /media-libs/smjpeg
parent*** empty log message *** (diff)
downloadgentoo-2-c8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d.tar.gz
gentoo-2-c8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d.tar.bz2
gentoo-2-c8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d.zip
Maintainence and FHS 2.1 fixes
Added a lot of USE flags GGI support and lcms support for libmng
Diffstat (limited to 'media-libs/smjpeg')
-rw-r--r--media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild b/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..3244337ca254
--- /dev/null
+++ b/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild,v 1.1 2001/02/13 14:29:41 achim Exp $
+
+P=smjpeg-0.2.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="SDL Motion JPEG Library"
+SRC_URI="ftp://ftp.linuxgames.com/loki/open-source/smjpeg/${A}"
+HOMEPAGE="http://www.lokigames.com/development/smjpeg.php3"
+
+DEPEND=">=media-libs/libsdl-1.1.7"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc CHANGES COPYING README TODO SMJPEG.txt
+
+}
+
+