summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-30 05:09:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-30 05:09:26 +0000
commit1898b306009c6ed30489b41e9b94cd78b548e51e (patch)
tree6491399116adac47b405fb35be11b14e23bb91ff /media-libs/smpeg
parentAdd fixes from Debian for amd64 support #100109 Micha Wiernowolski. (diff)
downloadgentoo-2-1898b306009c6ed30489b41e9b94cd78b548e51e.tar.gz
gentoo-2-1898b306009c6ed30489b41e9b94cd78b548e51e.tar.bz2
gentoo-2-1898b306009c6ed30489b41e9b94cd78b548e51e.zip
keep smpeg-config output clean
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs/smpeg')
-rw-r--r--media-libs/smpeg/files/smpeg-0.4.4-config.patch18
-rw-r--r--media-libs/smpeg/smpeg-0.4.4-r5.ebuild3
2 files changed, 20 insertions, 1 deletions
diff --git a/media-libs/smpeg/files/smpeg-0.4.4-config.patch b/media-libs/smpeg/files/smpeg-0.4.4-config.patch
new file mode 100644
index 000000000000..2175276c351f
--- /dev/null
+++ b/media-libs/smpeg/files/smpeg-0.4.4-config.patch
@@ -0,0 +1,18 @@
+Only dump -L/-rpath if libdir is non-standard
+
+--- smpeg-config.in
++++ smpeg-config.in
+@@ -45,11 +45,13 @@
+ echo $includes -I@includedir@/smpeg `@SDL_CONFIG@ --cflags`
+ ;;
+ --libs)
++ if [ "@libdir@" != "/usr/lib" ]; then
+ if [ "`uname`" = "SunOS" ]; then
+ libdirs="-L@libdir@ -R@libdir@"
+ else
+ libdirs="-L@libdir@ @SMPEG_RLD_FLAGS@"
+ fi
++ fi
+ echo $libdirs -lsmpeg `@SDL_CONFIG@ --libs`
+ ;;
+ *)
diff --git a/media-libs/smpeg/smpeg-0.4.4-r5.ebuild b/media-libs/smpeg/smpeg-0.4.4-r5.ebuild
index 33e314899691..de85a162ac28 100644
--- a/media-libs/smpeg/smpeg-0.4.4-r5.ebuild
+++ b/media-libs/smpeg/smpeg-0.4.4-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.4-r5.ebuild,v 1.3 2005/07/06 22:58:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.4-r5.ebuild,v 1.4 2005/07/30 05:09:26 vapier Exp $
inherit eutils toolchain-funcs
@@ -23,6 +23,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-m4.patch
epatch "${FILESDIR}"/${P}-gnu-stack.patch
+ epatch "${FILESDIR}"/${P}-config.patch
sed -i \
-e 's:-mcpu=ev4 -Wa,-mall::' \
-e 's:-march=486::' \