summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2011-04-07 11:33:10 +0000
committerLuca Barbato <lu_zero@gentoo.org>2011-04-07 11:33:10 +0000
commitacfc83eddec7b3402969b7d7f29cba99426e9652 (patch)
treefef5e470363323873c7c6765616f8cc8253926e0 /media-libs/vo-aacenc/vo-aacenc-9999.ebuild
parent[bump] dev-perl/Authen-NTLM-1.80.0 (diff)
downloadgentoo-2-acfc83eddec7b3402969b7d7f29cba99426e9652.tar.gz
gentoo-2-acfc83eddec7b3402969b7d7f29cba99426e9652.tar.bz2
gentoo-2-acfc83eddec7b3402969b7d7f29cba99426e9652.zip
First release
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/vo-aacenc/vo-aacenc-9999.ebuild')
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/vo-aacenc/vo-aacenc-9999.ebuild b/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
new file mode 100644
index 000000000000..66fd9565a079
--- /dev/null
+++ b/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-aacenc/vo-aacenc-9999.ebuild,v 1.1 2011/04/07 11:33:10 lu_zero Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+fi
+
+inherit eutils multilib autotools ${SCM}
+
+DESCRIPTION="VisualOn AAC encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || KEYWORDS="~amd64 ~arm ~x86-fbsd ~x64-macos"
+IUSE="examples static-libs neon"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable examples example) \
+ $(use_enable neon armv7neon) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}