summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-11 18:02:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-11 18:02:17 +0000
commit3b5b476b8f33b2fb4c2a97b86516771a1bde1ab9 (patch)
tree328669a968507355292c9f2d4b40e52abd01b587 /media-libs/xine-lib
parentStable on amd64; bug 199841 (diff)
downloadgentoo-2-3b5b476b8f33b2fb4c2a97b86516771a1bde1ab9.tar.gz
gentoo-2-3b5b476b8f33b2fb4c2a97b86516771a1bde1ab9.tar.bz2
gentoo-2-3b5b476b8f33b2fb4c2a97b86516771a1bde1ab9.zip
bump for security fix bug #205197, giving two ebuilds at Diego's request, one candidate for stable without IUSE default, one for ~arch due to numerous people bitching about some defaults... bitching--
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'media-libs/xine-lib')
-rw-r--r--media-libs/xine-lib/ChangeLog11
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-1.1.9.13
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-1.1.9.1-r13
-rw-r--r--media-libs/xine-lib/xine-lib-1.1.9.1-r1.ebuild184
-rw-r--r--media-libs/xine-lib/xine-lib-1.1.9.1.ebuild182
5 files changed, 382 insertions, 1 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 9bc6a8f0369e..672b6043f13d 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.487 2008/01/06 20:11:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.488 2008/01/11 18:02:16 aballier Exp $
+
+*xine-lib-1.1.9.1-r1 (11 Jan 2008)
+*xine-lib-1.1.9.1 (11 Jan 2008)
+
+ 11 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ +xine-lib-1.1.9.1.ebuild, +xine-lib-1.1.9.1-r1.ebuild:
+ bump for security fix bug #205197, giving two ebuilds at Diego's request,
+ one candidate for stable without IUSE default, one for ~arch due to numerous
+ people bitching about some defaults... bitching--
06 Jan 2008; Diego Pettenò <flameeyes@gentoo.org>
-files/xine-lib-1.1.4-CVE-2007-1246.patch,
diff --git a/media-libs/xine-lib/files/digest-xine-lib-1.1.9.1 b/media-libs/xine-lib/files/digest-xine-lib-1.1.9.1
new file mode 100644
index 000000000000..9beb30c7bbe1
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-1.1.9.1
@@ -0,0 +1,3 @@
+MD5 3ca1e43386c01293ddc3aeaf8b5f804f xine-lib-1.1.9.1.tar.bz2 7392199
+RMD160 93e2e87002eb038b8b6a0150451d5ae37192c59d xine-lib-1.1.9.1.tar.bz2 7392199
+SHA256 024986df7f5ad973cbed18c50a2abb30ca88220b3cb6b2b09ec2db9b9498e4e7 xine-lib-1.1.9.1.tar.bz2 7392199
diff --git a/media-libs/xine-lib/files/digest-xine-lib-1.1.9.1-r1 b/media-libs/xine-lib/files/digest-xine-lib-1.1.9.1-r1
new file mode 100644
index 000000000000..9beb30c7bbe1
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-1.1.9.1-r1
@@ -0,0 +1,3 @@
+MD5 3ca1e43386c01293ddc3aeaf8b5f804f xine-lib-1.1.9.1.tar.bz2 7392199
+RMD160 93e2e87002eb038b8b6a0150451d5ae37192c59d xine-lib-1.1.9.1.tar.bz2 7392199
+SHA256 024986df7f5ad973cbed18c50a2abb30ca88220b3cb6b2b09ec2db9b9498e4e7 xine-lib-1.1.9.1.tar.bz2 7392199
diff --git a/media-libs/xine-lib/xine-lib-1.1.9.1-r1.ebuild b/media-libs/xine-lib/xine-lib-1.1.9.1-r1.ebuild
new file mode 100644
index 000000000000..e49fd4263117
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-1.1.9.1-r1.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.9.1-r1.ebuild,v 1.1 2008/01/11 18:02:16 aballier Exp $
+
+EAPI=1
+
+inherit eutils flag-o-matic toolchain-funcs libtool
+
+# This should normally be empty string, unless a release has a suffix.
+if [[ "${P/_pre/}" != "${P}" ]]; then
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+else
+ MY_PKG_SUFFIX=""
+ MY_P="${PN}-${PV/_/-}${MY_PKG_SUFFIX}"
+ S="${WORKDIR}/${MY_P}"
+
+ SRC_URI="mirror://sourceforge/xine/${MY_P}.tar.bz2"
+fi
+
+DESCRIPTION="Core libraries for Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="-aalib -libcaca -arts esd win32codecs nls +dvd +X directfb +vorbis +alsa
+gnome sdl speex +theora ipv6 altivec opengl aac -fbcon +xv xvmc
+-samba dxr3 vidix mng -flac -oss +v4l xinerama vcd +a52 +mad -imagemagick +dts
+-debug +modplug -gtk pulseaudio -mmap -truetype wavpack +musepack +xcb -jack
+-real"
+
+RDEPEND="X? ( x11-libs/libXext
+ x11-libs/libX11 )
+ xv? ( x11-libs/libXv )
+ xvmc? ( x11-libs/libXvMC )
+ xinerama? ( x11-libs/libXinerama )
+ win32codecs? ( >=media-libs/win32codecs-0.50 )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-1.2.7 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ directfb? ( >=dev-libs/DirectFB-0.9.9 )
+ gnome? ( >=gnome-base/gnome-vfs-2.0 )
+ flac? ( >=media-libs/flac-1.1.2 )
+ sdl? ( >=media-libs/libsdl-1.1.5 )
+ dxr3? ( >=media-libs/libfame-0.9.0 )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ theora? ( media-libs/libogg media-libs/libvorbis >=media-libs/libtheora-1.0_alpha6 )
+ speex? ( media-libs/libogg media-libs/libvorbis media-libs/speex )
+ libcaca? ( >=media-libs/libcaca-0.99_beta1 )
+ samba? ( net-fs/samba )
+ mng? ( media-libs/libmng )
+ vcd? ( media-video/vcdimager )
+ a52? ( >=media-libs/a52dec-0.7.4-r5 )
+ mad? ( media-libs/libmad )
+ imagemagick? ( media-gfx/imagemagick )
+ dts? ( || ( media-libs/libdca media-libs/libdts ) )
+ >=media-video/ffmpeg-0.4.9_p20070129
+ modplug? ( media-libs/libmodplug )
+ nls? ( virtual/libintl )
+ gtk? ( =x11-libs/gtk+-2* )
+ pulseaudio? ( media-sound/pulseaudio )
+ truetype? ( =media-libs/freetype-2* media-libs/fontconfig )
+ virtual/libiconv
+ wavpack? ( >=media-sound/wavpack-4.31 )
+ musepack? ( media-libs/libmpcdec )
+ xcb? ( >=x11-libs/libxcb-1.0 )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+ real? (
+ x86? ( media-libs/win32codecs )
+ x86-fbsd? ( media-libs/win32codecs )
+ amd64? ( media-libs/amd64codecs ) )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXt
+ x11-proto/xproto
+ x11-proto/videoproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto ) )
+ v4l? ( virtual/os-headers )
+ dev-util/pkgconfig
+ sys-devel/libtool
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ #prevent quicktime crashing
+ append-flags -frename-registers -ffunction-sections
+
+ # Specific workarounds for too-few-registers arch...
+ if [[ $(tc-arch) == "x86" ]]; then
+ filter-flags -fforce-addr
+ filter-flags -momit-leaf-frame-pointer # break on gcc 3.4/4.x
+ filter-flags -fno-omit-frame-pointer #breaks per bug #149704
+ is-flag -O? || append-flags -O2
+ fi
+
+ local myconf
+
+ # enable/disable appropiate optimizations on sparc
+ [[ "${PROFILE_ARCH}" == "sparc64" ]] && myconf="${myconf} --enable-vis"
+ [[ "${PROFILE_ARCH}" == "sparc" ]] && myconf="${myconf} --disable-vis"
+
+ # The default CFLAGS (-O) is the only thing working on hppa.
+ use hppa && unset CFLAGS
+
+ # Too many file names are the same (xine_decoder.c), change the builddir
+ # So that the relative path is used to identify them.
+ mkdir "${WORKDIR}/build"
+
+ elibtoolize
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable gnome gnomevfs) \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable samba) \
+ $(use_enable altivec) \
+ $(use_enable v4l) \
+ \
+ $(use_enable mng) \
+ $(use_with imagemagick) \
+ $(use_enable gtk gdkpixbuf) \
+ \
+ $(use_enable aac faad) \
+ $(use_with flac libflac) \
+ $(use_with vorbis) \
+ $(use_with speex) \
+ $(use_with theora) \
+ $(use_with wavpack) \
+ $(use_enable modplug) \
+ $(use_enable a52 a52dec) --with-external-a52dec \
+ $(use_enable mad) --with-external-libmad \
+ $(use_enable dts) --with-external-libdts \
+ $(use_enable musepack) --with-external-libmpcdec \
+ \
+ $(use_with X x) \
+ $(use_enable xinerama) \
+ $(use_enable vidix) \
+ $(use_enable dxr3) \
+ $(use_enable directfb) \
+ $(use_enable fbcon fb) \
+ $(use_enable opengl) \
+ $(use_enable aalib) \
+ $(use_with libcaca caca) \
+ $(use_with sdl) \
+ $(use_enable xvmc) \
+ $(use_with xcb) \
+ \
+ $(use_enable oss) \
+ $(use_with alsa) \
+ $(use_with arts) \
+ $(use_with esd esound) \
+ $(use_with pulseaudio) \
+ $(use_with jack) \
+ \
+ $(use_enable vcd) --without-internal-vcdlibs \
+ \
+ $(use_enable win32codecs w32dll) \
+ $(use_enable real real-codecs) \
+ \
+ $(use_enable mmap) \
+ $(use_with truetype freetype) $(use_with truetype fontconfig) \
+ \
+ $(use_enable debug) \
+ --enable-asf \
+ --with-external-ffmpeg \
+ --disable-optimizations \
+ --disable-syncfb \
+ ${myconf} \
+ --with-xv-path=/usr/$(get_libdir) \
+ --with-w32-path=/usr/$(ABI=x86 get_libdir)/win32 \
+ --with-real-codecs-path=/usr/$(get_libdir)/codecs \
+ --enable-fast-install \
+ --disable-dependency-tracking || die "econf failed."
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" htmldir="/usr/share/doc/${PF}/html" \
+ install || die "emake install failed."
+}
diff --git a/media-libs/xine-lib/xine-lib-1.1.9.1.ebuild b/media-libs/xine-lib/xine-lib-1.1.9.1.ebuild
new file mode 100644
index 000000000000..43f6ab836d0d
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-1.1.9.1.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.9.1.ebuild,v 1.1 2008/01/11 18:02:16 aballier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs libtool
+
+# This should normally be empty string, unless a release has a suffix.
+if [[ "${P/_pre/}" != "${P}" ]]; then
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+else
+ MY_PKG_SUFFIX=""
+ MY_P="${PN}-${PV/_/-}${MY_PKG_SUFFIX}"
+ S="${WORKDIR}/${MY_P}"
+
+ SRC_URI="mirror://sourceforge/xine/${MY_P}.tar.bz2"
+fi
+
+DESCRIPTION="Core libraries for Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="aalib libcaca arts esd win32codecs nls dvd X directfb vorbis alsa
+gnome sdl speex theora ipv6 altivec opengl aac fbcon xv xvmc
+samba dxr3 vidix mng flac oss v4l xinerama vcd a52 mad imagemagick dts
+debug modplug gtk pulseaudio mmap truetype wavpack musepack xcb jack
+real"
+
+RDEPEND="X? ( x11-libs/libXext
+ x11-libs/libX11 )
+ xv? ( x11-libs/libXv )
+ xvmc? ( x11-libs/libXvMC )
+ xinerama? ( x11-libs/libXinerama )
+ win32codecs? ( >=media-libs/win32codecs-0.50 )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-1.2.7 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ directfb? ( >=dev-libs/DirectFB-0.9.9 )
+ gnome? ( >=gnome-base/gnome-vfs-2.0 )
+ flac? ( >=media-libs/flac-1.1.2 )
+ sdl? ( >=media-libs/libsdl-1.1.5 )
+ dxr3? ( >=media-libs/libfame-0.9.0 )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ theora? ( media-libs/libogg media-libs/libvorbis >=media-libs/libtheora-1.0_alpha6 )
+ speex? ( media-libs/libogg media-libs/libvorbis media-libs/speex )
+ libcaca? ( >=media-libs/libcaca-0.99_beta1 )
+ samba? ( net-fs/samba )
+ mng? ( media-libs/libmng )
+ vcd? ( media-video/vcdimager )
+ a52? ( >=media-libs/a52dec-0.7.4-r5 )
+ mad? ( media-libs/libmad )
+ imagemagick? ( media-gfx/imagemagick )
+ dts? ( || ( media-libs/libdca media-libs/libdts ) )
+ >=media-video/ffmpeg-0.4.9_p20070129
+ modplug? ( media-libs/libmodplug )
+ nls? ( virtual/libintl )
+ gtk? ( =x11-libs/gtk+-2* )
+ pulseaudio? ( media-sound/pulseaudio )
+ truetype? ( =media-libs/freetype-2* media-libs/fontconfig )
+ virtual/libiconv
+ wavpack? ( >=media-sound/wavpack-4.31 )
+ musepack? ( media-libs/libmpcdec )
+ xcb? ( >=x11-libs/libxcb-1.0 )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+ real? (
+ x86? ( media-libs/win32codecs )
+ x86-fbsd? ( media-libs/win32codecs )
+ amd64? ( media-libs/amd64codecs ) )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXt
+ x11-proto/xproto
+ x11-proto/videoproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto ) )
+ v4l? ( virtual/os-headers )
+ dev-util/pkgconfig
+ sys-devel/libtool
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ #prevent quicktime crashing
+ append-flags -frename-registers -ffunction-sections
+
+ # Specific workarounds for too-few-registers arch...
+ if [[ $(tc-arch) == "x86" ]]; then
+ filter-flags -fforce-addr
+ filter-flags -momit-leaf-frame-pointer # break on gcc 3.4/4.x
+ filter-flags -fno-omit-frame-pointer #breaks per bug #149704
+ is-flag -O? || append-flags -O2
+ fi
+
+ local myconf
+
+ # enable/disable appropiate optimizations on sparc
+ [[ "${PROFILE_ARCH}" == "sparc64" ]] && myconf="${myconf} --enable-vis"
+ [[ "${PROFILE_ARCH}" == "sparc" ]] && myconf="${myconf} --disable-vis"
+
+ # The default CFLAGS (-O) is the only thing working on hppa.
+ use hppa && unset CFLAGS
+
+ # Too many file names are the same (xine_decoder.c), change the builddir
+ # So that the relative path is used to identify them.
+ mkdir "${WORKDIR}/build"
+
+ elibtoolize
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable gnome gnomevfs) \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable samba) \
+ $(use_enable altivec) \
+ $(use_enable v4l) \
+ \
+ $(use_enable mng) \
+ $(use_with imagemagick) \
+ $(use_enable gtk gdkpixbuf) \
+ \
+ $(use_enable aac faad) \
+ $(use_with flac libflac) \
+ $(use_with vorbis) \
+ $(use_with speex) \
+ $(use_with theora) \
+ $(use_with wavpack) \
+ $(use_enable modplug) \
+ $(use_enable a52 a52dec) --with-external-a52dec \
+ $(use_enable mad) --with-external-libmad \
+ $(use_enable dts) --with-external-libdts \
+ $(use_enable musepack) --with-external-libmpcdec \
+ \
+ $(use_with X x) \
+ $(use_enable xinerama) \
+ $(use_enable vidix) \
+ $(use_enable dxr3) \
+ $(use_enable directfb) \
+ $(use_enable fbcon fb) \
+ $(use_enable opengl) \
+ $(use_enable aalib) \
+ $(use_with libcaca caca) \
+ $(use_with sdl) \
+ $(use_enable xvmc) \
+ $(use_with xcb) \
+ \
+ $(use_enable oss) \
+ $(use_with alsa) \
+ $(use_with arts) \
+ $(use_with esd esound) \
+ $(use_with pulseaudio) \
+ $(use_with jack) \
+ \
+ $(use_enable vcd) --without-internal-vcdlibs \
+ \
+ $(use_enable win32codecs w32dll) \
+ $(use_enable real real-codecs) \
+ \
+ $(use_enable mmap) \
+ $(use_with truetype freetype) $(use_with truetype fontconfig) \
+ \
+ $(use_enable debug) \
+ --enable-asf \
+ --with-external-ffmpeg \
+ --disable-optimizations \
+ --disable-syncfb \
+ ${myconf} \
+ --with-xv-path=/usr/$(get_libdir) \
+ --with-w32-path=/usr/$(ABI=x86 get_libdir)/win32 \
+ --with-real-codecs-path=/usr/$(get_libdir)/codecs \
+ --enable-fast-install \
+ --disable-dependency-tracking || die "econf failed."
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" htmldir="/usr/share/doc/${PF}/html" \
+ install || die "emake install failed."
+}