summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-07 12:01:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-07 12:01:51 +0000
commit2782c135f1a99d8c542b5f97de11b34f6229495f (patch)
tree5e3092835788b93f4ee0f9a4c4e1f84e50307572 /media-libs
parentdisable parallel make (diff)
downloadgentoo-2-2782c135f1a99d8c542b5f97de11b34f6229495f.tar.gz
gentoo-2-2782c135f1a99d8c542b5f97de11b34f6229495f.tar.bz2
gentoo-2-2782c135f1a99d8c542b5f97de11b34f6229495f.zip
Version bump with huge build fixes patch as the release is broken upstream. Thanks to Ian Leonard in bug #135221 for the notice and part of the patches.
(Portage version: 2.1_rc4-r3)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libtheora/ChangeLog9
-rw-r--r--media-libs/libtheora/files/digest-libtheora-1.0_alpha63
-rw-r--r--media-libs/libtheora/files/libtheora-1.0alpha6-buildfixes.patch113
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha6.ebuild55
4 files changed, 179 insertions, 1 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index d01e39df9546..863456e7334c 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libtheora
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.38 2006/05/25 02:58:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.39 2006/06/07 12:01:51 flameeyes Exp $
+
+*libtheora-1.0_alpha6 (07 Jun 2006)
+
+ 07 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libtheora-1.0alpha6-buildfixes.patch, +libtheora-1.0_alpha6.ebuild:
+ Version bump with huge build fixes patch as the release is broken upstream.
+ Thanks to Ian Leonard in bug #135221 for the notice and part of the patches.
25 May 2006; Diego Pettenò <flameeyes@gentoo.org>
libtheora-1.0_alpha5.ebuild:
diff --git a/media-libs/libtheora/files/digest-libtheora-1.0_alpha6 b/media-libs/libtheora/files/digest-libtheora-1.0_alpha6
new file mode 100644
index 000000000000..5beb4076a158
--- /dev/null
+++ b/media-libs/libtheora/files/digest-libtheora-1.0_alpha6
@@ -0,0 +1,3 @@
+MD5 ff8d0c112fdab66930acf42c423d2536 libtheora-1.0alpha6.tar.bz2 1559318
+RMD160 b0d81dab81ec96d51e2d6a4c047beff807de6077 libtheora-1.0alpha6.tar.bz2 1559318
+SHA256 4e6044cb24d2cdb42e5d9402c709644886e8761f7b166781469ffda44240da92 libtheora-1.0alpha6.tar.bz2 1559318
diff --git a/media-libs/libtheora/files/libtheora-1.0alpha6-buildfixes.patch b/media-libs/libtheora/files/libtheora-1.0alpha6-buildfixes.patch
new file mode 100644
index 000000000000..15e90a92f698
--- /dev/null
+++ b/media-libs/libtheora/files/libtheora-1.0alpha6-buildfixes.patch
@@ -0,0 +1,113 @@
+Complete build fixes so that 1.0_alpha6 of libtheora actually _builds_.
+
+Thanks to Ian Leonard for some of the patches here merged.
+Index: libtheora-1.0alpha6/configure.ac
+===================================================================
+--- libtheora-1.0alpha6.orig/configure.ac
++++ libtheora-1.0alpha6/configure.ac
+@@ -115,12 +115,14 @@ if test "x${ac_enable_asm}" = xyes; then
+ if test ! "x$target_vendor" = "xapple"; then
+ cpu_x86_32=yes
+ cpu_optimization="32 bit x86"
++ AC_DEFINE([USE_ASM], [], [make use of asm optimization])
+ fi
+ ;;
+ x86_64)
+ cpu_x86_64=yes
+ cpu_optimization="64 bit x86"
+- ;;
++ AC_DEFINE([USE_ASM], [], [make use of asm optimization])
++ ;;
+ esac
+ else
+ cpu_optimization="disabled"
+Index: libtheora-1.0alpha6/lib/encoder_disabled.c
+===================================================================
+--- /dev/null
++++ libtheora-1.0alpha6/lib/encoder_disabled.c
+@@ -0,0 +1,51 @@
++/********************************************************************
++ * *
++ * THIS FILE IS PART OF THE OggTheora SOFTWARE CODEC SOURCE CODE. *
++ * USE, DISTRIBUTION AND REPRODUCTION OF THIS LIBRARY SOURCE IS *
++ * GOVERNED BY A BSD-STYLE SOURCE LICENSE INCLUDED WITH THIS SOURCE *
++ * IN 'COPYING'. PLEASE READ THESE TERMS BEFORE DISTRIBUTING. *
++ * *
++ * THE Theora SOURCE CODE IS COPYRIGHT (C) 2002-2003 *
++ * by the Xiph.Org Foundation http://www.xiph.org/ *
++ * *
++ ********************************************************************
++
++ function:
++ last mod: $Id: libtheora-1.0alpha6-buildfixes.patch,v 1.1 2006/06/07 12:01:51 flameeyes Exp $
++
++ ********************************************************************/
++
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
++#include "toplevel_lookup.h"
++#include "toplevel.h"
++
++int theora_encode_init(theora_state *th, theora_info *c){
++ return OC_DISABLED;
++}
++
++int theora_encode_YUVin(theora_state *t, yuv_buffer *yuv){
++ return OC_DISABLED;
++}
++
++int theora_encode_packetout( theora_state *t, int last_p, ogg_packet *op){
++ return OC_DISABLED;
++}
++
++int theora_encode_header(theora_state *t, ogg_packet *op){
++ return OC_DISABLED;
++}
++
++int theora_encode_comment(theora_comment *tc, ogg_packet *op){
++ return OC_DISABLED;
++}
++
++int theora_encode_tables(theora_state *t, ogg_packet *op){
++ return OC_DISABLED;
++}
++
++void theora_encoder_clear (CP_INSTANCE * cpi)
++{
++}
+Index: libtheora-1.0alpha6/lib/cpu.c
+===================================================================
+--- libtheora-1.0alpha6.orig/lib/cpu.c
++++ libtheora-1.0alpha6/lib/cpu.c
+@@ -26,10 +26,10 @@ cpuid(ogg_int32_t op, ogg_uint32_t *out_
+ "cpuid \n\t"
+ "movl %%ebx,%1 \n\t"
+ "popq %%rbx"
+- : "=a" (*eax),
+- "=r" (*ebx),
+- "=c" (*ecx),
+- "=d" (*edx)
++ : "=a" (*out_eax),
++ "=r" (*out_ebx),
++ "=c" (*out_ecx),
++ "=d" (*out_edx)
+ : "a" (op)
+ : "cc");
+ # elif defined(__i386__)
+@@ -37,10 +37,10 @@ cpuid(ogg_int32_t op, ogg_uint32_t *out_
+ "cpuid \n\t"
+ "movl %%ebx,%1 \n\t"
+ "popl %%ebx"
+- : "=a" (*eax),
+- "=r" (*ebx),
+- "=c" (*ecx),
+- "=d" (*edx)
++ : "=a" (*out_eax),
++ "=r" (*out_ebx),
++ "=c" (*out_ecx),
++ "=d" (*out_edx)
+ : "a" (op)
+ : "cc");
+ # elif defined(WIN32)
diff --git a/media-libs/libtheora/libtheora-1.0_alpha6.ebuild b/media-libs/libtheora/libtheora-1.0_alpha6.ebuild
new file mode 100644
index 000000000000..ba648c70a949
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.0_alpha6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha6.ebuild,v 1.1 2006/06/07 12:01:51 flameeyes Exp $
+
+inherit flag-o-matic libtool autotools
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org/"
+SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
+
+LICENSE="xiph"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="encode doc"
+
+RDEPEND=">=media-libs/libogg-1.1.0
+ encode? ( >=media-libs/libvorbis-1.0.1 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:SUBDIRS = .*:SUBDIRS = lib include doc:' Makefile.am
+
+ epatch "${FILESDIR}/${P/_/}-buildfixes.patch"
+ AT_M4DIR="m4" eautoreconf
+
+ elibtoolize
+}
+
+src_compile() {
+ # bug #75403, -O3 needs to be filtered to -O2
+ replace-flags -O3 -O2
+
+ use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
+
+ econf \
+ $(use_enable encode) \
+ --enable-shared \
+ --disable-dependency-tracking \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make \
+ DESTDIR="${D}" \
+ docdir=usr/share/doc/${PF} \
+ install || die "make install failed"
+
+ dodoc README
+}