summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-15 07:01:15 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-15 07:01:15 +0000
commit36c366261ecd9a6360661a72ac24bb6ea2dfdc47 (patch)
treed20e6291b7bd7b355ad16017a12cc2cc759dd00f /media-libs
parentSmall fix to src_install (diff)
downloadgentoo-2-36c366261ecd9a6360661a72ac24bb6ea2dfdc47.tar.gz
gentoo-2-36c366261ecd9a6360661a72ac24bb6ea2dfdc47.tar.bz2
gentoo-2-36c366261ecd9a6360661a72ac24bb6ea2dfdc47.zip
Version bump, drop old
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/clutter/ChangeLog8
-rw-r--r--media-libs/clutter/clutter-1.14.4.ebuild (renamed from media-libs/clutter/clutter-1.14.0.ebuild)61
2 files changed, 39 insertions, 30 deletions
diff --git a/media-libs/clutter/ChangeLog b/media-libs/clutter/ChangeLog
index 5368837088ad..869219222a8c 100644
--- a/media-libs/clutter/ChangeLog
+++ b/media-libs/clutter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/clutter
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.70 2013/04/17 17:18:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.71 2013/05/15 07:01:15 pacho Exp $
+
+*clutter-1.14.4 (15 May 2013)
+
+ 15 May 2013; Pacho Ramos <pacho@gentoo.org> +clutter-1.14.4.ebuild,
+ -clutter-1.14.0.ebuild:
+ Version bump, drop old
*clutter-1.14.2 (17 Apr 2013)
diff --git a/media-libs/clutter/clutter-1.14.0.ebuild b/media-libs/clutter/clutter-1.14.4.ebuild
index 3a49bb486d26..9830348c9072 100644
--- a/media-libs/clutter/clutter-1.14.0.ebuild
+++ b/media-libs/clutter/clutter-1.14.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.14.0.ebuild,v 1.1 2013/03/28 17:40:05 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.14.4.ebuild,v 1.1 2013/05/15 07:01:15 pacho Exp $
EAPI="5"
CLUTTER_LA_PUNT="yes"
@@ -39,7 +39,8 @@ RDEPEND="
>=x11-libs/libXcomposite-0.4
gtk? ( >=x11-libs/gtk+-3.3.18:3 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.6 )"
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.15
virtual/pkgconfig
@@ -55,33 +56,6 @@ DEPEND="${RDEPEND}
RESTRICT="test"
src_prepare() {
- DOCS="README NEWS ChangeLog*"
-
- # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
- # (GLX error blabla)
- # XXX: Profiling, coverage disabled for now
- # XXX: What about cex100/egl/osx/wayland/win32 backends?
- # XXX: evdev/tslib input seem to be experimental?
- G2CONF="${G2CONF} ${myconf}
- --enable-xinput
- --enable-x11-backend=yes
- --disable-profile
- --disable-maintainer-flags
- --disable-gcov
- --disable-cex100-backend
- --disable-egl-backend
- --disable-quartz-backend
- --disable-wayland-backend
- --disable-win32-backend
- --disable-tslib-input
- --disable-evdev-input
- $(usex debug --enable-debug=yes --enable-debug=minimum)
- $(use_enable gtk gdk-backend)
- $(use_enable introspection)
- $(use_enable doc docs)
- $(use_enable test conformance)
- $(use_enable test gdk-pixbuf)"
-
# We only need conformance tests, the rest are useless for us
sed -e 's/^\(SUBDIRS =\).*/\1/g' \
-i tests/Makefile.am || die "am tests sed failed"
@@ -91,6 +65,35 @@ src_prepare() {
gnome2_src_prepare
}
+src_configure() {
+ DOCS="README NEWS ChangeLog*"
+
+ # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
+ # (GLX error blabla)
+ # XXX: Profiling, coverage disabled for now
+ # XXX: What about cex100/egl/osx/wayland/win32 backends?
+ # XXX: evdev/tslib input seem to be experimental?
+ gnome2_src_configure \
+ --enable-xinput \
+ --enable-x11-backend=yes \
+ --disable-profile \
+ --disable-maintainer-flags \
+ --disable-gcov \
+ --disable-cex100-backend \
+ --disable-egl-backend \
+ --disable-quartz-backend \
+ --disable-wayland-backend \
+ --disable-win32-backend \
+ --disable-tslib-input \
+ --disable-evdev-input \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(use_enable gtk gdk-backend) \
+ $(use_enable introspection) \
+ $(use_enable doc docs) \
+ $(use_enable test conformance) \
+ $(use_enable test gdk-pixbuf)
+}
+
src_compile() {
default
if use test; then