summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-05 05:43:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-05 05:43:52 +0000
commit595fb9b2e8fca89bda71cca48dc6a618077f65bc (patch)
tree31d8563ea32769f95108de2703a1c1b698b16d5e /media-libs
parentCosmetic fixes (Manifest recommit) (diff)
downloadgentoo-2-595fb9b2e8fca89bda71cca48dc6a618077f65bc.tar.gz
gentoo-2-595fb9b2e8fca89bda71cca48dc6a618077f65bc.tar.bz2
gentoo-2-595fb9b2e8fca89bda71cca48dc6a618077f65bc.zip
old
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.2.5-r11
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.2.5-r21
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.5-xfree-4.3.patch159
-rw-r--r--media-libs/libsdl/files/libsdl_gcc33_fix.diff14
-rw-r--r--media-libs/libsdl/libsdl-1.2.5-r1.ebuild131
-rw-r--r--media-libs/libsdl/libsdl-1.2.5-r2.ebuild136
6 files changed, 0 insertions, 442 deletions
diff --git a/media-libs/libsdl/files/digest-libsdl-1.2.5-r1 b/media-libs/libsdl/files/digest-libsdl-1.2.5-r1
deleted file mode 100644
index 7f81a2ad2402..000000000000
--- a/media-libs/libsdl/files/digest-libsdl-1.2.5-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 cacacf4e4cca546de168fedc23b9b44b SDL-1.2.5.tar.gz 1854550
diff --git a/media-libs/libsdl/files/digest-libsdl-1.2.5-r2 b/media-libs/libsdl/files/digest-libsdl-1.2.5-r2
deleted file mode 100644
index 7f81a2ad2402..000000000000
--- a/media-libs/libsdl/files/digest-libsdl-1.2.5-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 cacacf4e4cca546de168fedc23b9b44b SDL-1.2.5.tar.gz 1854550
diff --git a/media-libs/libsdl/files/libsdl-1.2.5-xfree-4.3.patch b/media-libs/libsdl/files/libsdl-1.2.5-xfree-4.3.patch
deleted file mode 100644
index d571a8a7d43a..000000000000
--- a/media-libs/libsdl/files/libsdl-1.2.5-xfree-4.3.patch
+++ /dev/null
@@ -1,159 +0,0 @@
-diff -urN SDL-1.2.5.old/src/video/x11/SDL_x11modes.c SDL-1.2.5/src/video/x11/SDL_x11modes.c
---- SDL-1.2.5.old/src/video/x11/SDL_x11modes.c 2002-09-29 17:35:25.000000000 -0700
-+++ SDL-1.2.5/src/video/x11/SDL_x11modes.c 2003-04-13 22:03:43.000000000 -0700
-@@ -44,6 +44,8 @@
- #endif
-
- #define MAX(a, b) (a > b ? a : b)
-+#define V_INTERLACE 0x010
-+#define V_DBLSCAN 0x020
-
- #ifdef XFREE86_VM
- Bool SDL_NAME(XF86VidModeGetModeInfo)(Display *dpy, int scr, SDL_NAME(XF86VidModeModeInfo) *info)
-@@ -91,6 +93,77 @@
- }
- #endif
-
-+#ifdef XFREE86_VM
-+static int get_vidmode_filter(SDL_NAME(XF86VidModeModeInfo) **modes, int nmodes, char **bitmap)
-+{
-+ int i, result = 0;
-+ int use_all_modes, use_specific_mode;
-+ const char *variable;
-+ char *temp;
-+
-+ if (!nmodes)
-+ return 0;
-+
-+ temp = (char *)malloc((nmodes)*sizeof(char));
-+ if (!temp)
-+ return 0;
-+
-+ for ( i = 0; i < nmodes; ++i )
-+ temp[i] = 0;
-+
-+ variable = getenv("SDL_VIDEO_X11_USE_ALL_MODES");
-+ use_all_modes = variable ? atoi(variable) : 0;
-+ variable = getenv("SDL_VIDEO_X11_USE_SPECIFIC_MODE");
-+ use_specific_mode = variable ? atoi(variable) : 0;
-+
-+ qsort(modes, nmodes, sizeof *modes, cmpmodes);
-+
-+ if ( use_all_modes ) {
-+ for ( i = 0; i < nmodes; ++i )
-+ temp[i] = 1;
-+ result = 1;
-+/* } else if ( use_specific_mode ) { ... */
-+ } else {
-+ int previous_refresh, current_refresh;
-+ SDL_NAME(XF86VidModeModeInfo) *previous, *current;
-+
-+ previous = modes[0];
-+ previous_refresh = (int)(previous->dotclock * 1000.0 /
-+ (previous->htotal * previous->vtotal));
-+ if ( previous->flags & V_INTERLACE ) previous_refresh *= 2;
-+ else if ( previous->flags & V_DBLSCAN ) previous_refresh /= 2;
-+
-+ temp[0] = 1;
-+ for ( i = 1; i < nmodes; ++i ) {
-+ current = modes[i];
-+ current_refresh = (int)(current->dotclock * 1000.0 /
-+ (current->htotal * current->vtotal));
-+ if ( current->flags & V_INTERLACE ) current_refresh *= 2;
-+ else if ( current->flags & V_DBLSCAN ) current_refresh /= 2;
-+
-+ /* Compare this mode to the previous one */
-+ if ( current->hdisplay == previous->hdisplay &&
-+ current->vdisplay == previous->vdisplay ) {
-+ if ( current_refresh > previous_refresh ) {
-+ temp[i-1] = 0;
-+ temp[i] = 1;
-+ }
-+ else
-+ temp[i] = 0;
-+ }
-+ else
-+ temp[i] = 1;
-+
-+ previous = current;
-+ previous_refresh = current_refresh;
-+ }
-+ result = 1;
-+ }
-+ *bitmap = temp;
-+ return result;
-+}
-+#endif
-+
- static void get_real_resolution(_THIS, int* w, int* h);
-
- static void set_best_resolution(_THIS, int width, int height)
-@@ -101,10 +174,11 @@
- SDL_NAME(XF86VidModeModeInfo) **modes;
- int i;
- int nmodes;
-+ char *bitmap;
-
- if ( SDL_NAME(XF86VidModeGetModeLine)(SDL_Display, SDL_Screen, &i, &mode) &&
-- SDL_NAME(XF86VidModeGetAllModeLines)(SDL_Display,SDL_Screen,&nmodes,&modes)){
-- qsort(modes, nmodes, sizeof *modes, cmpmodes);
-+ SDL_NAME(XF86VidModeGetAllModeLines)(SDL_Display,SDL_Screen,&nmodes,&modes) &&
-+ get_vidmode_filter(modes, nmodes, &bitmap) ) {
- #ifdef XFREE86_DEBUG
- printf("Available modes:\n");
- for ( i = 0; i < nmodes; ++i ) {
-@@ -114,7 +188,8 @@
- #endif
- for ( i = nmodes-1; i > 0 ; --i ) {
- if ( (modes[i]->hdisplay >= width) &&
-- (modes[i]->vdisplay >= height) )
-+ (modes[i]->vdisplay >= height) &&
-+ (bitmap[i] == 1) )
- break;
- }
- if ( (modes[i]->hdisplay != mode.hdisplay) ||
-@@ -122,6 +197,7 @@
- SDL_NAME(XF86VidModeSwitchToMode)(SDL_Display, SDL_Screen, modes[i]);
- }
- XFree(modes);
-+ if (bitmap) free(bitmap);
- }
- }
- #endif /* XFREE86_VM */
-@@ -269,6 +345,7 @@
- int vm_major, vm_minor;
- int nmodes;
- SDL_NAME(XF86VidModeModeInfo) **modes;
-+ char *bitmap = (char*)0;
- #endif
- #ifdef HAVE_XIGXME
- int xme_major, xme_minor;
-@@ -330,15 +407,18 @@
- }
- }
- if ( ! buggy_X11 &&
-- SDL_NAME(XF86VidModeGetAllModeLines)(SDL_Display, SDL_Screen,&nmodes,&modes) ) {
-+ SDL_NAME(XF86VidModeGetAllModeLines)(SDL_Display, SDL_Screen,&nmodes,&modes) &&
-+ get_vidmode_filter(modes, nmodes, &bitmap) ) {
-
-- qsort(modes, nmodes, sizeof *modes, cmpmodes);
- SDL_modelist = (SDL_Rect **)malloc((nmodes+2)*sizeof(SDL_Rect *));
- if ( SDL_modelist ) {
- n = 0;
- for ( i=0; i<nmodes; ++i ) {
- int w, h;
-
-+ /* Exclude those vidmodes that have been filtered out */
-+ if (!bitmap[i]) continue;
-+
- /* Check to see if we should add the screen size (Xinerama) */
- w = modes[i]->hdisplay;
- h = modes[i]->vdisplay;
-@@ -371,6 +451,7 @@
- SDL_modelist[n] = NULL;
- }
- XFree(modes);
-+ if (bitmap) free(bitmap);
-
- use_vidmode = vm_major * 100 + vm_minor;
- save_mode(this);
diff --git a/media-libs/libsdl/files/libsdl_gcc33_fix.diff b/media-libs/libsdl/files/libsdl_gcc33_fix.diff
deleted file mode 100644
index 3346509de9a2..000000000000
--- a/media-libs/libsdl/files/libsdl_gcc33_fix.diff
+++ /dev/null
@@ -1,14 +0,0 @@
---- SDL-1.2.5-old/src/video/SDL_stretch.c 2002-03-06 12:23:03.000000000 +0100
-+++ SDL-1.2.5/src/video/SDL_stretch.c 2003-05-28 21:46:38.000000000 +0200
-@@ -261,9 +261,8 @@
- break;
- default:
- #ifdef __GNUC__
-- __asm__ __volatile__ ("
-- call _copy_row
-- "
-+ __asm__ __volatile__ (
-+ "call _copy_row"
- : "=&D" (u1), "=&S" (u2)
- : "0" (dstp), "1" (srcp)
- : "memory" );
diff --git a/media-libs/libsdl/libsdl-1.2.5-r1.ebuild b/media-libs/libsdl/libsdl-1.2.5-r1.ebuild
deleted file mode 100644
index b788cee6fd50..000000000000
--- a/media-libs/libsdl/libsdl-1.2.5-r1.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r1.ebuild,v 1.12 2004/03/19 07:56:04 mr_bones_ Exp $
-
-IUSE="arts xv opengl fbcon aalib nas esd X svga ggi alsa"
-
-S="${WORKDIR}/SDL-${PV}"
-DESCRIPTION="Simple Direct Media Layer"
-SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
-HOMEPAGE="http://www.libsdl.org/"
-
-SLOT="0"
-LICENSE="LGPL-2"
-KEYWORDS="x86 alpha ppc -sparc"
-
-RDEPEND=">=media-libs/audiofile-0.1.9
- X? ( virtual/x11 )
- esd? ( >=media-sound/esound-0.2.19 )
- ggi? ( >=media-libs/libggi-2.0_beta3 )
- aalib? ( media-libs/aalib )
- nas? ( media-libs/nas )
- alsa? ( media-libs/alsa-lib )
- arts? ( kde-base/arts )
- svga? ( >=media-libs/svgalib-1.4.2 )
- opengl? ( virtual/opengl )"
-# This create circular deps for the moment ...
-# directfb? ( dev-libs/DirectFB )"
-
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}/src/video/directfb
- cp SDL_DirectFB_video.c SDL_DirectFB_video.c.orig
- sed -e "s:DICAPS_ALL, ::" SDL_DirectFB_video.c.orig \
- > SDL_DirectFB_video.c
- cd ${S}
- sed -i 's:head -1:head -n 1:' configure
-}
-
-src_compile() {
- local myconf
-
- use X \
- && myconf="${myconf} --enable-video-x11" \
- || myconf="${myconf} --disable-video-x11"
-
- use xv \
- && myconf="${myconf} --enable-video-x11-xv" \
- || myconf="${myconf} --disable-video-x11-xv"
-
- use esd \
- && myconf="${myconf} --enable-esd" \
- || myconf="${myconf} --disable-esd"
-
- use ggi \
- && myconf="${myconf} --enable-video-ggi" \
- || myconf="${myconf} --disable-video-ggi"
-
- use nas \
- && myconf="${myconf} --enable-nas" \
- || myconf="${myconf} --disable-nas"
-
- use alsa \
- && myconf="${myconf} --enable-alsa" \
- || myconf="${myconf} --disable-alsa"
-
- use arts \
- && myconf="${myconf} --enable-arts" \
- || myconf="${myconf} --disable-arts"
-
- use svga \
- && myconf="${myconf} --enable-video-svga" \
- || myconf="${myconf} --disable-video-svga"
-
- use aalib \
- && myconf="${myconf} --enable-video-aalib" \
- || myconf="${myconf} --disable-video-aalib"
-
- use fbcon \
- && myconf="${myconf} --enable-video-fbcon" \
- || myconf="${myconf} --disable-video-fbcon"
-
- use opengl \
- && myconf="${myconf} --enable-video-opengl" \
- || myconf="${myconf} --disable-video-opengl"
-
- #use directfb \
- # && myconf="${myconf} --enable-video-directfb" \
- myconf="${myconf} --disable-video-directfb"
-
- use x86 \
- && myconf="${myconf} --enable-nasm" \
- || myconf="${myconf} --disable-nasm"
-
- if use nas || use alsa || use oss || use arts || use esd
- then
- myconf="${myconf} --enable-audio"
- else
- myconf="${myconf} --disable-audio"
- fi
-
- if use X || use xv || use ggi || use aalib || use svga || use fbcon || use opengl
- then
- myconf="${myconf} --enable-video-dummy"
- else
- myconf="${myconf} --disable-video"
- fi
-
- econf \
- --enable-joystick \
- --enable-cdrom \
- --enable-threads \
- --enable-timers \
- --enable-endian \
- --enable-file \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- make \
- DESTDIR=${D} \
- install || die
-
- preplib /usr
- dodoc BUGS COPYING CREDITS README* TODO WhatsNew
- dohtml -r ./
-}
diff --git a/media-libs/libsdl/libsdl-1.2.5-r2.ebuild b/media-libs/libsdl/libsdl-1.2.5-r2.ebuild
deleted file mode 100644
index 5d0a358c9d37..000000000000
--- a/media-libs/libsdl/libsdl-1.2.5-r2.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r2.ebuild,v 1.12 2004/03/30 05:24:29 spyderous Exp $
-
-IUSE="arts xv opengl fbcon aalib nas esd X svga ggi alsa"
-
-S="${WORKDIR}/SDL-${PV}"
-DESCRIPTION="Simple Direct Media Layer"
-SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
-HOMEPAGE="http://www.libsdl.org/"
-
-SLOT="0"
-LICENSE="LGPL-2"
-KEYWORDS="x86 ~alpha ~ppc -sparc hppa"
-
-RDEPEND=">=media-libs/audiofile-0.1.9
- X? ( virtual/x11 )
- esd? ( >=media-sound/esound-0.2.19 )
- ggi? ( >=media-libs/libggi-2.0_beta3 )
- aalib? ( media-libs/aalib )
- nas? ( media-libs/nas )
- alsa? ( media-libs/alsa-lib )
- arts? ( kde-base/arts )
- svga? ( >=media-libs/svgalib-1.4.2 )
- opengl? ( virtual/opengl )"
-# This creates circular deps for the moment ...
-# directfb? ( dev-libs/DirectFB )"
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4.0.5
- x86? ( dev-lang/nasm )"
-
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/libsdl_gcc33_fix.diff
- cd ${S}/src/video/directfb
-
- sed -i "s:DICAPS_ALL, ::" SDL_DirectFB_video.c
-
- # Patch to allow SDL apps to choose the BEST refresh rates for a given
- # resolution in XFree86-4.3 instead of the worst one.
- cd ${S}
- use X && epatch ${FILESDIR}/${P}-xfree-4.3.patch
- sed -i 's:head -1:head -n 1:' configure
-}
-
-src_compile() {
- local myconf
-
- use X \
- && myconf="${myconf} --enable-video-x11" \
- || myconf="${myconf} --disable-video-x11"
-
- use xv \
- && myconf="${myconf} --enable-video-x11-xv" \
- || myconf="${myconf} --disable-video-x11-xv"
-
- use esd \
- && myconf="${myconf} --enable-esd" \
- || myconf="${myconf} --disable-esd"
-
- use ggi \
- && myconf="${myconf} --enable-video-ggi" \
- || myconf="${myconf} --disable-video-ggi"
-
- use nas \
- && myconf="${myconf} --enable-nas" \
- || myconf="${myconf} --disable-nas"
-
- use alsa \
- && myconf="${myconf} --enable-alsa" \
- || myconf="${myconf} --disable-alsa"
-
- use arts \
- && myconf="${myconf} --enable-arts" \
- || myconf="${myconf} --disable-arts"
-
- use svga \
- && myconf="${myconf} --enable-video-svga" \
- || myconf="${myconf} --disable-video-svga"
-
- use aalib \
- && myconf="${myconf} --enable-video-aalib" \
- || myconf="${myconf} --disable-video-aalib"
-
- use fbcon \
- && myconf="${myconf} --enable-video-fbcon" \
- || myconf="${myconf} --disable-video-fbcon"
-
- use opengl \
- && myconf="${myconf} --enable-video-opengl" \
- || myconf="${myconf} --disable-video-opengl"
-
- #use directfb \
- # && myconf="${myconf} --enable-video-directfb" \
- myconf="${myconf} --disable-video-directfb"
-
- use x86 \
- && myconf="${myconf} --enable-nasm" \
- || myconf="${myconf} --disable-nasm"
-
- if use nas || use alsa || use oss || use arts || use esd
- then
- myconf="${myconf} --enable-audio"
- else
- myconf="${myconf} --disable-audio"
- fi
-
- if use X || use xv || use ggi || use aalib || use svga || use fbcon || use opengl
- then
- myconf="${myconf} --enable-video-dummy"
- else
- myconf="${myconf} --disable-video"
- fi
-
- econf \
- --enable-joystick \
- --enable-cdrom \
- --enable-threads \
- --enable-timers \
- --enable-endian \
- --enable-file \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- make \
- DESTDIR=${D} \
- install || die
-
- preplib /usr
- dodoc BUGS COPYING CREDITS README* TODO WhatsNew
- dohtml -r ./
-}