summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-10-04 14:18:14 +0000
committerSamuli Suominen <drac@gentoo.org>2007-10-04 14:18:14 +0000
commit7977a34bc332da57a2c71d62fcb9cd5a16f508a5 (patch)
tree58e8c5de0fef205aaf75f040aea3edb72a1cffbc /media-libs
parentfix baselayout-2 init script to use start_addon (diff)
downloadgentoo-2-7977a34bc332da57a2c71d62fcb9cd5a16f508a5.tar.gz
gentoo-2-7977a34bc332da57a2c71d62fcb9cd5a16f508a5.tar.bz2
gentoo-2-7977a34bc332da57a2c71d62fcb9cd5a16f508a5.zip
Add USE flags nls, threads and debug wrt #194566 and matching deps for them. Use emake instead of make in src_install.
(Portage version: 2.1.3.11)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libvisual/ChangeLog8
-rw-r--r--media-libs/libvisual/files/digest-libvisual-0.4.0-r13
-rw-r--r--media-libs/libvisual/libvisual-0.4.0-r1.ebuild30
3 files changed, 40 insertions, 1 deletions
diff --git a/media-libs/libvisual/ChangeLog b/media-libs/libvisual/ChangeLog
index bb22fa04736a..52beb87d0643 100644
--- a/media-libs/libvisual/ChangeLog
+++ b/media-libs/libvisual/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libvisual
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/ChangeLog,v 1.27 2007/02/07 14:46:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/ChangeLog,v 1.28 2007/10/04 14:18:13 drac Exp $
+
+*libvisual-0.4.0-r1 (04 Oct 2007)
+
+ 04 Oct 2007; Samuli Suominen <drac@gentoo.org> +libvisual-0.4.0-r1.ebuild:
+ Add USE flags nls, threads and debug wrt #194566 and matching deps for them.
+ Use emake instead of make in src_install.
07 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> libvisual-0.2.0.ebuild:
Remove static useflag, thanks to Jakub Moc in bug #165766.
diff --git a/media-libs/libvisual/files/digest-libvisual-0.4.0-r1 b/media-libs/libvisual/files/digest-libvisual-0.4.0-r1
new file mode 100644
index 000000000000..8c72a30bb246
--- /dev/null
+++ b/media-libs/libvisual/files/digest-libvisual-0.4.0-r1
@@ -0,0 +1,3 @@
+MD5 f4e78547c79ea8a8ad111cf8b85011bb libvisual-0.4.0.tar.gz 583386
+RMD160 df4fda944e84417def2817f248f587dea5b2d8f1 libvisual-0.4.0.tar.gz 583386
+SHA256 0b4dfdb87125e129567752089e3c8b54cefed601eef169d2533d8659da8dc1d7 libvisual-0.4.0.tar.gz 583386
diff --git a/media-libs/libvisual/libvisual-0.4.0-r1.ebuild b/media-libs/libvisual/libvisual-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..4f1cf7440058
--- /dev/null
+++ b/media-libs/libvisual/libvisual-0.4.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/libvisual-0.4.0-r1.ebuild,v 1.1 2007/10/04 14:18:13 drac Exp $
+
+DESCRIPTION="Libvisual is an abstraction library that comes between applications and audio visualisation plugins."
+HOMEPAGE="http://libvisual.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0.4"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug nls threads"
+
+RDEPEND="threads? ( >=dev-libs/glib-2 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --enable-static --enable-shared \
+ $(use_enable nls) \
+ $(use_enable threads) \
+ $(use_enable debug)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}