summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-25 22:38:16 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-25 22:38:16 +0000
commit7afc01fd950e2ad8fdfc639408886edc4bb95816 (patch)
treef8a403c667978abc416a1c0ecd6e7df2330849dd /media-libs
parentRemove old versions that cannot be fetched anymore. (diff)
downloadgentoo-2-7afc01fd950e2ad8fdfc639408886edc4bb95816.tar.gz
gentoo-2-7afc01fd950e2ad8fdfc639408886edc4bb95816.tar.bz2
gentoo-2-7afc01fd950e2ad8fdfc639408886edc4bb95816.zip
Convert to autotools-multilib. Acked by lu_zero, bug #455074.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/fontconfig/ChangeLog7
-rw-r--r--media-libs/fontconfig/fontconfig-2.10.2-r1.ebuild134
2 files changed, 140 insertions, 1 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index f6bff0a1c400..acd24948c786 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/fontconfig
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.164 2013/02/21 17:07:25 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.165 2013/02/25 22:38:16 mgorny Exp $
+
+*fontconfig-2.10.2-r1 (25 Feb 2013)
+
+ 25 Feb 2013; Michał Górny <mgorny@gentoo.org> +fontconfig-2.10.2-r1.ebuild:
+ Convert to autotools-multilib. Acked by lu_zero, bug #455074.
21 Feb 2013; Zac Medico <zmedico@gentoo.org> fontconfig-2.9.0.ebuild:
Fix for prefix and add ~arm-linux + ~x86-linux keywords.
diff --git a/media-libs/fontconfig/fontconfig-2.10.2-r1.ebuild b/media-libs/fontconfig/fontconfig-2.10.2-r1.ebuild
new file mode 100644
index 000000000000..f1e0eec6f0cd
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.10.2-r1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.10.2-r1.ebuild,v 1.1 2013/02/25 22:38:16 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-multilib readme.gentoo
+
+DESCRIPTION="A library for configuring and customizing font access"
+HOMEPAGE="http://fontconfig.org/"
+SRC_URI="http://fontconfig.org/release/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="doc static-libs"
+
+# Purposefully dropped the xml USE flag and libxml2 support. Expat is the
+# default and used by every distro. See bug #283191.
+
+# Note: replace emul-linux dep when expat becomes multilib-aware
+# (and add [${MULTILIB_USEDEP}] on it then!)
+RDEPEND=">=media-libs/freetype-2.2.1[${MULTILIB_USEDEP}]
+ >=dev-libs/expat-1.95.3
+ abi_x86_32? (
+ amd64? ( app-emulation/emul-linux-x86-baselibs[development] )
+ !<=app-emulation/emul-linux-x86-xlibs-20130224 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-sgml-utils[jadetex]
+ =app-text/docbook-sgml-dtd-3.1*
+ )"
+PDEPEND="app-admin/eselect-fontconfig
+ virtual/ttf-fonts"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.7.1-latin-reorder.patch # 130466
+ "${FILESDIR}"/${PN}-2.10.2-docbook.patch # 310157
+)
+
+pkg_setup() {
+ DOC_CONTENTS="Please make fontconfig configuration changes using
+ \`eselect fontconfig\`. Any changes made to /etc/fonts/fonts.conf will be
+ overwritten. If you need to reset your configuration to upstream defaults,
+ delete the directory ${ROOT}etc/fonts/conf.d/ and re-emerge fontconfig."
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc docbook)
+ # always enable docs to install manpages
+ --enable-docs
+ --localstatedir=/var
+ --with-default-fonts=/usr/share/fonts
+ --with-add-fonts=/usr/local/share/fonts
+ --with-templatedir=/etc/fonts/conf.avail
+ --with-freetype-config="$(tc-getPKG_CONFIG) freetype2"
+ )
+
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ # XXX: avoid calling this multiple times, bug #459210
+ install_others() {
+ # stuff installed from build-dir
+ autotools-utils_src_compile \
+ DESTDIR="${D}" -C doc install-man
+
+ insinto /etc/fonts
+ doins "${BUILD_DIR}"/fonts.conf
+ }
+ multilib_foreach_abi install_others
+
+ #fc-lang directory contains language coverage datafiles
+ #which are needed to test the coverage of fonts.
+ insinto /usr/share/fc-lang
+ doins fc-lang/*.orth
+
+ dodoc doc/fontconfig-user.{txt,pdf}
+
+ if [[ -e ${D}usr/share/doc/fontconfig/ ]]; then
+ mv "${D}"usr/share/doc/fontconfig/* "${D}"/usr/share/doc/${P}
+ rm -rf "${D}"usr/share/doc/fontconfig
+ fi
+
+ # Changes should be made to /etc/fonts/local.conf, and as we had
+ # too much problems with broken fonts.conf we force update it ...
+ echo 'CONFIG_PROTECT_MASK="/etc/fonts/fonts.conf"' > "${T}"/37fontconfig
+ doenvd "${T}"/37fontconfig
+
+ # As of fontconfig 2.7, everything sticks their noses in here.
+ dodir /etc/sandbox.d
+ echo 'SANDBOX_PREDICT="/var/cache/fontconfig"' > "${D}"/etc/sandbox.d/37fontconfig
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ # Bug #193476
+ # /etc/fonts/conf.d/ contains symlinks to ../conf.avail/ to include various
+ # config files. If we install as-is, we'll blow away user settings.
+ ebegin "Syncing fontconfig configuration to system"
+ if [[ -e ${ROOT}/etc/fonts/conf.d ]]; then
+ for file in "${ROOT}"/etc/fonts/conf.avail/*; do
+ f=${file##*/}
+ if [[ -L ${ROOT}/etc/fonts/conf.d/${f} ]]; then
+ [[ -f ${D}etc/fonts/conf.avail/${f} ]] \
+ && ln -sf ../conf.avail/"${f}" "${D}"etc/fonts/conf.d/ &>/dev/null
+ else
+ [[ -f ${D}etc/fonts/conf.avail/${f} ]] \
+ && rm "${D}"etc/fonts/conf.d/"${f}" &>/dev/null
+ fi
+ done
+ fi
+ eend $?
+}
+
+pkg_postinst() {
+ einfo "Cleaning broken symlinks in "${ROOT}"etc/fonts/conf.d/"
+ find -L "${ROOT}"etc/fonts/conf.d/ -type l -delete
+
+ readme.gentoo_print_elog
+
+ if [[ ${ROOT} = / ]]; then
+ ebegin "Creating global font cache"
+ /usr/bin/fc-cache -srf
+ eend $?
+ fi
+}