summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-11-19 05:31:11 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-11-19 05:31:11 +0000
commit802faf88bc669b0201082caadf50fcc3e11520b8 (patch)
tree3fd675f36ec46398fc0f6ba77474f9d42cc127cf /media-libs
parentBump -5.11 development version (diff)
downloadgentoo-2-802faf88bc669b0201082caadf50fcc3e11520b8.tar.gz
gentoo-2-802faf88bc669b0201082caadf50fcc3e11520b8.tar.bz2
gentoo-2-802faf88bc669b0201082caadf50fcc3e11520b8.zip
Bump to current upstream release. Ebuild now adds gobject-introspection and Orc support controller by USE-flags. Highlights of this release:
Use of Orc to completely replace liboil Number of ffmpegcolorspace enhancements and fixes Other fixes and enhancements (Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-base/ChangeLog12
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.30.ebuild55
-rw-r--r--media-libs/gst-plugins-base/metadata.xml6
3 files changed, 72 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-base/ChangeLog b/media-libs/gst-plugins-base/ChangeLog
index 3c538c46e1e8..6a444ab51186 100644
--- a/media-libs/gst-plugins-base/ChangeLog
+++ b/media-libs/gst-plugins-base/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-libs/gst-plugins-base
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.146 2010/09/23 16:31:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.147 2010/11/19 05:31:11 ford_prefect Exp $
+
+*gst-plugins-base-0.10.30 (19 Nov 2010)
+
+ 19 Nov 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +gst-plugins-base-0.10.30.ebuild, metadata.xml:
+ Bump to current upstream release. Ebuild now adds gobject-introspection
+ and Orc support controller by USE-flags. Highlights of this release:
+ Use of Orc to completely replace liboil
+ Number of ffmpegcolorspace enhancements and fixes
+ Other fixes and enhancements
23 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
gst-plugins-base-0.10.29.ebuild,
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.30.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.30.ebuild
new file mode 100644
index 000000000000..99c93294f2fd
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.30.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.30.ebuild,v 1.1 2010/11/19 05:31:11 ford_prefect Exp $
+
+EAPI=1
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-base gst-plugins10 gnome2 flag-o-matic autotools eutils
+# libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="introspection nls +orc"
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=media-libs/gstreamer-0.10.29
+ dev-libs/libxml2
+ app-text/iso-codes
+ orc? ( >=dev-lang/orc-0.4.5 )
+ !<media-libs/gst-plugins-bad-0.10.10"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.11.5 )
+ dev-util/pkgconfig
+ dev-util/gtk-doc-am"
+
+GST_PLUGINS_BUILD=""
+
+DOCS="AUTHORS NEWS README RELEASE"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.10.29-make-382.patch
+ eautoreconf
+}
+
+src_compile() {
+ # gst doesnt handle opts well, last tested with 0.10.15
+ strip-flags
+ replace-flags "-O3" "-O2"
+
+ gst-plugins-base_src_configure \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable orc)
+ emake || die "emake failed."
+}
+
+src_install() {
+ gnome2_src_install
+}
diff --git a/media-libs/gst-plugins-base/metadata.xml b/media-libs/gst-plugins-base/metadata.xml
index 6cb5dfb547c2..9da75892a141 100644
--- a/media-libs/gst-plugins-base/metadata.xml
+++ b/media-libs/gst-plugins-base/metadata.xml
@@ -3,4 +3,10 @@
<pkgmetadata>
<herd>gstreamer</herd>
<herd>gnome</herd>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ <flag name="orc">Use <pkg>dev-lang/orc</pkg> for runtime
+ optimisations</flag>
+ </use>
</pkgmetadata>