summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-12 13:04:33 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-12 13:04:33 +0000
commit86ef65957a906bfa2cd3efb8f2ed9b04e4a299b8 (patch)
treeb3a8269312e294311908235b436e4ada9f7735f0 /media-libs
parentVersion bump. (diff)
downloadgentoo-2-86ef65957a906bfa2cd3efb8f2ed9b04e4a299b8.tar.gz
gentoo-2-86ef65957a906bfa2cd3efb8f2ed9b04e4a299b8.tar.bz2
gentoo-2-86ef65957a906bfa2cd3efb8f2ed9b04e4a299b8.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/opengtl/ChangeLog7
-rw-r--r--media-libs/opengtl/opengtl-0.9.15.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/media-libs/opengtl/ChangeLog b/media-libs/opengtl/ChangeLog
index a4f5d1bb2f6a..5fd03a690e95 100644
--- a/media-libs/opengtl/ChangeLog
+++ b/media-libs/opengtl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/opengtl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/ChangeLog,v 1.2 2012/01/11 18:51:42 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/ChangeLog,v 1.3 2012/01/12 13:04:33 johu Exp $
+
+*opengtl-0.9.15.2 (12 Jan 2012)
+
+ 12 Jan 2012; Johannes Huber <johu@gentoo.org> +opengtl-0.9.15.2.ebuild:
+ Version bump.
11 Jan 2012; Johannes Huber <johu@gentoo.org> opengtl-0.9.15.1.ebuild:
Fix dep on llvm, bug #398263.
diff --git a/media-libs/opengtl/opengtl-0.9.15.2.ebuild b/media-libs/opengtl/opengtl-0.9.15.2.ebuild
new file mode 100644
index 000000000000..8de3a2e71a8f
--- /dev/null
+++ b/media-libs/opengtl/opengtl-0.9.15.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/opengtl-0.9.15.2.ebuild,v 1.1 2012/01/12 13:04:33 johu Exp $
+
+EAPI=4
+
+MY_P="OpenGTL-${PV}"
+
+inherit cmake-utils
+
+DESCRIPTION="Collection of libraries for graphics transformation algorithms"
+HOMEPAGE="http://opengtl.org/"
+SRC_URI="http://download.opengtl.org/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+RDEPEND="
+ media-libs/libpng
+ <sys-devel/llvm-3.0
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/lcov )
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use debug OPENGTL_ENABLE_DEBUG_OUTPUT)
+ $(cmake-utils_use test OPENGTL_BUILD_TESTS)
+ $(cmake-utils_use test OPENGTL_CODE_COVERAGE)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newdoc OpenShiva/doc/reference/region.pdf OpenShiva.pdf
+}