summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2014-01-26 03:24:22 +0000
committerMatt Turner <mattst88@gentoo.org>2014-01-26 03:24:22 +0000
commit8f6225ea025733b3937cc125b3b45c2e2eea6cef (patch)
tree407b86168424809e0f27580b3a8522a11881dc7e /media-libs
parentUpdate maintainers (add ahamilto as maintainer, me as proxy, proxy-maint herd... (diff)
downloadgentoo-2-8f6225ea025733b3937cc125b3b45c2e2eea6cef.tar.gz
gentoo-2-8f6225ea025733b3937cc125b3b45c2e2eea6cef.tar.bz2
gentoo-2-8f6225ea025733b3937cc125b3b45c2e2eea6cef.zip
Update glxext.h for bug #491644.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog9
-rw-r--r--media-libs/mesa/files/mesa-10.0.2-update-glxext.h.patch63
-rw-r--r--media-libs/mesa/mesa-10.0.2-r1.ebuild (renamed from media-libs/mesa/mesa-10.0.2.ebuild)5
3 files changed, 75 insertions, 2 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 87ac38e32f27..ae6f9eb60557 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.529 2014/01/26 02:14:37 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.530 2014/01/26 03:24:22 mattst88 Exp $
+
+*mesa-10.0.2-r1 (26 Jan 2014)
+
+ 26 Jan 2014; Matt Turner <mattst88@gentoo.org>
+ +files/mesa-10.0.2-update-glxext.h.patch, +mesa-10.0.2-r1.ebuild,
+ -mesa-10.0.2.ebuild:
+ Update glxext.h for bug #491644.
26 Jan 2014; Matt Turner <mattst88@gentoo.org> mesa-10.0.2.ebuild,
mesa-9.2.5.ebuild:
diff --git a/media-libs/mesa/files/mesa-10.0.2-update-glxext.h.patch b/media-libs/mesa/files/mesa-10.0.2-update-glxext.h.patch
new file mode 100644
index 000000000000..0cbaf9572924
--- /dev/null
+++ b/media-libs/mesa/files/mesa-10.0.2-update-glxext.h.patch
@@ -0,0 +1,63 @@
+From faa518dd947f35bca46dcc59493d3fbecf376d39 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Sat, 25 Jan 2014 19:16:38 -0800
+Subject: [PATCH] glx: Update glxext.h to revision 24777.
+
+It readds the GLXContextID typedef, but under #ifndef GLX_VERSION_1_3.
+
+Bugzilla: https://cvs.khronos.org/bugzilla/show_bug.cgi?id=11454
+---
+ include/GL/glxext.h | 14 +++++++++++---
+ 1 file changed, 11 insertions(+), 3 deletions(-)
+
+diff --git a/include/GL/glxext.h b/include/GL/glxext.h
+index cfabe8c..8c642f3 100644
+--- a/include/GL/glxext.h
++++ b/include/GL/glxext.h
+@@ -33,10 +33,10 @@ extern "C" {
+ ** used to make the header, and the header can be found at
+ ** http://www.opengl.org/registry/
+ **
+-** Khronos $Revision: 1.1 $ on $Date: 2014/01/26 03:24:22 $
++** Khronos $Revision: 1.1 $ on $Date: 2014/01/26 03:24:22 $
+ */
+
+-#define GLX_GLXEXT_VERSION 20131008
++#define GLX_GLXEXT_VERSION 20140114
+
+ /* Generated C header for:
+ * API: glx
+@@ -49,6 +49,7 @@ extern "C" {
+
+ #ifndef GLX_VERSION_1_3
+ #define GLX_VERSION_1_3 1
++typedef XID GLXContextID;
+ typedef struct __GLXFBConfigRec *GLXFBConfig;
+ typedef XID GLXWindow;
+ typedef XID GLXPbuffer;
+@@ -272,7 +273,6 @@ __GLXextFuncPtr glXGetProcAddressARB (const GLubyte *procName);
+
+ #ifndef GLX_EXT_import_context
+ #define GLX_EXT_import_context 1
+-typedef XID GLXContextID;
+ #define GLX_SHARE_CONTEXT_EXT 0x800A
+ #define GLX_VISUAL_ID_EXT 0x800B
+ #define GLX_SCREEN_EXT 0x800C
+@@ -433,6 +433,14 @@ void glXCopyImageSubDataNV (Display *dpy, GLXContext srcCtx, GLuint srcName, GLe
+ #endif
+ #endif /* GLX_NV_copy_image */
+
++#ifndef GLX_NV_delay_before_swap
++#define GLX_NV_delay_before_swap 1
++typedef Bool ( *PFNGLXDELAYBEFORESWAPNVPROC) (Display *dpy, GLXDrawable drawable, GLfloat seconds);
++#ifdef GLX_GLXEXT_PROTOTYPES
++Bool glXDelayBeforeSwapNV (Display *dpy, GLXDrawable drawable, GLfloat seconds);
++#endif
++#endif /* GLX_NV_delay_before_swap */
++
+ #ifndef GLX_NV_float_buffer
+ #define GLX_NV_float_buffer 1
+ #define GLX_FLOAT_COMPONENTS_NV 0x20B0
+--
+1.8.3.2
+
diff --git a/media-libs/mesa/mesa-10.0.2.ebuild b/media-libs/mesa/mesa-10.0.2-r1.ebuild
index e63303a1a56e..11a49a216ba9 100644
--- a/media-libs/mesa/mesa-10.0.2.ebuild
+++ b/media-libs/mesa/mesa-10.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-10.0.2.ebuild,v 1.3 2014/01/26 02:14:36 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-10.0.2-r1.ebuild,v 1.1 2014/01/26 03:24:22 mattst88 Exp $
EAPI=5
@@ -179,6 +179,9 @@ src_prepare() {
epatch
fi
+ # Bug 491644
+ epatch "${FILESDIR}"/mesa-10.0.2-update-glxext.h.patch
+
# relax the requirement that r300 must have llvm, bug 380303
epatch "${FILESDIR}"/mesa-9.2-dont-require-llvm-for-r300.patch