summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-01 06:31:06 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-01 06:31:06 +0000
commit913ff10ca0554e9286b9bf75077186d93ba74488 (patch)
treeb5d484e5185532eb5fe8cb887201bc5d7e80438d /media-libs
parentarm stable, bug #379569 (diff)
downloadgentoo-2-913ff10ca0554e9286b9bf75077186d93ba74488.tar.gz
gentoo-2-913ff10ca0554e9286b9bf75077186d93ba74488.tar.bz2
gentoo-2-913ff10ca0554e9286b9bf75077186d93ba74488.zip
Bump. Build system changes only. DISABLE_DEPRECATED flags were removed by upstream. Do not set PYTHON_DEPEND, it makes python into a runtime dependency.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/clutter-gst/ChangeLog10
-rw-r--r--media-libs/clutter-gst/clutter-gst-1.4.4.ebuild44
2 files changed, 53 insertions, 1 deletions
diff --git a/media-libs/clutter-gst/ChangeLog b/media-libs/clutter-gst/ChangeLog
index ce09c17b2054..efa2812118c3 100644
--- a/media-libs/clutter-gst/ChangeLog
+++ b/media-libs/clutter-gst/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/clutter-gst
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/ChangeLog,v 1.17 2011/10/15 22:59:07 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/ChangeLog,v 1.18 2011/11/01 06:31:05 tetromino Exp $
+
+*clutter-gst-1.4.4 (01 Nov 2011)
+
+ 01 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +clutter-gst-1.4.4.ebuild:
+ Bump. Build system changes only. DISABLE_DEPRECATED flags were removed by
+ upstream. Do not set PYTHON_DEPEND, it makes python into a runtime
+ dependency.
*clutter-gst-1.4.2 (15 Oct 2011)
diff --git a/media-libs/clutter-gst/clutter-gst-1.4.4.ebuild b/media-libs/clutter-gst/clutter-gst-1.4.4.ebuild
new file mode 100644
index 000000000000..422f1bec77a4
--- /dev/null
+++ b/media-libs/clutter-gst/clutter-gst-1.4.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/clutter-gst-1.4.4.ebuild,v 1.1 2011/11/01 06:31:06 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+CLUTTER_LA_PUNT="yes"
+
+# inherit clutter after gnome2 so that defaults aren't overriden
+# inherit gnome.org in the end so we use gnome mirrors and get the xz tarball
+# no PYTHON_DEPEND, python2 is just a build-time dependency
+inherit python gnome2 clutter gnome.org
+
+DESCRIPTION="GStreamer Integration library for Clutter"
+
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.20:2
+ >=media-libs/clutter-1.4.0:1.0[introspection?]
+ >=media-libs/gstreamer-0.10.26:0.10[introspection?]
+ media-libs/gst-plugins-base:0.10[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.8 )"
+DEPEND="${RDEPEND}
+ =dev-lang/python-2*
+ doc? ( >=dev-util/gtk-doc-1.8 )"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README"
+ EXAMPLES="examples/{*.c,*.png,README}"
+ G2CONF="${G2CONF}
+ $(use_enable introspection)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_compile() {
+ # Clutter tries to access dri without userpriv, upstream bug #661873
+ # Massive failure of a hack, see bug 360219, bug 360073, bug 363917
+ DISPLAY="999invalid" emake
+}