summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-14 18:52:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-14 18:52:53 +0000
commitb2729e46e40819929715e93b1c281e9e7a53c5ae (patch)
tree811dbdd4cccb3582834bbf0e6d714c071c7c9de0 /media-libs
parentVersion bump (diff)
downloadgentoo-2-b2729e46e40819929715e93b1c281e9e7a53c5ae.tar.gz
gentoo-2-b2729e46e40819929715e93b1c281e9e7a53c5ae.tar.bz2
gentoo-2-b2729e46e40819929715e93b1c281e9e7a53c5ae.zip
removed older ebuilds
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/t1lib/t1lib-1.3.ebuild33
1 files changed, 17 insertions, 16 deletions
diff --git a/media-libs/t1lib/t1lib-1.3.ebuild b/media-libs/t1lib/t1lib-1.3.ebuild
index 6887ba13ae59..0cf3f2b502de 100644
--- a/media-libs/t1lib/t1lib-1.3.ebuild
+++ b/media-libs/t1lib/t1lib-1.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/t1lib/t1lib-1.3.ebuild,v 1.1 2001/10/29 02:49:10 lordjoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/t1lib/t1lib-1.3.ebuild,v 1.2 2002/04/14 18:52:53 seemant Exp $
S=${WORKDIR}/T1Lib-${PV}
DESCRIPTION="A Type 1 Rasterizer Library for UNIX/X11"
@@ -15,21 +15,22 @@ DEPEND="virtual/glibc
src_compile() {
local myconf
- if [ "`use X`" ]
- then
- myconf="--with-x"
- else
- myconf="--without-x"
- fi
-
- ./configure --host=${CHOST} --prefix=/usr --datadir=/etc ${myconf} || die
-
- if [ "`use tetex`" ]
- then
- emake || die
- else
- emake without_doc || die
- fi
+ local myopt
+
+ use X \
+ && myconf="--with-x" \
+ || myconf="--without-x"
+
+ use tetex \
+ && myopt="without_doc"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --datadir=/etc \
+ ${myconf} || die
+
+ emake ${myopt} || die
}
src_install() {