summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-06-25 05:07:50 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-06-25 05:07:50 +0000
commitd8f9b7ed78d85ea2a047e3441a1504ffc15d9332 (patch)
tree9c4b411c4191381f800246335dd4c4a04365ce75 /media-libs
parentFix broken Manifest entry for ChangeLog. (diff)
downloadgentoo-2-d8f9b7ed78d85ea2a047e3441a1504ffc15d9332.tar.gz
gentoo-2-d8f9b7ed78d85ea2a047e3441a1504ffc15d9332.tar.bz2
gentoo-2-d8f9b7ed78d85ea2a047e3441a1504ffc15d9332.zip
Version bump with a few bugfixes. No longer uses gconf, meaning that gnome-settings-daemon-2.x will no longer automatically load the canberra gtk modules. Install devhelp docs in /usr/share/gtk-doc where devhelp expects to find them.
(Portage version: 2.2.0_alpha112/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libcanberra/ChangeLog11
-rw-r--r--media-libs/libcanberra/libcanberra-0.29.ebuild73
2 files changed, 83 insertions, 1 deletions
diff --git a/media-libs/libcanberra/ChangeLog b/media-libs/libcanberra/ChangeLog
index 1c12f2f8da8b..105a3e69e7a7 100644
--- a/media-libs/libcanberra/ChangeLog
+++ b/media-libs/libcanberra/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/libcanberra
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcanberra/ChangeLog,v 1.82 2012/06/02 12:21:29 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcanberra/ChangeLog,v 1.83 2012/06/25 05:07:50 tetromino Exp $
+
+*libcanberra-0.29 (25 Jun 2012)
+
+ 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libcanberra-0.29.ebuild:
+ Version bump with a few bugfixes. No longer uses gconf, meaning that
+ gnome-settings-daemon-2.x will no longer automatically load the canberra gtk
+ modules. Install devhelp docs in /usr/share/gtk-doc where devhelp expects to
+ find them.
02 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
libcanberra-0.28-r5.ebuild:
diff --git a/media-libs/libcanberra/libcanberra-0.29.ebuild b/media-libs/libcanberra/libcanberra-0.29.ebuild
new file mode 100644
index 000000000000..020eb404baf3
--- /dev/null
+++ b/media-libs/libcanberra/libcanberra-0.29.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcanberra/libcanberra-0.29.ebuild,v 1.1 2012/06/25 05:07:50 tetromino Exp $
+
+EAPI="4"
+
+inherit libtool systemd autotools eutils
+
+DESCRIPTION="Portable Sound Event Library"
+HOMEPAGE="http://0pointer.de/lennart/projects/libcanberra/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="alsa gnome gstreamer +gtk +gtk3 oss pulseaudio +sound tdb udev"
+
+COMMON_DEPEND="media-libs/libvorbis
+ >=sys-devel/libtool-2.2.6b
+ alsa? (
+ media-libs/alsa-lib
+ udev? ( >=sys-fs/udev-160 ) )
+ gstreamer? ( >=media-libs/gstreamer-0.10.15 )
+ gtk? ( >=x11-libs/gtk+-2.20.0:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
+ tdb? ( sys-libs/tdb )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+ sound? ( x11-themes/sound-theme-freedesktop )" # Required for index.theme wrt #323379
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+REQUIRED_USE="udev? ( alsa )"
+
+src_prepare() {
+ # https://bugs.freedesktop.org/show_bug.cgi?id=31454
+ epatch "${FILESDIR}"/${PN}-0.28-underlinking.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-dependency-tracking \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable gstreamer) \
+ $(use_enable gtk) \
+ $(use_enable gtk3) \
+ $(use_enable tdb) \
+ $(use_enable udev) \
+ $(systemd_with_unitdir) \
+ --disable-lynx \
+ --disable-gtk-doc
+}
+
+src_install() {
+ # Disable parallel installation until bug #253862 is solved
+ emake -j1 DESTDIR="${D}" install
+
+ # Remove useless .la files:
+ # libcanberra uses lt_dlopenext instead of ld_dlopen to load the modules,
+ # which means that it will first try appending ".la" to the given filename
+ # prefix; if that fails, it will append the module extension for the
+ # current system and try that (".so" on Linux, ".bundle" on Darwin, ".dll"
+ # on Windows, etc.). Only if both fail will it return an error.
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+}