summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-01-13 19:59:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-01-13 19:59:08 +0000
commited28143286f536be733b48a84dcb7404db2ed33d (patch)
treeb1623a1fa5144d1ffcf82cf78d1f3dd4883f4fa9 /media-libs
parentversion bump, bug #446724 by Jacques-Pascal Deplaix (diff)
downloadgentoo-2-ed28143286f536be733b48a84dcb7404db2ed33d.tar.gz
gentoo-2-ed28143286f536be733b48a84dcb7404db2ed33d.tar.bz2
gentoo-2-ed28143286f536be733b48a84dcb7404db2ed33d.zip
Version bump, bug #451662.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gstreamer/ChangeLog9
-rw-r--r--media-libs/gstreamer/gstreamer-1.0.5.ebuild68
2 files changed, 75 insertions, 2 deletions
diff --git a/media-libs/gstreamer/ChangeLog b/media-libs/gstreamer/ChangeLog
index f8031fa06608..ee610f938180 100644
--- a/media-libs/gstreamer/ChangeLog
+++ b/media-libs/gstreamer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gstreamer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.316 2012/12/20 03:34:02 tetromino Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.317 2013/01/13 19:59:08 eva Exp $
+
+*gstreamer-1.0.5 (13 Jan 2013)
+
+ 13 Jan 2013; Gilles Dartiguelongue <eva@gentoo.org> +gstreamer-1.0.5.ebuild:
+ Version bump, bug #451662.
20 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org> metadata.xml:
Switch to global introspection USE flag.
diff --git a/media-libs/gstreamer/gstreamer-1.0.5.ebuild b/media-libs/gstreamer/gstreamer-1.0.5.ebuild
new file mode 100644
index 000000000000..bc285bdcda33
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.0.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/gstreamer-1.0.5.ebuild,v 1.1 2013/01/13 19:59:08 eva Exp $
+
+EAPI="5"
+
+inherit eutils multilib pax-utils
+
+DESCRIPTION="Streaming media framework"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+introspection nls +orc test"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/gtk-doc-am-1.12
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+# gtk-doc-am to install API docs
+
+src_configure() {
+ if [[ ${CHOST} == *-interix* ]] ; then
+ export ac_cv_lib_dl_dladdr=no
+ export ac_cv_func_poll=no
+ fi
+ if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
+ # GCC groks this, but then refers to an implementation (___multi3,
+ # ___udivti3) that don't exist (at least I can't find it), so force
+ # this one to be off, such that we use 2x64bit emulation code.
+ export gst_cv_uint128_t=no
+ fi
+
+ # Disable static archives, dependency tracking and examples
+ # to speed up build time
+ # Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
+ econf \
+ --disable-debug \
+ --disable-examples \
+ --disable-static \
+ --disable-valgrind \
+ --enable-check \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable test tests) \
+ --with-package-name="GStreamer ebuild for Gentoo" \
+ --with-package-origin="http://packages.gentoo.org/package/media-libs/gstreamer"
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
+ default
+ prune_libtool_files
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}" \
+ "${ED}usr/libexec/gstreamer-${SLOT}/gst-plugin-scanner"
+}