summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-28 23:17:59 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-28 23:17:59 +0000
commitf0821312e8e1a2bdd5bda65df57ecff16ec848bb (patch)
tree8c78daa558ea981367202a3b3ef5cdf89385a117 /media-libs
parentversion bump (bug #90761) (diff)
downloadgentoo-2-f0821312e8e1a2bdd5bda65df57ecff16ec848bb.tar.gz
gentoo-2-f0821312e8e1a2bdd5bda65df57ecff16ec848bb.tar.bz2
gentoo-2-f0821312e8e1a2bdd5bda65df57ecff16ec848bb.zip
fix m4 warning and make it so we dont need to run autotools
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/aalib/aalib-1.4_rc4-r2.ebuild41
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch (renamed from media-libs/aalib/files/aalib-1.4_rc4-gentoo.diff)32
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc4-m4.patch9
3 files changed, 37 insertions, 45 deletions
diff --git a/media-libs/aalib/aalib-1.4_rc4-r2.ebuild b/media-libs/aalib/aalib-1.4_rc4-r2.ebuild
index c8a63d7d65eb..e6cb1aad51d7 100644
--- a/media-libs/aalib/aalib-1.4_rc4-r2.ebuild
+++ b/media-libs/aalib/aalib-1.4_rc4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/aalib/aalib-1.4_rc4-r2.ebuild,v 1.28 2005/04/09 22:00:32 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aalib/aalib-1.4_rc4-r2.ebuild,v 1.29 2005/04/28 23:17:59 vapier Exp $
inherit eutils libtool
@@ -13,48 +13,35 @@ SRC_URI="mirror://sourceforge/aa-project/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86 ~ppc-macos"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~ppc-macos s390 sparc x86"
IUSE="X slang gpm static"
-RDEPEND=">=sys-libs/ncurses-5.1
+DEPEND=">=sys-libs/ncurses-5.1
X? ( virtual/x11 )
gpm? ( sys-libs/gpm )
slang? ( >=sys-libs/slang-1.4.2 )"
-DEPEND="${RDEPEND}
- !ppc-macos? (>=sys-devel/autoconf-2.58)
- >=sys-devel/automake-1.4"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-gentoo.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-m4.patch
if use ppc-macos; then
- cd ${S}/src
- epatch ${FILESDIR}/${PN}-osx.patch
+ cd src
+ epatch "${FILESDIR}"/${PN}-osx.patch
fi
-
- elibtoolize
-
- touch *
}
src_compile() {
- # We need autoconf-2.5 and automake-1.4
- export WANT_AUTOCONF=2.5
- export WANT_AUTOMAKE=1.4
-
- econf `use_with slang slang-driver` \
- `use_with X x11-driver` \
- `use_enable static`
-
- if use ppc-macos; then
- cd ${S}
- sed -i -e 's:$(AUTOMAKE) --foreign --include-deps:$(AUTOMAKE) --foreign --include-deps -a -c -f:' src/Makefile
- fi
-
+ econf \
+ $(use_with slang slang-driver) \
+ $(use_with X x11-driver) \
+ $(use_enable static) \
+ || die
emake || die
}
src_install() {
make DESTDIR="${D}" install || die
- dodoc ANNOUNCE AUTHORS ChangeLog COPYING NEWS README*
+ dodoc ANNOUNCE AUTHORS ChangeLog NEWS README*
}
diff --git a/media-libs/aalib/files/aalib-1.4_rc4-gentoo.diff b/media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch
index 416f3d78d8a9..4eb4a391a5be 100644
--- a/media-libs/aalib/files/aalib-1.4_rc4-gentoo.diff
+++ b/media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch
@@ -1,21 +1,17 @@
---- aalib-1.4.0/configure.in~ Tue Apr 24 16:00:02 2001
-+++ aalib-1.4.0/configure.in Sun May 6 20:37:32 2001
-@@ -83,10 +83,10 @@
- fi
- ])
- AC_ARG_WITH(gpm-mouse,
-- [ --with-gpm-mouse=base-dir Specifies the base gpm directory],
-- if test x$withval = xyes
-+ [ --with-gpm-mouse=base-dir/no Specifies the base gpm directory],
-+ if test x$withval = xno
- then
-- AC_MSG_WARN(Usage is: --with-gpm-mouse=base-dir)
-+ gpm_mousedriver_test=no
- else
- LIBS="$LIBS -L$withval/lib -lgpm"
- AC_DEFINE(GPM_MOUSEDRIVER)
---- aalib-1.4.0/configure.orig Sun May 6 20:38:23 2001
-+++ aalib-1.4.0/configure Sun May 6 20:38:26 2001
+Fix --with-gpm-mouse usage to not be so freaky. Don't patch
+configure.in that way we avoid having to run autotools.
+
+ AC_ARG_WITH(gpm-mouse,
+ - [ --with-gpm-mouse=base-dir Specifies the base gpm directory],
+ - if test x$withval = xyes
+ + [ --with-gpm-mouse=base-dir/no Specifies the base gpm directory],
+ + if test x$withval = xno
+ then
+ - AC_MSG_WARN(Usage is: --with-gpm-mouse=base-dir)
+ + gpm_mousedriver_test=no
+ else
+--- aalib-1.4.0/configure
++++ aalib-1.4.0/configure
@@ -28,7 +28,7 @@
ac_help="$ac_help
--with-curses-driver=no/yes Used to disable/force curses driver"
diff --git a/media-libs/aalib/files/aalib-1.4_rc4-m4.patch b/media-libs/aalib/files/aalib-1.4_rc4-m4.patch
new file mode 100644
index 000000000000..3670f19125fc
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc4-m4.patch
@@ -0,0 +1,9 @@
+Get rid of aclocal warning:
+/usr/share/aclocal/aalib.m4:12: warning: underquoted definition of AM_PATH_AALIB
+--- aalib-1.4.0/aalib.m4
++++ aalib-1.4.0/aalib.m4
+@@ -11,3 +11,3 @@
+ dnl
+-AC_DEFUN(AM_PATH_AALIB,
++AC_DEFUN([AM_PATH_AALIB],
+ [dnl