summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-23 12:46:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-23 12:46:52 +0000
commitf4ba6e3579cbfc2e9a0b25bbd787ddd996595760 (patch)
tree3e90f4c0e198fb10e5fb8d0c9dd6ea3a4440faa0 /media-libs
parentSRC_URI and HOMEPAGE changed. Bugs #65829, #91760 fixed in new release and #1... (diff)
downloadgentoo-2-f4ba6e3579cbfc2e9a0b25bbd787ddd996595760.tar.gz
gentoo-2-f4ba6e3579cbfc2e9a0b25bbd787ddd996595760.tar.bz2
gentoo-2-f4ba6e3579cbfc2e9a0b25bbd787ddd996595760.zip
Version bump to 1.0.12_rc1 version.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/ChangeLog8
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.12_rc1.ebuild66
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.12_rc13
3 files changed, 76 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 140e902fd2c7..ebabb3ad6688 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.174 2006/05/29 19:16:51 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.175 2006/06/23 12:46:52 flameeyes Exp $
+
+*alsa-lib-1.0.12_rc1 (23 Jun 2006)
+
+ 23 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-lib-1.0.12_rc1.ebuild:
+ Version bump to 1.0.12_rc1 version.
29 May 2006; Guy Martin <gmsoft@gentoo.org> alsa-lib-1.0.11.ebuild:
Stable on hppa.
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.12_rc1.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.12_rc1.ebuild
new file mode 100644
index 000000000000..4df9c1ce40cc
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.12_rc1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.12_rc1.ebuild,v 1.1 2006/06/23 12:46:52 flameeyes Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/alsa
+ >=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.0.10_rc3-hardened.patch"
+ epatch "${FILESDIR}/${PN}-1.0.10-no-wordexp-header.patch"
+
+ eautomake
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ einfo ""
+ einfo "Please try media-sound/alsa-driver before filing bugs about unstable"
+ einfo "or missing output with in-kernel drivers. Misaligned versions of"
+ einfo "alsa-lib and drivers used can cause problems."
+}
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.12_rc1 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.12_rc1
new file mode 100644
index 000000000000..2fb0d4246015
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.12_rc1
@@ -0,0 +1,3 @@
+MD5 8a3f6d218a9285426556fb3006054725 alsa-lib-1.0.12rc1.tar.bz2 705338
+RMD160 9e235fdcee54fb9c1b98218d93590b16a59675e6 alsa-lib-1.0.12rc1.tar.bz2 705338
+SHA256 f7fb1855610c33cbfc362fce5b130fef634f614e99616c4a99d8cf33758d2eea alsa-lib-1.0.12rc1.tar.bz2 705338