summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2013-04-23 21:56:12 +0000
committerLuca Barbato <lu_zero@gentoo.org>2013-04-23 21:56:12 +0000
commit5dfdc7cdf2c4091495688cf92df4f4dacb819ecd (patch)
treea8f1cee932974666455c5dfa0ed574d0dab39da4 /media-plugins/alsa-plugins
parentStable for x86, wrt bug #466710 (diff)
downloadgentoo-2-5dfdc7cdf2c4091495688cf92df4f4dacb819ecd.tar.gz
gentoo-2-5dfdc7cdf2c4091495688cf92df4f4dacb819ecd.tar.bz2
gentoo-2-5dfdc7cdf2c4091495688cf92df4f4dacb819ecd.zip
Add libav9 support, patch derived from Ubuntu/Debian, thanks to Jiří Moravec <qjim@volny.cz> for preparing it.
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-plugins/alsa-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog7
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.26.ebuild3
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.26-libav9.patch34
3 files changed, 42 insertions, 2 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index 336369da4188..22d1a235fe88 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.167 2013/04/12 17:28:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.168 2013/04/23 21:56:12 lu_zero Exp $
+
+ 23 Apr 2013; Luca Barbato <lu_zero@gentoo.org> alsa-plugins-1.0.26.ebuild,
+ +files/alsa-plugins-1.0.26-libav9.patch:
+ Add libav9 support, patch derived from Ubuntu/Debian, thanks to Jiří
+ Moravec <qjim@volny.cz> for preparing it.
12 Apr 2013; Agostino Sarubbo <ago@gentoo.org> alsa-plugins-1.0.26.ebuild:
Stable for ia64, wrt bug #463451
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.26.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.26.ebuild
index 94fb16a02be5..d7b5c5ac43cb 100644
--- a/media-plugins/alsa-plugins/alsa-plugins-1.0.26.ebuild
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.26.ebuild,v 1.12 2013/04/12 17:28:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.26.ebuild,v 1.13 2013/04/23 21:56:12 lu_zero Exp $
EAPI=4
@@ -30,6 +30,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch
"${FILESDIR}"/${PN}-1.0.23-automagic.patch
"${FILESDIR}"/${PN}-1.0.25-avcodec54.patch
+ "${FILESDIR}"/${P}-libav9.patch #443258
)
S=${WORKDIR}/${MY_P}
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.26-libav9.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.26-libav9.patch
new file mode 100644
index 000000000000..dfd75dfc0c8d
--- /dev/null
+++ b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.26-libav9.patch
@@ -0,0 +1,34 @@
+Author: Reinhard Tartler <siretart@ubuntu.com>
+Description: Update to newer libav API - compatible to libav 0.8 and libav 9
+
+Index: alsa-plugins-1.0.26/a52/pcm_a52.c
+===================================================================
+--- alsa-plugins-1.0.26.orig/a52/pcm_a52.c 2013-04-22 20:29:05.107102697 +0200
++++ alsa-plugins-1.0.26/a52/pcm_a52.c 2013-04-22 20:34:12.985107208 +0200
+@@ -25,6 +25,8 @@
+ #include <alsa/asoundlib.h>
+ #include <alsa/pcm_external.h>
+ #include <alsa/pcm_plugin.h>
++#include <libavutil/audioconvert.h>
++#include <libavutil/mem.h>
+ #include AVCODEC_HEADER
+
+ struct a52_ctx {
+@@ -429,7 +431,7 @@
+
+ a52_free(rec);
+
+- rec->avctx = avcodec_alloc_context();
++ rec->avctx = avcodec_alloc_context3(rec->codec);
+ if (! rec->avctx)
+ return -ENOMEM;
+
+@@ -457,7 +459,7 @@
+ }
+ #endif
+
+- if (avcodec_open(rec->avctx, rec->codec) < 0)
++ if (avcodec_open2(rec->avctx, rec->codec, NULL) < 0)
+ return -EINVAL;
+
+ rec->inbuf = malloc(rec->avctx->frame_size * 2 * io->channels);