summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
commite4f208dd887e639fdac3f8a599c7c06cac41dde1 (patch)
tree59db30fcd642a5476b02fdfb3a3ff5fd7dc18f2f /media-plugins/mythdvd
parentIntroduced CVS snapshot (diff)
downloadgentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.gz
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.bz2
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.zip
Version bump
Diffstat (limited to 'media-plugins/mythdvd')
-rw-r--r--media-plugins/mythdvd/ChangeLog7
-rw-r--r--media-plugins/mythdvd/Manifest2
-rw-r--r--media-plugins/mythdvd/files/digest-mythdvd-0.141
-rw-r--r--media-plugins/mythdvd/mythdvd-0.14.ebuild82
4 files changed, 91 insertions, 1 deletions
diff --git a/media-plugins/mythdvd/ChangeLog b/media-plugins/mythdvd/ChangeLog
index 0f1324756686..964ba5785e2a 100644
--- a/media-plugins/mythdvd/ChangeLog
+++ b/media-plugins/mythdvd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythdvd
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.6 2004/01/15 18:04:10 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.7 2004/02/03 13:51:53 aliz Exp $
+
+*mythdvd-0.14 (03 Feb 2004)
+
+ 03 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> mythdvd-0.14.ebuild:
+ Version bump
15 Jan 2004; Max Kalika <max@gentoo.org> mythdvd-0.13.ebuild:
Bump to stable x86.
diff --git a/media-plugins/mythdvd/Manifest b/media-plugins/mythdvd/Manifest
index 989f250a74d6..800526dada9e 100644
--- a/media-plugins/mythdvd/Manifest
+++ b/media-plugins/mythdvd/Manifest
@@ -1,8 +1,10 @@
MD5 bdca7d5accce6ff791b81a2acc8b6df7 mythdvd-0.11.ebuild 1962
MD5 2dd8b7f31de6a77c3ed57ef51accbf87 mythdvd-0.13.ebuild 2374
MD5 7e81b395052da2d61bbae4268e107fef mythdvd-0.12.ebuild 2374
+MD5 c37d41e38874102effe3ee1d34cd2908 mythdvd-0.14.ebuild 2375
MD5 a8817c259a600a3dd029574660622881 ChangeLog 863
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 29d1ec475eee7e6e4d5b6a605611c4c7 files/digest-mythdvd-0.11 64
MD5 43523be8d2e4958df76e6e1b2b63791c files/digest-mythdvd-0.12 65
MD5 afa9416eab98d5f2ad7a39bc35be2561 files/digest-mythdvd-0.13 65
+MD5 11e5f49a3ebb04645d97007cb08afdd7 files/digest-mythdvd-0.14 65
diff --git a/media-plugins/mythdvd/files/digest-mythdvd-0.14 b/media-plugins/mythdvd/files/digest-mythdvd-0.14
new file mode 100644
index 000000000000..f860d531c16d
--- /dev/null
+++ b/media-plugins/mythdvd/files/digest-mythdvd-0.14
@@ -0,0 +1 @@
+MD5 3fcbd26eabcbf14e43707385631590ca mythdvd-0.14.tar.bz2 121833
diff --git a/media-plugins/mythdvd/mythdvd-0.14.ebuild b/media-plugins/mythdvd/mythdvd-0.14.ebuild
new file mode 100644
index 000000000000..829395919a13
--- /dev/null
+++ b/media-plugins/mythdvd/mythdvd-0.14.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.14.ebuild,v 1.1 2004/02/03 13:51:53 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="DVD player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="alsa lirc transcode"
+
+DEPEND="media-libs/libdvdread
+ >=sys-apps/sed-4
+ >=media-plugins/mythvideo-${PV}
+ transcode? ( media-video/transcode )
+ || ( media-video/mplayer media-video/xine-ui media-video/ogle )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local myconf="--enable-vcd"
+ myconf="${myconf} `use_enable transcode`"
+
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+
+ if [ "`use alsa`" ] ; then
+ echo "CONFIG += using_alsa" >> settings.pro
+ echo "EXTRA_LIBS += -lasound" >> settings.pro
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
+ -e "s:#EXTRA_LIBS += -llirc_client:EXTRA_LIBS += -llirc_client:" \
+ -i "settings.pro" || die "enable lirc sed failed"
+ fi
+
+ econf ${myconf}
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins dvddb/*.sql
+
+ dodoc AUTHORS COPYING README UPGRADING
+ newdoc dvddb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythDVD,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/README.db.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}