summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-04-02 20:30:50 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-04-02 20:30:50 +0000
commit716aeeb2ab761eb1e70a443590247b0ea90e8d42 (patch)
treeea6fab502be83a7b47938cf538d8efa819f509f4 /media-plugins/vdr-live
parentAdd missing kernel checks (#310797 by Phil Koenig, Tom Knight, Tyler Montbria... (diff)
downloadgentoo-2-716aeeb2ab761eb1e70a443590247b0ea90e8d42.tar.gz
gentoo-2-716aeeb2ab761eb1e70a443590247b0ea90e8d42.tar.bz2
gentoo-2-716aeeb2ab761eb1e70a443590247b0ea90e8d42.zip
Add vdr >=1.7.27 compatibility patch
(Portage version: 2.2.0_alpha98/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/vdr-live')
-rw-r--r--media-plugins/vdr-live/ChangeLog9
-rw-r--r--media-plugins/vdr-live/files/vdr-1.7.27-compatibility.patch48
-rw-r--r--media-plugins/vdr-live/vdr-live-0.2.0.20120114-r1.ebuild (renamed from media-plugins/vdr-live/vdr-live-0.2.0.20120114.ebuild)21
3 files changed, 67 insertions, 11 deletions
diff --git a/media-plugins/vdr-live/ChangeLog b/media-plugins/vdr-live/ChangeLog
index 692302f12bd7..9aac727ddc2e 100644
--- a/media-plugins/vdr-live/ChangeLog
+++ b/media-plugins/vdr-live/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-live
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.30 2012/03/09 23:25:19 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.31 2012/04/02 20:30:50 idl0r Exp $
+
+*vdr-live-0.2.0.20120114-r1 (02 Apr 2012)
+
+ 02 Apr 2012; Christian Ruppert <idl0r@gentoo.org>
+ +files/vdr-1.7.27-compatibility.patch, +vdr-live-0.2.0.20120114-r1.ebuild,
+ -vdr-live-0.2.0.20120114.ebuild:
+ Add vdr >=1.7.27 compatibility patch
09 Mar 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
vdr-live-0.2.0.20120114.ebuild:
diff --git a/media-plugins/vdr-live/files/vdr-1.7.27-compatibility.patch b/media-plugins/vdr-live/files/vdr-1.7.27-compatibility.patch
new file mode 100644
index 000000000000..4eb296676621
--- /dev/null
+++ b/media-plugins/vdr-live/files/vdr-1.7.27-compatibility.patch
@@ -0,0 +1,48 @@
+commit 94a0a210a485ce1fc95c47a6bc67c4c16c89a0f9
+Author: Dieter Hametner <dh (plus) vdr (at) gekrumbel (dot) de>
+Date: Sun Mar 25 16:42:12 2012 +0200
+
+ Updated LIVE to latest changes in vdr 1.7.27
+ - Do not use the direct access to cRecoding members any more.
+
+diff --git a/epg_events.cpp b/epg_events.cpp
+index a514769..cd4996e 100644
+--- a/epg_events.cpp
++++ b/epg_events.cpp
+@@ -182,12 +182,20 @@ namespace vdrlive
+
+ time_t EpgRecording::GetStartTime() const
+ {
++#if VDRVERSNUM < 10726
+ return m_recording ? m_recording->start : 0;
++#else
++ return m_recording ? m_recording->Start() : 0;
++#endif
+ }
+
+ time_t EpgRecording::GetEndTime() const
+ {
++#if VDRVERSNUM < 10726
+ return m_recording ? m_recording->start : 0;
++#else
++ return m_recording ? m_recording->Start() : 0;
++#endif
+ }
+
+ const string EpgRecording::Name() const
+diff --git a/recman.cpp b/recman.cpp
+index fb315d2..6a2fc00 100644
+--- a/recman.cpp
++++ b/recman.cpp
+@@ -383,7 +383,11 @@ namespace vdrlive {
+
+ time_t RecordingsItemRec::StartTime() const
+ {
++#if VDRVERSNUM < 10726
+ return m_recording->start;
++#else
++ return m_recording->Start();
++#endif
+ }
+
+ long RecordingsItemRec::Duration() const
diff --git a/media-plugins/vdr-live/vdr-live-0.2.0.20120114.ebuild b/media-plugins/vdr-live/vdr-live-0.2.0.20120114-r1.ebuild
index 10c07ebbd400..7fd065149b03 100644
--- a/media-plugins/vdr-live/vdr-live-0.2.0.20120114.ebuild
+++ b/media-plugins/vdr-live/vdr-live-0.2.0.20120114-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.2.0.20120114.ebuild,v 1.2 2012/03/09 23:25:19 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.2.0.20120114-r1.ebuild,v 1.1 2012/04/02 20:30:50 idl0r Exp $
EAPI="4"
@@ -55,6 +55,8 @@ src_prepare() {
if ! has_version ">=media-video/vdr-1.7.13"; then
sed -i "s:-include \$(VDRDIR)/Make.global:#-include \$(VDRDIR)/Make.global:" Makefile
fi
+
+ epatch "${FILESDIR}/vdr-1.7.27-compatibility.patch"
}
src_install() {
@@ -78,7 +80,7 @@ pkg_postinst() {
elog "On first install use login:pass"
elog "\tadmin:live"
- ewarn "\t\tWARNiNG!!!"
+ ewarn "\t\tWARNING!!!"
ewarn "This is a developer snapshot"
einfo "On problems, use the stable amd64, x86 versions of"
einfo "dev-libs/tntnet dev-libs/cxxtools media-plugins/vdr-live"
@@ -100,12 +102,11 @@ pkg_postinst() {
}
pkg_config() {
-
- make_live_cert
- local base=$(get_base 1)
- local keydir="/etc/vdr/plugins/live"
- install -d "${ROOT}${keydir}"
- install -m0400 "${base}.key" "${ROOT}${keydir}/live.key"
- install -m0444 "${base}.crt" "${ROOT}${keydir}/live.crt"
- chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live.*
+ make_live_cert
+ local base=$(get_base 1)
+ local keydir="/etc/vdr/plugins/live"
+ install -d "${ROOT}${keydir}"
+ install -m0400 "${base}.key" "${ROOT}${keydir}/live.key"
+ install -m0444 "${base}.crt" "${ROOT}${keydir}/live.crt"
+ chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live.*
}