summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-05-12 17:31:09 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-05-12 17:31:09 +0000
commit23bedab3333c811c01eb8a08a8b6e3b2f7cba7fa (patch)
tree5fd010de7a074ad5d0d96cc299aa87f027361f05 /media-plugins/vdr-xineliboutput
parentalpha/ia64/sparc stable wrt #221063 (diff)
downloadgentoo-2-23bedab3333c811c01eb8a08a8b6e3b2f7cba7fa.tar.gz
gentoo-2-23bedab3333c811c01eb8a08a8b6e3b2f7cba7fa.tar.bz2
gentoo-2-23bedab3333c811c01eb8a08a8b6e3b2f7cba7fa.zip
Version bumped. Thanks to Pertti Kosunen for noticing.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'media-plugins/vdr-xineliboutput')
-rw-r--r--media-plugins/vdr-xineliboutput/ChangeLog8
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.1.ebuild111
2 files changed, 118 insertions, 1 deletions
diff --git a/media-plugins/vdr-xineliboutput/ChangeLog b/media-plugins/vdr-xineliboutput/ChangeLog
index b6049cdf9519..ca222af5407e 100644
--- a/media-plugins/vdr-xineliboutput/ChangeLog
+++ b/media-plugins/vdr-xineliboutput/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-xineliboutput
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/ChangeLog,v 1.38 2008/04/24 20:03:29 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/ChangeLog,v 1.39 2008/05/12 17:31:09 zzam Exp $
+
+*vdr-xineliboutput-1.0.1 (12 May 2008)
+
+ 12 May 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +vdr-xineliboutput-1.0.1.ebuild:
+ Version bumped. Thanks to Pertti Kosunen for noticing.
*vdr-xineliboutput-1.0.0 (24 Apr 2008)
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.1.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.1.ebuild
new file mode 100644
index 000000000000..00fa7b8f7d2e
--- /dev/null
+++ b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.1.ebuild,v 1.1 2008/05/12 17:31:09 zzam Exp $
+
+inherit vdr-plugin eutils multilib versionator
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+SO_VERSION="${PV%_p*}"
+SO_VERSION="${SO_VERSION/_/}"
+
+DESCRIPTION="Video Disk Recorder Xinelib PlugIn"
+HOMEPAGE="http://sourceforge.net/projects/xineliboutput/"
+SRC_URI="mirror://sourceforge/${PN#vdr-}/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="fbcon X libextractor"
+
+RDEPEND=">=media-video/vdr-1.4.0
+ >=media-libs/xine-lib-1.1.1
+ media-libs/jpeg
+ libextractor? ( >=media-libs/libextractor-0.5.20 )
+ X? (
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto
+ x11-proto/renderproto
+ )"
+
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ X? (
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXext
+ x11-libs/libXrender
+ )"
+
+S=${WORKDIR}/${MY_P#vdr-}
+
+VDR_CONFD_FILE=${FILESDIR}/confd-1.0.0_pre6
+
+NO_GETTEXT_HACK=1
+
+use_onoff() {
+ if use "$1"; then
+ echo 1
+ else
+ echo 0
+ fi
+}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ cd "${S}"
+
+ XINE_PLUGIN_DIR=$(xine-config --plugindir)
+ if [[ ${XINE_PLUGIN_DIR} = "" ]]; then
+ eerror "Could not find xine plugin dir"
+ die "Could not find xine plugin dir"
+ fi
+ # stop some automagic overwriting the stuff we set
+ sed -e '/XINELIBOUTPUT_VDRPLUGIN = 1/s/^/#/' \
+ -e '/HAVE_EXTRACTOR_H = 1/s/^/#/' \
+ -i Makefile
+
+ cat >>Make.config <<-EOF
+ XINELIBOUTPUT_XINEPLUGIN = 1
+ XINELIBOUTPUT_VDRPLUGIN = 1
+
+ XINELIBOUTPUT_FB = $(use_onoff fbcon)
+ XINELIBOUTPUT_X11 = $(use_onoff X)
+
+ HAVE_XRENDER = 1
+ HAVE_XDPMS = 1
+ HAVE_EXTRACTOR_H = $(use_onoff libextractor)
+ EOF
+
+ # patching makefile to work with this
+ # $ rm ${outdir}/file; cp file ${outdir}/file
+ # work in the sandbox
+ sed -i Makefile \
+ -e 's:XINEPLUGINDIR.*=.*:XINEPLUGINDIR = '"${WORKDIR}/lib:" \
+ -e 's:VDRINCDIR.*=.*:VDRINCDIR ?= /usr/include:'
+ mkdir -p "${WORKDIR}/lib"
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ use fbcon && dobin vdr-fbfe
+ use X && dobin vdr-sxfe
+
+ # There may be no sub-plugin, depending on use-flags
+ insinto ${VDR_PLUGIN_DIR}
+ local f
+ for f in libxineliboutput*.so.${SO_VERSION}; do
+ [[ -f "$f" ]] || continue
+ doins "${f}" || die "could not install sub-plugin ${f}"
+ done
+
+ insinto "${XINE_PLUGIN_DIR}"
+ doins xineplug_inp_*.so
+
+ insinto "${XINE_PLUGIN_DIR}"/post
+ doins xineplug_post_*.so
+}