summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-01-08 00:32:39 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-01-08 00:32:39 +0000
commit27af7765e13005eb1e6e574a92b9e5305eda5339 (patch)
tree949b8629176aeac56df40694a38bc6982961aa72 /media-plugins
parentMask 1.3.0_alpha builds of audacious core & plugins. (diff)
downloadgentoo-2-27af7765e13005eb1e6e574a92b9e5305eda5339.tar.gz
gentoo-2-27af7765e13005eb1e6e574a92b9e5305eda5339.tar.bz2
gentoo-2-27af7765e13005eb1e6e574a92b9e5305eda5339.zip
Adding masked alpha2 build. No support offered, report bugs upstream only.
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog11
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha2.ebuild108
-rw-r--r--media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.0_alpha23
3 files changed, 119 insertions, 3 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index d4d677b04b0e..47902e237a06 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.27 2007/01/07 22:22:47 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.28 2007/01/08 00:32:39 chainsaw Exp $
+
+*audacious-plugins-1.3.0_alpha2 (08 Jan 2007)
+
+ 08 Jan 2007; Tony Vroon <chainsaw@gentoo.org>
+ +audacious-plugins-1.3.0_alpha2.ebuild:
+ Adding masked alpha2 build. No support offered, report bugs upstream only.
07 Jan 2007; Tony Vroon <chainsaw@gentoo.org>
-audacious-plugins-1.3.0_alpha1.ebuild:
- Developer releases are not appreciated by the community. Use an overlay if
- you want them. Closes bug #160761.
+ Developer releases are not appreciated by the community. Closes bug #160761.
*audacious-plugins-1.3.0_alpha1 (05 Jan 2007)
diff --git a/media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha2.ebuild b/media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha2.ebuild
new file mode 100644
index 000000000000..7c0a487c4f73
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha2.ebuild,v 1.1 2007/01/08 00:32:39 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://static.audacious-media-player.org/release/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aac alsa arts chardet esd flac jack lirc modplug mp3 musepack nls oss sid sndfile timidity vorbis wavpack wma pulseaudio"
+
+RDEPEND="app-arch/unzip
+ dev-libs/libxml2
+ net-misc/curl
+ >=media-sound/audacious-1.3.0_alpha2
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ >=dev-cpp/libbinio-1.4
+ >=media-libs/libsdl-1.2.5
+ media-libs/taglib
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0
+ || ( ~media-libs/flac-1.1.2
+ ~media-libs/flac-1.1.3 )
+ )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-libs/libsamplerate
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ modplug? ( media-libs/libmodplug )
+ musepack? ( media-libs/libmpcdec )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( media-libs/libsndfile )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ wavpack? ( >=media-sound/wavpack-4.31 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ echo
+ ewarn "MP3 support is now optional, you may want to enable the mp3 USE-flag"
+ echo
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ $(use_enable vorbis) \
+ $(use_enable esd) \
+ $(use_enable mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable flac) \
+ $(use_enable aac) \
+ $(use_enable modplug) \
+ $(use_enable lirc) \
+ $(use_enable sndfile) \
+ $(use_enable wma) \
+ $(use_enable sid) \
+ $(use_enable musepack) \
+ $(use_enable jack) \
+ $(use_enable timidity) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable chardet) \
+ $(use_enable wavpack) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS
+}
+
+pkg_postinst() {
+ mp3_warning
+ ewarn "This is alpha-quality software, and you have unmasked this software manually. Do *not* use the Gentoo bugtracker for this package."
+ elog "Note that you need to recompile *all* third-party plugins to use Audacious 1.3 alpha builds."
+ elog "Failure to do so may cause the player to crash."
+ elog "Any bug reports are to be made on: http://bugs-meta.atheme.org/"
+}
diff --git a/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.0_alpha2 b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.0_alpha2
new file mode 100644
index 000000000000..5f5d67e8e778
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.0_alpha2
@@ -0,0 +1,3 @@
+MD5 b842c262c911c0ccaee767964798ebd0 audacious-plugins-1.3.0-alpha2.tgz 2584805
+RMD160 8d242b3262902cfa7eadd563bc6f3be3fb0b8e4a audacious-plugins-1.3.0-alpha2.tgz 2584805
+SHA256 e7e1831d6fa0bd9a3e29c5d32f3a814c41b91187e172df19b860fedcc1461646 audacious-plugins-1.3.0-alpha2.tgz 2584805