summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-10-20 18:02:23 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-10-20 18:02:23 +0000
commit37f9b793872ea97f1dc96374c57145722e9ca2ac (patch)
tree8bb2c767c48c019ccb29e8daf23381264783e147 /media-plugins
parentAdd cssselect dependency for bug #439058 (use --force since we need to do a s... (diff)
downloadgentoo-2-37f9b793872ea97f1dc96374c57145722e9ca2ac.tar.gz
gentoo-2-37f9b793872ea97f1dc96374c57145722e9ca2ac.tar.bz2
gentoo-2-37f9b793872ea97f1dc96374c57145722e9ca2ac.zip
vdr-plugin-2.eclass, fixed append string
(Portage version: 2.1.11.9/cvs/Linux i686)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-osdpip/ChangeLog9
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.10-avutil50.patch45
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild38
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild (renamed from media-plugins/vdr-osdpip/vdr-osdpip-0.1.0.ebuild)14
4 files changed, 16 insertions, 90 deletions
diff --git a/media-plugins/vdr-osdpip/ChangeLog b/media-plugins/vdr-osdpip/ChangeLog
index fd7534fef8b5..0a43842590d2 100644
--- a/media-plugins/vdr-osdpip/ChangeLog
+++ b/media-plugins/vdr-osdpip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-osdpip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.15 2012/07/01 14:07:12 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.16 2012/10/20 18:02:23 hd_brummy Exp $
+
+*vdr-osdpip-0.1.1-r1 (20 Oct 2012)
+
+ 20 Oct 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
+ -vdr-osdpip-0.0.10.ebuild, -files/vdr-osdpip-0.0.10-avutil50.patch,
+ -vdr-osdpip-0.1.0.ebuild, +vdr-osdpip-0.1.1-r1.ebuild:
+ vdr-plugin-2.eclass, fixed append string
01 Jul 2012; Joerg Bornkessel <hd_brummy@gentoo.org> vdr-osdpip-0.1.1.ebuild:
stable amd64 x86, bug 419117
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.10-avutil50.patch b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.10-avutil50.patch
deleted file mode 100644
index 822957030442..000000000000
--- a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.10-avutil50.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-Index: osdpip-0.0.10/decoder.c
-===================================================================
---- osdpip-0.0.10.orig/decoder.c
-+++ osdpip-0.0.10/decoder.c
-@@ -27,10 +27,10 @@ int cDecoder::Open()
- }
- m_PicDecoded = avcodec_alloc_frame();
- m_PicResample = avcodec_alloc_frame();
-- m_BufferResample = new unsigned char[400 * 300 * 4]; // size for RGBA32
-+ m_BufferResample = new unsigned char[400 * 300 * 4]; // size for RGB32
- #ifndef USE_SWSCALE
- m_PicConvert = avcodec_alloc_frame();
-- m_BufferConvert = new unsigned char[400 * 300 * 4]; // size for RGBA32
-+ m_BufferConvert = new unsigned char[400 * 300 * 4]; // size for RGB32
- #endif
-
- return 0;
-@@ -82,14 +82,14 @@ int cDecoder::Resample(int width, int he
- context = sws_getContext(m_Context->width - (OsdPipSetup.CropLeft + OsdPipSetup.CropRight),
- m_Context->height - (OsdPipSetup.CropTop + OsdPipSetup.CropBottom),
- PIX_FMT_YUV420P,
-- m_Width, m_Height, ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P,
-+ m_Width, m_Height, ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P,
- SWS_LANCZOS, NULL, NULL, NULL);
- if (!context) {
- printf("Error initializing scale context.\n");
- return -1;
- }
- avpicture_fill((AVPicture *) m_PicResample, m_BufferResample,
-- ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P,
-+ ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P,
- m_Width, m_Height);
- sws_scale(context, pic_crop.data, pic_crop.linesize,
- 0, m_Context->height - (OsdPipSetup.CropTop + OsdPipSetup.CropBottom),
-@@ -121,8 +121,8 @@ int cDecoder::Resample(int width, int he
- if (ConvertToRGB)
- {
- avpicture_fill((AVPicture *) m_PicConvert, m_BufferConvert,
-- PIX_FMT_RGBA32, m_Width, m_Height);
-- img_convert((AVPicture *) m_PicConvert, PIX_FMT_RGBA32,
-+ PIX_FMT_RGB32, m_Width, m_Height);
-+ img_convert((AVPicture *) m_PicConvert, PIX_FMT_RGB32,
- (AVPicture *) m_PicResample, PIX_FMT_YUV420P,
- m_Width, m_Height);
- }
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild
deleted file mode 100644
index e1a5c95dfc76..000000000000
--- a/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild,v 1.5 2011/04/06 17:16:53 idl0r Exp $
-
-inherit vdr-plugin flag-o-matic
-
-DESCRIPTION="VDR plugin: Show another channel in the OSD"
-HOMEPAGE="http://www.magoa.net/linux"
-SRC_URI="http://home.arcor.de/andreas.regel/files/osdpip/${P}.tgz"
-
-KEYWORDS="~amd64 x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND=">=media-video/vdr-1.4.0
- >=media-libs/libmpeg2-0.4.0
- >=virtual/ffmpeg-0.4.9"
-RDEPEND="${DEPEND}"
-
-#PATCHES=("${FILESDIR}/${P}-vdr-1.5.0.diff")
-PATCHES=( "${FILESDIR}/${P}-avutil50.patch" )
-
-src_unpack() {
- vdr-plugin_src_unpack
-
- sed -i Makefile \
- -e 's+^FFMDIR.*$+FFMDIR = /usr/include/ffmpeg+' \
- -e 's+-I\$(FFMDIR)/libavcodec+-I$(FFMDIR)+' \
- -e 's+-L\$(FFMDIR)/libavcodec++'
-
- if has_version ">=virtual/ffmpeg-0.4.9_p20080326" ; then
- #epatch "${FILESDIR}/${P}-ffmpeg-0.4.9_p20080326-new_header.diff"
- sed -i Makefile -e 's/#WITH_NEW_FFMPEG_HEADERS/WITH_NEW_FFMPEG_HEADERS/'
- fi
- # UINT64_C is needed by ffmpeg headers
- append-flags -D__STDC_CONSTANT_MACROS
-}
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.1.0.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild
index 70cd4e979218..b82ad4783a05 100644
--- a/media-plugins/vdr-osdpip/vdr-osdpip-0.1.0.ebuild
+++ b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.1.0.ebuild,v 1.2 2012/02/21 22:58:26 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild,v 1.1 2012/10/20 18:02:23 hd_brummy Exp $
-EAPI=3
+EAPI="4"
-inherit vdr-plugin flag-o-matic
+VERSION="880" # every bump, new version
+
+inherit vdr-plugin-2 flag-o-matic
DESCRIPTION="VDR plugin: Show another channel in the OSD"
HOMEPAGE="http://projects.vdr-developer.org/projects/plg-osdpip"
-SRC_URI="mirror://vdr-developerorg/download/267/${P}.tgz"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
KEYWORDS="~amd64 ~x86"
SLOT="0"
@@ -21,8 +23,8 @@ DEPEND=">=media-video/vdr-1.6.0_p2-r5
RDEPEND="${DEPEND}"
src_prepare() {
- vdr-plugin_src_prepare
+ vdr-plugin-2_src_prepare
# UINT64_C is needed by ffmpeg headers
- append-flags -D__STDC_CONSTANT_MACROS
+ append-cxxflags -D__STDC_CONSTANT_MACROS
}