summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-07-05 00:05:11 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-07-05 00:05:11 +0000
commit4cf2d6b1e55fd78f9f83d6c3bebbd029f07e78c9 (patch)
tree9fb5eff812859496d1073c3b486c786c6bd8e5b3 /media-plugins
parentStable on amd64 (diff)
downloadgentoo-2-4cf2d6b1e55fd78f9f83d6c3bebbd029f07e78c9.tar.gz
gentoo-2-4cf2d6b1e55fd78f9f83d6c3bebbd029f07e78c9.tar.bz2
gentoo-2-4cf2d6b1e55fd78f9f83d6c3bebbd029f07e78c9.zip
Cosmetic fixes.
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gmpc-magnatune/ChangeLog7
-rw-r--r--media-plugins/gmpc-magnatune/gmpc-magnatune-0.14.0.ebuild12
-rw-r--r--media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.0.ebuild12
3 files changed, 28 insertions, 3 deletions
diff --git a/media-plugins/gmpc-magnatune/ChangeLog b/media-plugins/gmpc-magnatune/ChangeLog
index 53d582dc345f..8913a3b5fccf 100644
--- a/media-plugins/gmpc-magnatune/ChangeLog
+++ b/media-plugins/gmpc-magnatune/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/gmpc-magnatune
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-magnatune/ChangeLog,v 1.4 2007/07/03 12:50:02 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-magnatune/ChangeLog,v 1.5 2007/07/05 00:05:11 ticho Exp $
+
+ 05 Jul 2007; Andrej Kacian <ticho@gentoo.org>
+ gmpc-magnatune-0.14.0.ebuild, gmpc-magnatune-0.15.0.ebuild:
+ Add check for correct USE flag for x11-libs/gtk+-2. Bug #184162, by Avuton
+ Olrich <avuton at gmail.com>.
03 Jul 2007; Christoph Mende <angelos@gentoo.org>
gmpc-magnatune-0.15.0.ebuild:
diff --git a/media-plugins/gmpc-magnatune/gmpc-magnatune-0.14.0.ebuild b/media-plugins/gmpc-magnatune/gmpc-magnatune-0.14.0.ebuild
index 57f860a8288f..a7190129262b 100644
--- a/media-plugins/gmpc-magnatune/gmpc-magnatune-0.14.0.ebuild
+++ b/media-plugins/gmpc-magnatune/gmpc-magnatune-0.14.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-magnatune/gmpc-magnatune-0.14.0.ebuild,v 1.2 2007/04/15 15:34:19 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-magnatune/gmpc-magnatune-0.14.0.ebuild,v 1.3 2007/07/05 00:05:11 ticho Exp $
+
+inherit eutils
DESCRIPTION="The plugin allows you to browse, and preview available albums on www.magnatune.com."
HOMEPAGE="http://sarine.nl/gmpc-plugins-lyrics-magnatune"
@@ -14,6 +16,14 @@ IUSE=""
DEPEND=">=media-sound/gmpc-${PV}
dev-libs/libxml2"
+pkg_setup() {
+ if ! built_with_use =x11-libs/gtk+-2* jpeg ; then
+ echo
+ eerror "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ die "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ fi
+}
+
src_compile ()
{
econf || die
diff --git a/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.0.ebuild b/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.0.ebuild
index 7cd21334dfa3..1449221d8718 100644
--- a/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.0.ebuild
+++ b/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.0.ebuild,v 1.3 2007/07/03 12:50:02 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.0.ebuild,v 1.4 2007/07/05 00:05:11 ticho Exp $
+
+inherit eutils
DESCRIPTION="The plugin allows you to browse, and preview available albums on www.magnatune.com."
HOMEPAGE="http://sarine.nl/gmpc-plugins-lyrics-magnatune"
@@ -14,6 +16,14 @@ IUSE=""
DEPEND=">=media-sound/gmpc-${PV}
dev-libs/libxml2"
+pkg_setup() {
+ if ! built_with_use =x11-libs/gtk+-2* jpeg ; then
+ echo
+ eerror "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ die "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ fi
+}
+
src_compile ()
{
econf || die