summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-18 18:00:18 +0000
committerMax Kalika <max@gentoo.org>2003-08-18 18:00:18 +0000
commit60d4e8261545c881268d42dbdd848f0408b6692c (patch)
treeb7380683c4141a5a21131026ab22f04037d93490 /media-plugins
parentMarked stable for sparc. (diff)
downloadgentoo-2-60d4e8261545c881268d42dbdd848f0408b6692c.tar.gz
gentoo-2-60d4e8261545c881268d42dbdd848f0408b6692c.tar.bz2
gentoo-2-60d4e8261545c881268d42dbdd848f0408b6692c.zip
Initial version.
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mythdvd/ChangeLog9
-rw-r--r--media-plugins/mythdvd/Manifest3
-rw-r--r--media-plugins/mythdvd/files/digest-mythdvd-0.111
-rw-r--r--media-plugins/mythdvd/mythdvd-0.11.ebuild70
4 files changed, 83 insertions, 0 deletions
diff --git a/media-plugins/mythdvd/ChangeLog b/media-plugins/mythdvd/ChangeLog
new file mode 100644
index 000000000000..b4685865ec18
--- /dev/null
+++ b/media-plugins/mythdvd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-plugins/mythdvd
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.1 2003/08/18 18:00:00 max Exp $
+
+*mythdvd-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythdvd-0.11.ebuild:
+ Initial version.
+
diff --git a/media-plugins/mythdvd/Manifest b/media-plugins/mythdvd/Manifest
new file mode 100644
index 000000000000..19b06576894c
--- /dev/null
+++ b/media-plugins/mythdvd/Manifest
@@ -0,0 +1,3 @@
+MD5 4e3b9f8afa474cfaec17ffd4e3a59a0a mythdvd-0.11.ebuild 1964
+MD5 99788171c69f9b8683ce10e7adbf8bfd ChangeLog 334
+MD5 29d1ec475eee7e6e4d5b6a605611c4c7 files/digest-mythdvd-0.11 64
diff --git a/media-plugins/mythdvd/files/digest-mythdvd-0.11 b/media-plugins/mythdvd/files/digest-mythdvd-0.11
new file mode 100644
index 000000000000..031bee3283f4
--- /dev/null
+++ b/media-plugins/mythdvd/files/digest-mythdvd-0.11
@@ -0,0 +1 @@
+MD5 0ed928b49be755e6b66d7d0b153e94e8 mythdvd-0.11.tar.bz2 87816
diff --git a/media-plugins/mythdvd/mythdvd-0.11.ebuild b/media-plugins/mythdvd/mythdvd-0.11.ebuild
new file mode 100644
index 000000000000..8ec8307a6af6
--- /dev/null
+++ b/media-plugins/mythdvd/mythdvd-0.11.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.11.ebuild,v 1.1 2003/08/18 18:00:00 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="DVD player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="transcode"
+
+DEPEND="media-libs/libdvdread
+ >=sys-apps/sed-4
+ >=media-plugins/mythvideo-${PV}
+ transcode? ( media-video/transcode )
+ || ( media-video/mplayer media-video/xine-ui media-video/ogle )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ econf "`use_enable transcode`"
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins dvddb/*.sql
+
+ dodoc AUTHORS COPYING README UPGRADING
+ newdoc dvddb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythDVD,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/README.db.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}