summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-04-16 10:19:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-04-16 10:19:30 +0000
commitae7de9a8e0fd4dd2a8c14bd14cb1a64e264579b4 (patch)
treefc674ba9a3ee22417fb4f5ef70d4e716e0a55a06 /media-plugins
parentAdd bug number (diff)
downloadgentoo-2-ae7de9a8e0fd4dd2a8c14bd14cb1a64e264579b4.tar.gz
gentoo-2-ae7de9a8e0fd4dd2a8c14bd14cb1a64e264579b4.tar.bz2
gentoo-2-ae7de9a8e0fd4dd2a8c14bd14cb1a64e264579b4.zip
old
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.20.ebuild82
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.21.ebuild82
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild82
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.14_rc1-init-ffmpeg.patch13
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.17-automagic.patch56
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.19-speex.patch73
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.20-automagic.patch12
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.22-automagic.patch12
-rw-r--r--media-plugins/alsa-plugins/files/ffmpeg-headers.patch54
9 files changed, 0 insertions, 466 deletions
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.20.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.20.ebuild
deleted file mode 100644
index b573d36970b5..000000000000
--- a/media-plugins/alsa-plugins/alsa-plugins-1.0.20.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.20.ebuild,v 1.12 2011/04/10 20:21:10 scarabeus Exp $
-
-EAPI=2
-
-MY_P="${P/_/}"
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="ALSA extra plugins"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sh ~sparc x86"
-IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
-
-RDEPEND=">=media-libs/alsa-lib-${PV}[alsa_pcm_plugins_ioplug]
- ffmpeg? ( virtual/ffmpeg
- media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
- jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
- libsamplerate? (
- media-libs/libsamplerate
- media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
- pulseaudio? ( media-sound/pulseaudio )
- speex? ( media-libs/speex
- media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
- !media-plugins/alsa-jack"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
- # failed assert. As the code works just fine with asserts disabled, for now
- # disable them waiting for a better solution.
- sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
- "${S}/pulse/Makefile.am"
-
- # Bug #256119
- epatch "${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch
-
- # Bug #278352
- epatch "${FILESDIR}"/${P}-automagic.patch
-
- eautoreconf
-}
-
-src_configure() {
- use debug || append-flags -DNDEBUG
-
- local myspeex
-
- if use speex; then
- myspeex=lib
- else
- myspeex=no
- fi
-
- econf \
- --disable-dependency-tracking \
- $(use_enable ffmpeg avcodec) \
- $(use_enable jack) \
- $(use_enable libsamplerate samplerate) \
- $(use_enable pulseaudio) \
- --with-speex=${myspeex}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- cd "${S}/doc"
- dodoc upmix.txt vdownmix.txt README-pcm-oss
- use jack && dodoc README-jack
- use libsamplerate && dodoc samplerate.txt
- use pulseaudio && dodoc README-pulse
- use ffmpeg && dodoc lavcrate.txt a52.txt
-}
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.21.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.21.ebuild
deleted file mode 100644
index 626de36a8910..000000000000
--- a/media-plugins/alsa-plugins/alsa-plugins-1.0.21.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.21.ebuild,v 1.10 2011/04/10 20:21:10 scarabeus Exp $
-
-EAPI=2
-
-MY_P="${P/_/}"
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="ALSA extra plugins"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
-IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
-
-RDEPEND=">=media-libs/alsa-lib-${PV}[alsa_pcm_plugins_ioplug]
- ffmpeg? ( virtual/ffmpeg
- media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
- jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
- libsamplerate? (
- media-libs/libsamplerate
- media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
- pulseaudio? ( media-sound/pulseaudio )
- speex? ( media-libs/speex
- media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
- !media-plugins/alsa-jack"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
- # failed assert. As the code works just fine with asserts disabled, for now
- # disable them waiting for a better solution.
- sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
- "${S}/pulse/Makefile.am"
-
- # Bug #256119
- epatch "${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch
-
- # Bug #278352
- epatch "${FILESDIR}"/${P}-automagic.patch
-
- eautoreconf
-}
-
-src_configure() {
- use debug || append-flags -DNDEBUG
-
- local myspeex
-
- if use speex; then
- myspeex=lib
- else
- myspeex=no
- fi
-
- econf \
- --disable-dependency-tracking \
- $(use_enable ffmpeg avcodec) \
- $(use_enable jack) \
- $(use_enable libsamplerate samplerate) \
- $(use_enable pulseaudio) \
- --with-speex=${myspeex}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- cd "${S}/doc"
- dodoc upmix.txt vdownmix.txt README-pcm-oss
- use jack && dodoc README-jack
- use libsamplerate && dodoc samplerate.txt
- use pulseaudio && dodoc README-pulse
- use ffmpeg && dodoc lavcrate.txt a52.txt
-}
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild
deleted file mode 100644
index b9af9732d9cd..000000000000
--- a/media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild,v 1.2 2011/04/10 20:21:10 scarabeus Exp $
-
-EAPI=2
-
-MY_P="${P/_/}"
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="ALSA extra plugins"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
-
-RDEPEND=">=media-libs/alsa-lib-${PV}[alsa_pcm_plugins_ioplug]
- ffmpeg? ( virtual/ffmpeg
- media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
- jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
- libsamplerate? (
- media-libs/libsamplerate
- media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
- pulseaudio? ( media-sound/pulseaudio )
- speex? ( media-libs/speex
- media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
- !media-plugins/alsa-jack"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
- # failed assert. As the code works just fine with asserts disabled, for now
- # disable them waiting for a better solution.
- sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
- "${S}/pulse/Makefile.am"
-
- # Bug #256119
- epatch "${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch
-
- # Bug #278352
- epatch "${FILESDIR}"/${P}-automagic.patch
-
- eautoreconf
-}
-
-src_configure() {
- use debug || append-flags -DNDEBUG
-
- local myspeex
-
- if use speex; then
- myspeex=lib
- else
- myspeex=no
- fi
-
- econf \
- --disable-dependency-tracking \
- $(use_enable ffmpeg avcodec) \
- $(use_enable jack) \
- $(use_enable libsamplerate samplerate) \
- $(use_enable pulseaudio) \
- --with-speex=${myspeex}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- cd "${S}/doc"
- dodoc upmix.txt vdownmix.txt README-pcm-oss
- use jack && dodoc README-jack
- use libsamplerate && dodoc samplerate.txt
- use pulseaudio && dodoc README-pulse
- use ffmpeg && dodoc lavcrate.txt a52.txt
-}
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.14_rc1-init-ffmpeg.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.14_rc1-init-ffmpeg.patch
deleted file mode 100644
index c0bc1be37cc9..000000000000
--- a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.14_rc1-init-ffmpeg.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: alsa-plugins-1.0.14rc1/a52/pcm_a52.c
-===================================================================
---- alsa-plugins-1.0.14rc1.orig/a52/pcm_a52.c
-+++ alsa-plugins-1.0.14rc1/a52/pcm_a52.c
-@@ -421,6 +421,8 @@ static int a52_prepare(snd_pcm_ioplug_t
- {
- struct a52_ctx *rec = io->private_data;
-
-+ avcodec_init();
-+
- a52_free(rec);
-
- rec->avctx = avcodec_alloc_context();
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.17-automagic.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.17-automagic.patch
deleted file mode 100644
index 410fd9213569..000000000000
--- a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.17-automagic.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff -ur alsa-plugins-1.0.17.orig/configure.in alsa-plugins-1.0.17/configure.in
---- alsa-plugins-1.0.17.orig/configure.in 2008-07-30 22:01:02.000000000 -0400
-+++ alsa-plugins-1.0.17/configure.in 2008-07-30 22:04:59.000000000 -0400
-@@ -15,13 +15,25 @@
- AC_CHECK_LIB(asound, snd_pcm_ioplug_create,,
- AC_ERROR([*** libasound has no external plugin SDK]), -ldl)
-
--PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
-+AC_ARG_ENABLE([jack],
-+ AC_HELP_STRING([--disable-jack], [Disable building of JACK plugin]))
-+if test "x$enable_jack" != "xno"; then
-+ PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
-+fi
- AM_CONDITIONAL(HAVE_JACK, test x$HAVE_JACK = xyes)
-
--PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
-+AC_ARG_ENABLE([pulseaudio],
-+ AC_HELP_STRING([--disable-pulseaudio], [Disable building of pulseaudio plugin]))
-+if test "x$enable_pulseaudio" != "xno"; then
-+ PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
-+fi
- AM_CONDITIONAL(HAVE_PULSE, test x$HAVE_PULSE = xyes)
-
--PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
-+AC_ARG_ENABLE([samplerate],
-+ AC_HELP_STRING([--disable-samplerate], [Disable building of samplerate plugin]))
-+if test "x$enable_samplerate" != "xno"; then
-+ PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
-+fi
- AM_CONDITIONAL(HAVE_SAMPLERATE, test x$HAVE_SAMPLERATE = xyes)
-
- AC_ARG_ENABLE([maemo-plugin],
-@@ -45,6 +57,8 @@
- fi
- fi
-
-+AC_ARG_ENABLE([avcodec],
-+ AC_HELP_STRING([--disable-avcodec], [Disable building of avcodec code (a52 plugin)]))
- AC_ARG_WITH([avcodec-includedir],
- AS_HELP_STRING([--with-avcodec-includedir=dir],
- [AVcodec include directory]),
-@@ -60,9 +74,11 @@
- AC_SUBST(AVCODEC_CFLAGS)
- AVCODEC_LIBS="$AVCODEC_LIBS -lavcodec"
- AC_SUBST(AVCODEC_LIBS)
--AC_CHECK_LIB([avcodec], [avcodec_open], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
--if test x$HAVE_AVCODEC = xyes; then
-- AC_CHECK_HEADER([ffmpeg/avcodec.h], [], [HAVE_AVCODEC=no])
-+if test "x$enable_avcodec" != "xno"; then
-+ AC_CHECK_LIB([avcodec], [avcodec_open], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
-+ if test x$HAVE_AVCODEC = xyes; then
-+ AC_CHECK_HEADER([ffmpeg/avcodec.h], [], [HAVE_AVCODEC=no])
-+ fi
- fi
- AM_CONDITIONAL(HAVE_AVCODEC, test x$HAVE_AVCODEC = xyes)
- CFLAGS="$CFLAGS_saved"
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.19-speex.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.19-speex.patch
deleted file mode 100644
index 5f339a3e1e81..000000000000
--- a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.19-speex.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From: Takashi Iwai <tiwai@suse.de>
-Date: Wed, 21 Jan 2009 15:53:36 +0000 (+0100)
-Subject: Fix build of pph plugin with speex-1.2rc1
-X-Git-Tag: v1.0.20~10
-X-Git-Url: http://git.alsa-project.org/?p=alsa-plugins.git;a=commitdiff_plain;h=ba7cd8e0a04798479f851741ec29fef97889aa39;hp=c547b535a20a0909c17cb6dd14e5e364b2ae0fe9
-
-Fix build of pph plugin with speex-1.2rc1
-
-The resampler code is moved to libspeexdsp instead of libspeex.
-
-Signed-off-by: Takashi Iwai <tiwai@suse.de>
----
-
-diff --git a/configure.in b/configure.in
-index 837934f..ce95b5d 100644
---- a/configure.in
-+++ b/configure.in
-@@ -106,16 +106,18 @@ AC_SUBST(AVCODEC_CFLAGS)
- AC_SUBST(AVCODEC_LIBS)
- AC_SUBST(AVCODEC_HEADER)
-
--USE_LIBSPEEX=""
-+PKG_CHECK_MODULES(speexdsp, [speexdsp >= 1.2], [HAVE_SPEEXDSP="yes"], [HAVE_SPEEXDSP=""])
-+AM_CONDITIONAL(HAVE_SPEEXDSP, test "$HAVE_SPEEXDSP" = "yes")
-+
- AC_ARG_WITH([speex],
- AS_HELP_STRING([--with-speex={builtin|lib|no}],
- [build speex resampler (built-in code, link with external lib, or no build)]),
- [PPH=$withval], [PPH="lib"])
-
-+USE_LIBSPEEX=""
- if test "$PPH" = "lib"; then
-- PKG_CHECK_MODULES(speex, [speex >= 1.2], [USE_LIBSPEEX="yes"], [USE_LIBSPEEX=""])
-- if test "$USE_LIBSPEEX" = "yes"; then
-- AC_CHECK_LIB([speex], [speex_resampler_init],
-+ if test "$HAVE_SPEEXDSP" = "yes"; then
-+ AC_CHECK_LIB([speexdsp], [speex_resampler_init],
- [USE_LIBSPEEX="yes"], [USE_LIBSPEEX=""])
- fi
- if test "$USE_LIBSPEEX" = "yes"; then
-@@ -197,6 +199,6 @@ if test "$HAVE_AVCODEC" = "yes"; then
- fi
- echo "Speex rate plugin: $PPH"
- if test "$PPH" = "lib"; then
-- echo " speex_CFLAGS: $speex_CFLAGS"
-- echo " speex_LIBS: $speex_LIBS"
-+ echo " speexdsp_CFLAGS: $speexdsp_CFLAGS"
-+ echo " speexdsp_LIBS: $speexdsp_LIBS"
- fi
-diff --git a/pph/Makefile.am b/pph/Makefile.am
-index d24176c..551e5bd 100644
---- a/pph/Makefile.am
-+++ b/pph/Makefile.am
-@@ -2,15 +2,16 @@ asound_module_rate_speexrate_LTLIBRARIES = libasound_module_rate_speexrate.la
-
- asound_module_rate_speexratedir = @ALSA_PLUGIN_DIR@
-
--AM_CFLAGS = -DVAR_ARRAYS -DRANDOM_PREFIX=alsa_lib -DOUTSIDE_SPEEX -Wall -g @ALSA_CFLAGS@
-+AM_CFLAGS = -DVAR_ARRAYS -Wall -g @ALSA_CFLAGS@
- AM_LDFLAGS = -module -avoid-version -export-dynamic -no-undefined $(LDFLAGS_NOUNDEFINED)
-
- libasound_module_rate_speexrate_la_SOURCES = rate_speexrate.c
- libasound_module_rate_speexrate_la_LIBADD = @ALSA_LIBS@
- if USE_LIBSPEEX
--AM_CFLAGS += @speex_CFLAGS@
--libasound_module_rate_speexrate_la_LIBADD += @speex_LIBS@
-+AM_CFLAGS += @speexdsp_CFLAGS@
-+libasound_module_rate_speexrate_la_LIBADD += @speexdsp_LIBS@
- else
-+AM_CFLAGS += -DRANDOM_PREFIX=alsa_lib -DOUTSIDE_SPEEX
- libasound_module_rate_speexrate_la_SOURCES += resample.c
- libasound_module_rate_speexrate_la_LIBADD += -lm
- endif
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.20-automagic.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.20-automagic.patch
deleted file mode 100644
index 512ccc755e06..000000000000
--- a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.20-automagic.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur alsa-plugins-1.0.20.orig/Makefile.am alsa-plugins-1.0.20/Makefile.am
---- alsa-plugins-1.0.20.orig/Makefile.am 2009-05-06 10:07:28.000000000 +0300
-+++ alsa-plugins-1.0.20/Makefile.am 2009-08-01 18:23:26.000000000 +0300
-@@ -17,7 +17,7 @@
- if HAVE_PPH
- SUBDIRS += pph
- endif
--if HAVE_SPEEXDSP
-+if USE_LIBSPEEX
- SUBDIRS += speex
- endif
-
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.22-automagic.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.22-automagic.patch
deleted file mode 100644
index f7d9e7dc437a..000000000000
--- a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.22-automagic.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur alsa-plugins-1.0.21.orig/Makefile.am alsa-plugins-1.0.21/Makefile.am
---- alsa-plugins-1.0.21.orig/Makefile.am 2009-05-06 10:07:28.000000000 +0300
-+++ alsa-plugins-1.0.21/Makefile.am 2009-08-01 18:23:26.000000000 +0300
-@@ -17,7 +17,7 @@
- if HAVE_PPH
- SUBDIRS += pph
- endif
--if HAVE_SPEEXDSP
-+if USE_LIBSPEEX
- SUBDIRS += speex
- endif
-
diff --git a/media-plugins/alsa-plugins/files/ffmpeg-headers.patch b/media-plugins/alsa-plugins/files/ffmpeg-headers.patch
deleted file mode 100644
index 86026d48d54c..000000000000
--- a/media-plugins/alsa-plugins/files/ffmpeg-headers.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -ru alsa-plugins-1.0.17.orig/a52/pcm_a52.c alsa-plugins-1.0.17/a52/pcm_a52.c
---- alsa-plugins-1.0.17.orig/a52/pcm_a52.c 2008-08-06 18:28:39.000000000 +0200
-+++ alsa-plugins-1.0.17/a52/pcm_a52.c 2008-08-06 18:28:54.000000000 +0200
-@@ -18,6 +18,7 @@
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- */
-
-+#include "config.h"
- #include <stdio.h>
- #include <string.h>
- #define __USE_XOPEN
-@@ -25,7 +26,11 @@
- #include <alsa/asoundlib.h>
- #include <alsa/pcm_external.h>
- #include <alsa/pcm_plugin.h>
-+#ifdef HAVE_FFMPEG_AVCODEC_H
- #include <ffmpeg/avcodec.h>
-+#elif defined(HAVE_LIBAVCODEC_AVCODEC_H)
-+#include <libavcodec/avcodec.h>
-+#endif
-
- struct a52_ctx {
- snd_pcm_ioplug_t io;
-diff -ru alsa-plugins-1.0.17.orig/configure.in alsa-plugins-1.0.17/configure.in
---- alsa-plugins-1.0.17.orig/configure.in 2008-08-06 18:28:39.000000000 +0200
-+++ alsa-plugins-1.0.17/configure.in 2008-08-06 18:31:00.000000000 +0200
-@@ -77,7 +77,7 @@
- if test "x$enable_avcodec" != "xno"; then
- AC_CHECK_LIB([avcodec], [avcodec_open], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
- if test x$HAVE_AVCODEC = xyes; then
-- AC_CHECK_HEADER([ffmpeg/avcodec.h], [], [HAVE_AVCODEC=no])
-+ AC_CHECK_HEADERS([ffmpeg/avcodec.h], , [AC_CHECK_HEADERS([libavcodec/avcodec.h], , [HAVE_AVCODEC=no])])
- fi
- fi
- AM_CONDITIONAL(HAVE_AVCODEC, test x$HAVE_AVCODEC = xyes)
-diff -ru alsa-plugins-1.0.17.orig/rate-lavc/rate_lavcrate.c alsa-plugins-1.0.17/rate-lavc/rate_lavcrate.c
---- alsa-plugins-1.0.17.orig/rate-lavc/rate_lavcrate.c 2008-08-06 18:28:39.000000000 +0200
-+++ alsa-plugins-1.0.17/rate-lavc/rate_lavcrate.c 2008-08-06 18:28:54.000000000 +0200
-@@ -16,10 +16,15 @@
- * Lesser General Public License for more details.
- */
-
-+#include "config.h"
- #include <stdio.h>
- #include <alsa/asoundlib.h>
- #include <alsa/pcm_rate.h>
-+#ifdef HAVE_FFMPEG_AVCODEC_H
- #include <ffmpeg/avcodec.h>
-+#elif defined(HAVE_LIBAVCODEC_AVCODEC_H)
-+#include <libavcodec/avcodec.h>
-+#endif
- #include "gcd.h"
-
- static int filter_size = 16;