summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-03-12 17:22:31 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-03-12 17:22:31 +0000
commitb47138a6acd0343d848c4406ab95febedfcef930 (patch)
tree9c21c61356bc7f758a04b8c4f93d9923fc551a0c /media-plugins
parentRevert back to ~ppc64 because this is not ready to be stabilized. (diff)
downloadgentoo-2-b47138a6acd0343d848c4406ab95febedfcef930.tar.gz
gentoo-2-b47138a6acd0343d848c4406ab95febedfcef930.tar.bz2
gentoo-2-b47138a6acd0343d848c4406ab95febedfcef930.zip
bump; rev 30 is not offiziell released, but is tagged as 0.3.4 in svn
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog12
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_gcc-4.4.x.diff22
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_gentoo.diff139
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_vdr-1.7.26_ChannelSwitch.patch36
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild93
5 files changed, 300 insertions, 2 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index a3bd0b64ca4e..98d8624096f4 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/vdr-graphtft
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.27 2011/04/06 17:08:37 idl0r Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.28 2012/03/12 17:22:31 hd_brummy Exp $
+
+*vdr-graphtft-0.3.4 (12 Mar 2012)
+
+ 12 Mar 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +vdr-graphtft-0.3.4.ebuild, +files/vdr-graphtft-0.3.4_gcc-4.4.x.diff,
+ +files/vdr-graphtft-0.3.4_gentoo.diff,
+ +files/vdr-graphtft-0.3.4_vdr-1.7.26_ChannelSwitch.patch:
+ bump; rev 30 is not offiziell released, but is tagged as 0.3.4 in svn
06 Apr 2011; Christian Ruppert <idl0r@gentoo.org>
vdr-graphtft-0.2.2-r1.ebuild, vdr-graphtft-0.3.2.24.ebuild:
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_gcc-4.4.x.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_gcc-4.4.x.diff
new file mode 100644
index 000000000000..4e32c187ac10
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_gcc-4.4.x.diff
@@ -0,0 +1,22 @@
+diff -Naur graphtft-30.orig/graphtft-fe/common.cc graphtft-30/graphtft-fe/common.cc
+--- graphtft-30.orig/graphtft-fe/common.cc 2012-03-12 02:10:38.000000000 +0100
++++ graphtft-30/graphtft-fe/common.cc 2012-03-12 02:30:16.000000000 +0100
+@@ -11,6 +11,7 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #include <graphtft.hpp>
+
+diff -Naur graphtft-30.orig/graphtft-fe/graphtft.hpp graphtft-30/graphtft-fe/graphtft.hpp
+--- graphtft-30.orig/graphtft-fe/graphtft.hpp 2012-03-12 02:10:38.000000000 +0100
++++ graphtft-30/graphtft-fe/graphtft.hpp 2012-03-12 02:30:57.000000000 +0100
+@@ -16,6 +16,7 @@
+ #include <X11/Xlib.h>
+ #include <Imlib2.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #define __FRONTEND
+ #include <../common.h>
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_gentoo.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_gentoo.diff
new file mode 100644
index 000000000000..ea0e7ad3d748
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_gentoo.diff
@@ -0,0 +1,139 @@
+diff -Naur graphtft-30.orig/dfbrenderer/dfbrenderer.c graphtft-30/dfbrenderer/dfbrenderer.c
+--- graphtft-30.orig/dfbrenderer/dfbrenderer.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/dfbrenderer/dfbrenderer.c 2012-03-12 03:29:35.000000000 +0100
+@@ -257,7 +257,7 @@
+ {
+ // make path relative to the themes directory
+
+- asprintf(&path, "%s/graphTFT/themes/%s/%s",
++ asprintf(&path, "%s/themes/%s/%s",
+ confPath.c_str(), themePath.c_str(), p.c_str());
+ }
+ else
+@@ -281,7 +281,7 @@
+
+ // at least add the default path
+
+- asprintf(&path, "%s/graphTFT/fonts/", confPath.c_str());
++ asprintf(&path, "%s/fonts/", confPath.c_str());
+ tell(0, "Info: Adding font path '%s'", path);
+ fontPaths[count] = path;
+ free(path);
+@@ -483,7 +483,7 @@
+ else
+ {
+ const char* tmp = themePath.c_str();
+- asprintf(&fpath, "%s/graphTFT/themes/%s/%s", confPath.c_str(), tmp, fname);
++ asprintf(&fpath, "%s/themes/%s/%s", confPath.c_str(), tmp, fname);
+ }
+
+ tell(4,"creating imageprovider for %s", fpath);
+@@ -561,7 +561,7 @@
+ else
+ {
+ const char* tmp = themePath.c_str();
+- asprintf(&fpath, "%s/graphTFT/themes/%s/%s", confPath.c_str(), tmp, fname);
++ asprintf(&fpath, "%s/themes/%s/%s", confPath.c_str(), tmp, fname);
+ }
+
+ tell(4,"creating imageprovider for %s", fpath);
+diff -Naur graphtft-30.orig/dspitems.c graphtft-30/dspitems.c
+--- graphtft-30.orig/dspitems.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/dspitems.c 2012-03-12 03:30:16.000000000 +0100
+@@ -107,7 +107,7 @@
+ if (p[0] != '/')
+ {
+ p = string(GraphTFTSetup.PluginConfPath)
+- + "/graphTFT/themes/"
++ + "/themes/"
+ + string(Thms::theTheme->getDir())
+ + "/" + p;
+ }
+diff -Naur graphtft-30.orig/graphtft.c graphtft-30/graphtft.c
+--- graphtft-30.orig/graphtft.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/graphtft.c 2012-03-12 03:32:48.000000000 +0100
+@@ -22,6 +22,8 @@
+ #include <graphtft.h>
+ #include <span.h>
+
++#define DATA_DIR "/usr/share/vdr/graphTFT"
++
+ //***************************************************************************
+ // cGraphTFTMenu
+ //***************************************************************************
+@@ -300,13 +302,13 @@
+
+ // try to get the config dir
+
+- if (!ConfigDirectory())
+- return false;
++// if (!ConfigDirectory())
++// return false;
+
+ // init
+
+ GraphTFTSetup.setClient(this);
+- GraphTFTSetup.PluginConfPath = strdup(ConfigDirectory());
++ GraphTFTSetup.PluginConfPath = strdup(DATA_DIR);
+
+ #if APIVERSNUM < 10507
+ RegisterI18n(Phrases);
+@@ -322,7 +324,7 @@
+ if (loadThemes() != 0)
+ return false;
+
+- if (display->Init(_dev, ConfigDirectory(), port) != success)
++ if (display->Init(_dev, DATA_DIR, port) != success)
+ {
+ tell(0, "Error: Initializing graphTFT device faild, aborting!");
+
+@@ -355,8 +357,8 @@
+
+ // look for the themes in the config directory
+
+- asprintf(&buffer, "find %s/graphTFT/themes -follow -type f -name '*.theme' | sort",
+- ConfigDirectory());
++ asprintf(&buffer, "find %s/themes -follow -type f -name '*.theme' | sort",
++ DATA_DIR);
+
+ p = popen(buffer, "r");
+
+diff -Naur graphtft-30.orig/imlibrenderer/imlibrenderer.c graphtft-30/imlibrenderer/imlibrenderer.c
+--- graphtft-30.orig/imlibrenderer/imlibrenderer.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/imlibrenderer/imlibrenderer.c 2012-03-12 03:33:54.000000000 +0100
+@@ -123,7 +123,7 @@
+ {
+ // make path relative to the themes directory
+
+- asprintf(&path, "%s/graphTFT/themes/%s/%s",
++ asprintf(&path, "%s/themes/%s/%s",
+ confPath.c_str(), themePath.c_str(), p.c_str());
+ }
+ else
+@@ -146,7 +146,7 @@
+
+ // at least add the default path
+
+- asprintf(&path, "%s/graphTFT/fonts/", confPath.c_str());
++ asprintf(&path, "%s/fonts/", confPath.c_str());
+ tell(0, "Info: Adding font path '%s'", path);
+ imlib_add_path_to_font_path(path);
+ free(path);
+@@ -217,7 +217,7 @@
+ if (fname[0] == '/')
+ path << fname;
+ else
+- path << confPath << "/graphTFT/themes/" << themePath << "/" << fname;
++ path << confPath << "/themes/" << themePath << "/" << fname;
+
+ if (!fileExists(path.str().c_str()))
+ {
+@@ -291,7 +291,7 @@
+ if (fname[0] == '/')
+ path << fname;
+ else
+- path << confPath << "/graphTFT/themes/" << themePath << "/" << fname;
++ path << confPath << "/themes/" << themePath << "/" << fname;
+
+ if (!fileExists(path.str().c_str()))
+ {
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_vdr-1.7.26_ChannelSwitch.patch b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_vdr-1.7.26_ChannelSwitch.patch
new file mode 100644
index 000000000000..a2e5a6665e73
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.4_vdr-1.7.26_ChannelSwitch.patch
@@ -0,0 +1,36 @@
+--- graphtft-0.3.4/display.c.orig 2011-10-18 10:55:14.000000000 +0200
++++ graphtft-0.3.4/display.c 2012-03-11 11:52:32.545415663 +0100
+@@ -931,12 +931,15 @@
+ // Osd Channel Switch
+ //***************************************************************************
+
+-void cGraphTFTDisplay::ChannelSwitch(const cDevice* Device, int ChannelNumber)
+-{
++#if VDRVERSNUM >= 10726
++void cGraphTFTDisplay::ChannelSwitch(const cDevice* Device, int ChannelNumber, bool LiveView) {
++#else
++void cGraphTFTDisplay::ChannelSwitch(const cDevice* Device, int ChannelNumber) {
++ bool LiveView = Device && Device->IsPrimaryDevice() && !EITScanner.UsesDevice(Device);
++#endif
+ tell(5, "ChannelSwitch on %p: %d", Device, ChannelNumber);
+
+- if (Device->IsPrimaryDevice()
+- && !EITScanner.UsesDevice(Device)
++ if (LiveView
+ && _channel != ChannelNumber
+ && cDevice::CurrentChannel() != _channel)
+ {
+--- graphtft-0.3.4/display.h.orig 2011-10-18 10:55:14.000000000 +0200
++++ graphtft-0.3.4/display.h 2012-03-11 11:57:28.705392921 +0100
+@@ -348,7 +348,11 @@
+
+ // status interface
+
++#if VDRVERSNUM >= 10726
++ virtual void ChannelSwitch(const cDevice* Device, int ChannelNumber, bool LiveView);
++#else
+ virtual void ChannelSwitch(const cDevice* Device, int ChannelNumber);
++#endif
+ virtual void OsdSetEvent(const cEvent* event);
+ virtual void OsdSetRecording(const cRecording* recording);
+ virtual void OsdChannel(const char* Text);
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild
new file mode 100644
index 000000000000..0ea92767ef32
--- /dev/null
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild,v 1.1 2012/03/12 17:22:31 hd_brummy Exp $
+
+EAPI="4"
+
+RESTRICT="test"
+
+inherit eutils vdr-plugin flag-o-matic
+
+S="${WORKDIR}/graphtft-30"
+
+DESCRIPTION="VDR plugin: GraphTFT"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Graphtft-plugin"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+IUSE_THEMES="+theme_deepblue theme_avp theme_deeppurple theme_poetter"
+IUSE="${IUSE_THEMES} directfb graphtft-fe imagemagick touchscreen"
+
+DEPEND=">=media-video/vdr-1.6.0_p2-r1[graphtft]
+ media-libs/imlib2[png,jpeg]
+ gnome-base/libgtop
+ >=virtual/ffmpeg-0.4.8_p20090201
+ imagemagick? ( media-gfx/imagemagick[png,jpeg,cxx] )
+ directfb? ( dev-libs/DirectFB )
+ graphtft-fe? ( media-libs/imlib2[png,jpeg,X] )"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND="theme_deepblue? ( =x11-themes/vdrgraphtft-deepblue-0.3.1 )
+ theme_avp? ( =x11-themes/vdrgraphtft-avp-0.3.1 )
+ theme_deeppurple? ( =x11-themes/vdrgraphtft-deeppurple-0.3.2 )
+ theme_poetter? ( =x11-themes/vdrgraphtft-poetter-0.3.2 )"
+
+PATCHES=("${FILESDIR}/${P}_gentoo.diff"
+ "${FILESDIR}/${PN}-0.3.2.24_makefile.diff"
+ "${FILESDIR}/${P}_gcc-4.4.x.diff"
+ "${FILESDIR}/${P}_vdr-1.7.26_ChannelSwitch.patch")
+
+src_prepare() {
+
+ sed -i Makefile -e "s: WITH_X_COMM = 1:#WITH_X_COMM = 1:"
+
+ ! use touchscreen && sed -i Makefile -e "s:WITH_TOUCH = 1:#WITH_TOUCH = 1:"
+
+ use graphtft-fe && sed -i Makefile \
+ -e "s:#WITH_X_COMM:WITH_X_COMM:"
+
+ vdr-plugin_src_prepare
+
+ sed -i "${S}"/imlibrenderer/fbrenderer/fbrenderer.c \
+ -i "${S}"/imlibrenderer/dvbrenderer/mpeg2encoder.c \
+ -e "s:libavutil/avcodec.h:libavcodec/avcodec.h:"
+
+ # UINT64_C is needed by ffmpeg headers
+ append-flags -D__STDC_CONSTANT_MACROS
+}
+
+src_compile() {
+ vdr-plugin_src_compile
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe
+ emake
+ fi
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ dodoc "${S}"/documents/{README,HISTORY,HOWTO.Themes,INSTALL}
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe && dobin graphtft-fe
+ doinit graphtft-fe
+ fi
+}
+
+pkg_postinst() {
+ vdr-plugin_pkg_postinst
+
+ if use graphtft-fe; then
+ echo
+ elog "Graphtft-fe user:"
+ elog "Edit /etc/conf.d/vdr.graphtft"
+ elog "/etc/init.d/graphtft-fe start"
+ echo
+ fi
+}