summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-05-04 09:27:17 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-05-04 09:27:17 +0000
commit839dddd1820a39efdec21b8b2fd978c0e2ad8a33 (patch)
tree493bbc077497996d0b9c7980170b6feb21af4737 /media-sound/alsa-driver
parentVersion bump (diff)
downloadgentoo-2-839dddd1820a39efdec21b8b2fd978c0e2ad8a33.tar.gz
gentoo-2-839dddd1820a39efdec21b8b2fd978c0e2ad8a33.tar.bz2
gentoo-2-839dddd1820a39efdec21b8b2fd978c0e2ad8a33.zip
Version bump
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog7
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.3a.ebuild93
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.3a1
3 files changed, 100 insertions, 1 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 458083a60c73..bb9618cab22a 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.33 2003/05/03 16:49:51 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.34 2003/05/04 09:27:17 aliz Exp $
*alsa-driver-0.9.3 (05 May 2003)
05 May 2003; Arcady Genkin <agenkin@gentoo.org> :
Version update.
+*alsa-driver-0.9.3a (04 May 2003)
+
+ 04 May 2003; Daniel Ahlberg <aliz@gentoo.org> alsa-driver-0.9.3a.ebuild :
+ Version bump.
+
*alsa-driver-0.9.2 (27 Mar 2003)
15 Apr 2003; Arcady Genkin <agenkin@gentoo.org> :
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.3a.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.3a.ebuild
new file mode 100644
index 000000000000..b3329de6a811
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.3a.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.3a.ebuild,v 1.1 2003/05/04 09:27:17 aliz Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="0.9"
+KEYWORDS="~x86 ~ppc"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ # Arcady Genkin <agenkin@thpoon.com>
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ make || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You need to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use 'alsamixer' program to unmute them."
+ einfo
+}
+
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.3a b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.3a
new file mode 100644
index 000000000000..2f72020c5a5c
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.3a
@@ -0,0 +1 @@
+MD5 079f16ea29cf549a610337af31894a73 alsa-driver-0.9.3a.tar.bz2 1517655