summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-03-25 12:08:43 +0000
committerSimon Stelling <blubb@gentoo.org>2006-03-25 12:08:43 +0000
commitde5f38695a32870f978412ab842c735dd6d9e2c1 (patch)
treec04ec6f6e73afbda337a41fb3049901faf22d254 /media-sound/alsa-driver
parentRevision bump of thinkpad, with patches from TGL <degrenier@easyconnect.fr> t... (diff)
downloadgentoo-2-de5f38695a32870f978412ab842c735dd6d9e2c1.tar.gz
gentoo-2-de5f38695a32870f978412ab842c735dd6d9e2c1.tar.bz2
gentoo-2-de5f38695a32870f978412ab842c735dd6d9e2c1.zip
improve KERNEL_ABI patch
(Portage version: 2.1_pre6-r1)
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog6
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild8
2 files changed, 10 insertions, 4 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index e115bc8941ac..819348e4ff24 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.201 2006/03/25 10:35:47 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.202 2006/03/25 12:08:43 blubb Exp $
+
+ 25 Mar 2006; Simon Stelling <blubb@gentoo.org>
+ alsa-driver-1.0.11_rc4.ebuild:
+ improve KERNEL_ABI patch
25 Mar 2006; Simon Stelling <blubb@gentoo.org>
alsa-driver-1.0.11_rc4.ebuild:
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild
index 9ebffa8c36c3..410ca843647b 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild,v 1.2 2006/03/25 10:35:47 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.11_rc4.ebuild,v 1.3 2006/03/25 12:08:43 blubb Exp $
inherit linux-mod flag-o-matic eutils multilib
@@ -63,8 +63,6 @@ pkg_setup() {
export CBUILD=${CBUILD-${CHOST}}
export CHOST="sparc64-unknown-linux-gnu"
fi
-
- ABI=${KERNEL_ABI}
}
src_unpack() {
@@ -79,6 +77,8 @@ src_unpack() {
}
src_compile() {
+ local myABI=${ABI:-${DEFAULT_ABI}}
+
# Should fix bug #46901
is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
@@ -94,9 +94,11 @@ src_compile() {
# linux-mod_src_compile doesn't work well with alsa
ARCH=$(tc-arch-kernel)
+ ABI=${KERNEL_ABI}
# -j1 : see bug #71028
emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
ARCH=$(tc-arch)
+ ABI=${myABI}
if use doc;
then