summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-22 16:06:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-22 16:06:33 +0000
commit14457802136e4720fab31221cc742d3e154d9873 (patch)
treeb5d416b90aed6cc2e743cb0603ecf4cccc7fb9ea /media-sound/amarok/files
parentAdd patch to fix bug #157752 thanks to Grant McDorman for reporting; correct ... (diff)
downloadgentoo-2-14457802136e4720fab31221cc742d3e154d9873.tar.gz
gentoo-2-14457802136e4720fab31221cc742d3e154d9873.tar.bz2
gentoo-2-14457802136e4720fab31221cc742d3e154d9873.zip
Add patch to fix bug #157752 thanks to Grant McDorman for reporting; correct dependency for postgresql/libpq, thanks to Julien Allanos in bug #158812; remove old version, move patches on their own tarball to reduce size of filesdir.
(Portage version: 2.1.2_rc3-r9) (Signed Manifest commit)
Diffstat (limited to 'media-sound/amarok/files')
-rw-r--r--media-sound/amarok/files/amarok-1.4.4-asneeded.patch26
-rw-r--r--media-sound/amarok/files/amarok-1.4.4-lastfm+xine-lib-1.1.3.patch25
-rw-r--r--media-sound/amarok/files/amarok-1.4.4-musicbrainz.patch12
-rw-r--r--media-sound/amarok/files/amarok-1.4.4-podcast-fix.patch17
-rw-r--r--media-sound/amarok/files/amarok-1.4.4-sparc.patch11
-rw-r--r--media-sound/amarok/files/digest-amarok-1.4.43
-rw-r--r--media-sound/amarok/files/digest-amarok-1.4.4-r13
-rw-r--r--media-sound/amarok/files/digest-amarok-1.4.4-r23
8 files changed, 0 insertions, 100 deletions
diff --git a/media-sound/amarok/files/amarok-1.4.4-asneeded.patch b/media-sound/amarok/files/amarok-1.4.4-asneeded.patch
deleted file mode 100644
index 90eb2b982e89..000000000000
--- a/media-sound/amarok/files/amarok-1.4.4-asneeded.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: amarok/configure.in.in
-===================================================================
---- amarok/configure.in.in (revision 606189)
-+++ amarok/configure.in.in (revision 606190)
-@@ -886,10 +886,10 @@
- if test "x$have_libgpod" = "xyes"; then
- ac_cppflags_save=$CPPFLAGS
- ac_cflags_save=$CFLAGS
-- ac_ldflags_save=$LDFLAGS
-+ ac_libs_save=$LIBS
- CPPFLAGS="$CPPFLAGS $LIBGPOD_INCLUDES"
- CFLAGS="$CFLAGS $LIBGPOD_CFLAGS"
-- LDFLAGS="$LDFLAGS $LIBGPOD_LIBS"
-+ LIBS="$LIBS $LIBGPOD_LIBS"
-
- AC_CHECK_FUNCS(itdb_track_set_thumbnails, have_libgpod_artwork=yes)
- AC_CHECK_FUNCS(itdb_get_mountpoint)
-@@ -917,7 +917,7 @@
-
- CPPFLAGS=$ac_cppflags_save
- CFLAGS=$ac_cflags_save
-- LDFLAGS=$ac_ldflags_save
-+ LIBS=$ac_libs_save
- fi
- fi
- fi
diff --git a/media-sound/amarok/files/amarok-1.4.4-lastfm+xine-lib-1.1.3.patch b/media-sound/amarok/files/amarok-1.4.4-lastfm+xine-lib-1.1.3.patch
deleted file mode 100644
index fde2e41bd301..000000000000
--- a/media-sound/amarok/files/amarok-1.4.4-lastfm+xine-lib-1.1.3.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: amarok-1.4.4/amark/src/amarok_proxy.rb
-===================================================================
---- amarok-1.4.4/amarok/src/amarok_proxy.rb (revision 609364)
-+++ amarok-1.4.4/amarok/src/amarok_proxy.rb (revision 609365)
-@@ -117,6 +117,11 @@
- def cp_to_empty_outward( income, output )
- myputs "cp_to_empty_outward( income => #{income.inspect}, output => #{output.inspect}"
- income.each_line do |data|
-+ if data =~ /User-Agent: xine\/([0-9.]+)/
-+ version = $1.split(".").collect { |v| v.to_i }
-+ myputs("Found xine user agent version #{version.join(".")}")
-+ @xineworkaround = ( version[0] <= 1 && version[1] <= 1 && version[2] <= 2 )
-+ end
- myputs( data )
- data.chomp!
- safe_write( output, data )
-@@ -142,7 +147,7 @@
-
- def cp_all_inward( income, output )
- myputs( "cp_all( income => #{income.inspect}, output => #{output.inspect}" )
-- if self.is_a?( LastFM ) and @engine == 'xine-engine'
-+ if self.is_a?( LastFM ) and @xineworkaround
- myputs( "Using buffer fill workaround." )
- filler = Array.new( 4096, 0 )
- safe_write( output, filler ) # HACK: Fill xine's buffer so that xine_open() won't block
diff --git a/media-sound/amarok/files/amarok-1.4.4-musicbrainz.patch b/media-sound/amarok/files/amarok-1.4.4-musicbrainz.patch
deleted file mode 100644
index 76af067cbb5f..000000000000
--- a/media-sound/amarok/files/amarok-1.4.4-musicbrainz.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: amarok-1.4.4/amarok/src/tagdialog.cpp
-===================================================================
---- amarok-1.4.4.orig/amarok/src/tagdialog.cpp
-+++ amarok-1.4.4/amarok/src/tagdialog.cpp
-@@ -286,6 +286,7 @@ TagDialog::musicbrainzQuery() //SLOT
- m_mbTrack = m_bundle.url();
- KTRMLookup* ktrm = new KTRMLookup( m_mbTrack.path(), true );
- connect( ktrm, SIGNAL( sigResult( KTRMResultList, QString ) ), SLOT( queryDone( KTRMResultList, QString ) ) );
-+ connect( pushButton_cancel, SIGNAL(clicked()), ktrm, SLOT(deleteLater()));
-
- pushButton_musicbrainz->setEnabled( false );
- pushButton_musicbrainz->setText( i18n( "Generating audio fingerprint..." ) );
diff --git a/media-sound/amarok/files/amarok-1.4.4-podcast-fix.patch b/media-sound/amarok/files/amarok-1.4.4-podcast-fix.patch
deleted file mode 100644
index 26a5974b5bc1..000000000000
--- a/media-sound/amarok/files/amarok-1.4.4-podcast-fix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: amarok-1.4.4/amarok/src/playlistbrowseritem.cpp
-===================================================================
---- amarok-1.4.4.orig/amarok/src/playlistbrowseritem.cpp
-+++ amarok-1.4.4/amarok/src/playlistbrowseritem.cpp
-@@ -2051,10 +2051,10 @@ PodcastChannel::episodeExists( const QDo
- }
-
- QString episodeTitle = xml.namedItem( "title" ).toElement().text();
-- QString episodeURL = xml.namedItem( "enclosure" ).toElement().attribute( "url" );
-+ KURL episodeURL = xml.namedItem( "enclosure" ).toElement().attribute( "url" );
- command = QString("SELECT id FROM podcastepisodes WHERE parent='%1' AND url='%2' AND title='%3';")
- .arg( CollectionDB::instance()->escapeString( url().url() ),
-- CollectionDB::instance()->escapeString( episodeURL ),
-+ CollectionDB::instance()->escapeString( episodeURL.url() ),
- CollectionDB::instance()->escapeString( episodeTitle ) );
- QStringList values = CollectionDB::instance()->query( command );
- return !values.isEmpty();
diff --git a/media-sound/amarok/files/amarok-1.4.4-sparc.patch b/media-sound/amarok/files/amarok-1.4.4-sparc.patch
deleted file mode 100644
index 5cb14ac3e4cb..000000000000
--- a/media-sound/amarok/files/amarok-1.4.4-sparc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- amarok/src/mediadevice/daap/mongrel/http11/Makefile.am.orig 2006-11-02 23:22:08.000000000 -0800
-+++ amarok/src/mediadevice/daap/mongrel/http11/Makefile.am 2006-11-02 23:22:22.000000000 -0800
-@@ -4,7 +4,7 @@
-
- amarokrubylib_DATA = http11.rb
-
--INCLUDES = -I$(ruby_includes) -Dinline=__inline__
-+INCLUDES = -I$(ruby_includes) -Dinline=__inline__ -Dasm=__asm__
-
- libhttp11_la_LDFLAGS = \
- -shared \
diff --git a/media-sound/amarok/files/digest-amarok-1.4.4 b/media-sound/amarok/files/digest-amarok-1.4.4
deleted file mode 100644
index 9f4ed3ac99e9..000000000000
--- a/media-sound/amarok/files/digest-amarok-1.4.4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 56a9aec42088c338b81252f8e0651781 amarok-1.4.4.tar.bz2 17635707
-RMD160 61cd2748ce0111f4ba388a71e9504abb7362b0d7 amarok-1.4.4.tar.bz2 17635707
-SHA256 760d30337cb73c86b9298e5c2c9836b3a753c39805b54f75b1eea82c15e9a0ea amarok-1.4.4.tar.bz2 17635707
diff --git a/media-sound/amarok/files/digest-amarok-1.4.4-r1 b/media-sound/amarok/files/digest-amarok-1.4.4-r1
deleted file mode 100644
index 9f4ed3ac99e9..000000000000
--- a/media-sound/amarok/files/digest-amarok-1.4.4-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 56a9aec42088c338b81252f8e0651781 amarok-1.4.4.tar.bz2 17635707
-RMD160 61cd2748ce0111f4ba388a71e9504abb7362b0d7 amarok-1.4.4.tar.bz2 17635707
-SHA256 760d30337cb73c86b9298e5c2c9836b3a753c39805b54f75b1eea82c15e9a0ea amarok-1.4.4.tar.bz2 17635707
diff --git a/media-sound/amarok/files/digest-amarok-1.4.4-r2 b/media-sound/amarok/files/digest-amarok-1.4.4-r2
deleted file mode 100644
index 9f4ed3ac99e9..000000000000
--- a/media-sound/amarok/files/digest-amarok-1.4.4-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 56a9aec42088c338b81252f8e0651781 amarok-1.4.4.tar.bz2 17635707
-RMD160 61cd2748ce0111f4ba388a71e9504abb7362b0d7 amarok-1.4.4.tar.bz2 17635707
-SHA256 760d30337cb73c86b9298e5c2c9836b3a753c39805b54f75b1eea82c15e9a0ea amarok-1.4.4.tar.bz2 17635707