summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-08-24 01:17:32 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-08-24 01:17:32 +0000
commit1053b56ee107ceaaf704f8e5efbda9f35f0bd47c (patch)
treec021badc68b8cc79e0197b3129e4418740c96b9f /media-sound/amarok
parentAdd support for txz archives by Marcin Baczyński #334027. (diff)
downloadgentoo-2-1053b56ee107ceaaf704f8e5efbda9f35f0bd47c.tar.gz
gentoo-2-1053b56ee107ceaaf704f8e5efbda9f35f0bd47c.tar.bz2
gentoo-2-1053b56ee107ceaaf704f8e5efbda9f35f0bd47c.zip
Added amarok 2.3.1.90 (2.3.2 Beta1).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/amarok-2.3.1.90.ebuild150
2 files changed, 157 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 29293768c5a8..443daafb6420 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.386 2010/08/10 12:55:46 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.387 2010/08/24 01:17:32 jmbsvicetto Exp $
+
+*amarok-2.3.1.90 (24 Aug 2010)
+
+ 24 Aug 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-2.3.1.90.ebuild:
+ Added amarok 2.3.1.90 (2.3.2 Beta1).
10 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-amarok-2.2.2-r1.ebuild, -files/amarok-2.2.2-nodebug.patch,
diff --git a/media-sound/amarok/amarok-2.3.1.90.ebuild b/media-sound/amarok/amarok-2.3.1.90.ebuild
new file mode 100644
index 000000000000..e9ec37745ded
--- /dev/null
+++ b/media-sound/amarok/amarok-2.3.1.90.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.3.1.90.ebuild,v 1.1 2010/08/24 01:17:32 jmbsvicetto Exp $
+
+EAPI="2"
+
+# Translations are only in the tarballs, not the git repo
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="af bg ca ca@valencia cs da de el en_GB es et fr it ja lt lv nb nds pa pl
+ pt pt_BR ru sk sl sr sr@ijekavian sr@ijekavianlatin sr@latin sv th tr uk zh_CN zh_TW"
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+else
+ EGIT_REPO_URI="git://git.kde.org/${PN}/${PN}.git"
+ GIT_ECLASS="git"
+fi
+
+KDE_REQUIRED="never"
+inherit flag-o-matic kde4-base ${GIT_ECLASS}
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="cdda daap debug embedded ipod lastfm mp3tunes mtp opengl +player semantic-desktop +utils"
+
+# Tests require gmock - http://code.google.com/p/gmock/
+# It's not in the tree yet
+RESTRICT="test"
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+COMMONDEPEND="
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ player? (
+ app-crypt/qca:2
+ >=app-misc/strigi-0.5.7[dbus,qt4]
+ || ( >=dev-db/mysql-5.0.76 =virtual/mysql-5.1 )
+ >=kde-base/kdelibs-${KDE_MINIMAL}[opengl?,semantic-desktop?]
+ sys-libs/zlib
+ x11-libs/qt-script
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ >=kde-base/libkcddb-${KDE_MINIMAL}
+ >=kde-base/libkcompactdisc-${KDE_MINIMAL}
+ >=kde-base/kdemultimedia-kioslaves-${KDE_MINIMAL}
+ )
+ embedded? ( <dev-db/mysql-5.1[embedded,-minimal] )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-0.3.0 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ x11-libs/qt-core[glib]
+ )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+ opengl? ( virtual/opengl )
+ )
+ utils? (
+ x11-libs/qt-core
+ x11-libs/qt-dbus
+ )
+ !player? ( !utils? ( media-sound/amarok[player] ) )
+"
+DEPEND="${COMMONDEPEND}
+ dev-util/automoc
+ dev-util/pkgconfig
+"
+RDEPEND="${COMMONDEPEND}
+ !media-sound/amarok-utils
+ player? ( >=kde-base/phonon-kde-${KDE_MINIMAL} )
+"
+
+src_prepare() {
+ if ! use player; then
+ # Disable po processing
+ sed -e "s:include(MacroOptionalAddSubdirectory)::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ sed -e "s:macro_optional_add_subdirectory( po )::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
+ use ppc64 && append-flags -mminimal-toc
+
+ if use player; then
+ mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ )
+ else
+ mycmakeargs=(
+ -DWITH_PLAYER=OFF
+ )
+ fi
+
+ mycmakeargs+=(
+ $(cmake-utils_use_with utils UTILITIES)
+ )
+ # $(cmake-utils_use_with semantic-desktop Nepomuk)
+ # $(cmake-utils_use_with semantic-desktop Soprano)
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use player; then
+
+ if use daap; then
+ echo
+ elog "You have installed amarok with daap support."
+ elog "You may be interested in installing www-servers/mongrel as well."
+ echo
+ fi
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amaroklive.com/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "dev-db/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+ fi
+}