summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2013-01-14 04:27:48 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2013-01-14 04:27:48 +0000
commit7192b30baaf0a8d3c2e3dad0c1d82ca6c29a1191 (patch)
treec0032024d57edaa4ea4a23742958a4caf1ccd621 /media-sound/amarok
parentVersion bump. (diff)
downloadgentoo-2-7192b30baaf0a8d3c2e3dad0c1d82ca6c29a1191.tar.gz
gentoo-2-7192b30baaf0a8d3c2e3dad0c1d82ca6c29a1191.tar.bz2
gentoo-2-7192b30baaf0a8d3c2e3dad0c1d82ca6c29a1191.zip
Applied reworked upstream patch by Matěj Laitl to fix a crash on startup related to the lastfm port - fixes bug 451476.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key BB0E6E98)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog7
-rw-r--r--media-sound/amarok/amarok-2.6.90.ebuild9
-rw-r--r--media-sound/amarok/files/amarok-2.6.90-fix-crash-lastfm.patch34
3 files changed, 48 insertions, 2 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index fff39f83890d..5106386c1435 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.440 2013/01/06 12:53:52 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.441 2013/01/14 04:27:48 jmbsvicetto Exp $
+
+ 14 Jan 2013; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +files/amarok-2.6.90-fix-crash-lastfm.patch, amarok-2.6.90.ebuild:
+ Applied reworked upstream patch by Matěj Laitl to fix a crash on startup
+ related to the lastfm port - fixes bug 451476.
*amarok-2.6.90 (06 Jan 2013)
diff --git a/media-sound/amarok/amarok-2.6.90.ebuild b/media-sound/amarok/amarok-2.6.90.ebuild
index fba3deabe2e6..46f0f1b65d98 100644
--- a/media-sound/amarok/amarok-2.6.90.ebuild
+++ b/media-sound/amarok/amarok-2.6.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.6.90.ebuild,v 1.1 2013/01/06 12:53:52 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.6.90.ebuild,v 1.2 2013/01/14 04:27:48 jmbsvicetto Exp $
EAPI=4
@@ -71,6 +71,13 @@ RDEPEND="${COMMONDEPEND}
$(add_kdebase_dep phonon-kde)
"
+# Reworked patch to apply cleanly on 2.6.90
+# commit 68f90970f51015b9410b0786fa4d861089ccd413
+# by Matěj Laitl <matej@laitl.cz>
+PATCHES=(
+ "${FILESDIR}/${P}-fix-crash-lastfm.patch"
+)
+
src_configure() {
# Append minimal-toc cflag for ppc64, see bug 280552 and 292707
use ppc64 && append-flags -mminimal-toc
diff --git a/media-sound/amarok/files/amarok-2.6.90-fix-crash-lastfm.patch b/media-sound/amarok/files/amarok-2.6.90-fix-crash-lastfm.patch
new file mode 100644
index 000000000000..b298c92937ab
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.6.90-fix-crash-lastfm.patch
@@ -0,0 +1,34 @@
+commit 68f90970f51015b9410b0786fa4d861089ccd413
+Author: Matěj Laitl <matej@laitl.cz>
+Date: Sat Dec 15 23:17:45 2012 +0100
+
+ ServiceBase::setModel(): prevent crash triggered by Last.fm rewrite
+
+ BUGFIXES:
+ * Prevent crash in ServiceBase::setModel triggered by Last.fm rewrite.
+
+ Lukáši, please test the patch so that we have no fear releasing 2.7
+ final.
+
+ BUG: 311723
+ FIXED-IN: 2.7
+
+diff -urN a/amarok-2.6.90/src/services/ServiceBase.cpp b/amarok-2.6.90/src/services/ServiceBase.cpp
+--- a/amarok-2.6.90/src/services/ServiceBase.cpp
++++ b/amarok-2.6.90/src/services/ServiceBase.cpp
+@@ -173,10 +173,9 @@ ServiceBase::itemActivated ( const QModelIndex & index )
+ void
+ ServiceBase::setModel( QAbstractItemModel * model )
+ {
+- //m_filterModel->setSourceModel( model );
+- //m_contentView->setModel( m_filterModel );
+- m_contentView->setModel( model );
+- m_model = model;
++ if( m_contentView )
++ m_contentView->setModel( model );
++ m_model = model;
+ }
+
+ QAbstractItemModel *
+
+