summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-24 02:50:25 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-24 02:50:25 +0000
commita941a85f1dab8e7adaff9ab204d8bb193f07d042 (patch)
tree9dd8573ff742d74ecfbfbb0a402c1bf3306ef8e5 /media-sound/amarok
parentMarking zemberek-server-0.7.1 ppc64 for bug 253054 (diff)
downloadgentoo-2-a941a85f1dab8e7adaff9ab204d8bb193f07d042.tar.gz
gentoo-2-a941a85f1dab8e7adaff9ab204d8bb193f07d042.tar.bz2
gentoo-2-a941a85f1dab8e7adaff9ab204d8bb193f07d042.zip
Bumped amarok-2.0.2 to include a lastfm patch. Thanks to Gustavo Henrique Nihei for poking me about it.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog9
-rw-r--r--media-sound/amarok/amarok-2.0.2-r3.ebuild90
-rw-r--r--media-sound/amarok/files/amarok-2.0.2-lastfm-authentication.patch34
3 files changed, 132 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index bcbbe655f261..f1c55baf3c30 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.320 2009/04/23 17:56:51 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.321 2009/04/24 02:50:23 jmbsvicetto Exp $
+
+*amarok-2.0.2-r3 (24 Apr 2009)
+
+ 24 Apr 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +files/amarok-2.0.2-lastfm-authentication.patch, +amarok-2.0.2-r3.ebuild:
+ Bumped amarok-2.0.2 to include a lastfm patch. Thanks to Gustavo Henrique
+ Nihei for poking me about it.
23 Apr 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-amarok-2.0.1.1.ebuild, -amarok-2.0.2-r1.ebuild:
diff --git a/media-sound/amarok/amarok-2.0.2-r3.ebuild b/media-sound/amarok/amarok-2.0.2-r3.ebuild
new file mode 100644
index 000000000000..1cf13caf57cd
--- /dev/null
+++ b/media-sound/amarok/amarok-2.0.2-r3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.0.2-r3.ebuild,v 1.1 2009/04/24 02:50:23 jmbsvicetto Exp $
+
+EAPI="2"
+
+KDE_LINGUAS="ar be bg ca cs csb da de el eo es et eu fi fr ga gl he is it ja km
+ ko ku lt lv nb nds ne nl nn oc pa pl pt pt_BR ro ru se si sk sl sv th tr uk zh_CN zh_TW"
+OPENGL_REQUIRED="optional"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="2"
+IUSE="cdaudio daap debug ifp ipod mp3tunes mp4 mtp njb +semantic-desktop"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+
+# Blocking amarok:0 until the KDE3 eclasses are updated
+# to move misc apps to /usr/kde/3.5
+DEPEND="
+ !media-sound/amarok:0
+ !media-sound/amarok-utils
+ >=app-misc/strigi-0.5.7
+ || (
+ >=dev-db/mysql-5.0.76-r1[embedded,-minimal]
+ >=dev-db/mysql-community-5.0.77-r1[embedded,-minimal]
+ )
+ >=media-libs/taglib-1.5
+ >=kde-base/kdelibs-${KDE_MINIMAL}[opengl?,semantic-desktop?]
+ >=kde-base/phonon-kde-${KDE_MINIMAL}
+ >=kde-base/plasma-workspace-${KDE_MINIMAL}
+ x11-libs/qtscriptgenerator
+ cdaudio? (
+ >=kde-base/libkcompactdisc-${KDE_MINIMAL}
+ >=kde-base/libkcddb-${KDE_MINIMAL}
+ )
+ ifp? ( media-libs/libifp )
+ ipod? ( >=media-libs/libgpod-0.7.0 )
+ mp3tunes? (
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ )
+ mp4? ( media-libs/libmp4v2 )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+ njb? ( >=media-libs/libnjb-2.2.4 )
+"
+
+RDEPEND="${DEPEND}
+ app-arch/unzip
+ daap? ( www-servers/mongrel )"
+
+# lastfm-authentication-patch was taken from upstream bug 188678.
+# commit http://websvn.kde.org/?view=rev&revision=949421
+PATCHES=( "${FILESDIR}/${PN}-ipod.patch" "${FILESDIR}/${P}-lastfm-authentication.patch" )
+
+src_configure() {
+ append-ldflags -L${KDEDIR}/$(get_libdir) -Wl,--as-needed
+
+ if ! use mp3tunes; then
+ sed -e'/mp3tunes/ s:^:#DONOTWANT :' \
+ -i "${S}"/src/services/CMakeLists.txt \
+ || die "Deactivating mp3tunes failed."
+ fi
+
+ # Remove superfluous QT_WEBKIT
+ sed -e 's/ -DQT_WEBKIT//g' \
+ -i "${S}"/src/scriptengine/generator/generator/CMakeLists.txt \
+ || die "Removing unnecessary -DQT_WEBKIT failed."
+ # Remove qtscript-generator
+ sed -e 's:add_subdirectory( src/scriptengine/generator )::g' \
+ -i "${S}"/CMakeLists.txt \
+ || die "Removing qtscriptgenerator failed."
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with cdaudio KdeMultimedia)
+ $(cmake-utils_use_with ipod Ipod)
+ $(cmake-utils_use_with ifp Ifp)
+ $(cmake-utils_use_with mp4 Mp4v2)
+ $(cmake-utils_use_with mtp Mtp)
+ $(cmake-utils_use_with njb Njb)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ kde4-base_src_configure
+}
diff --git a/media-sound/amarok/files/amarok-2.0.2-lastfm-authentication.patch b/media-sound/amarok/files/amarok-2.0.2-lastfm-authentication.patch
new file mode 100644
index 000000000000..cb47d0ad6ebd
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.0.2-lastfm-authentication.patch
@@ -0,0 +1,34 @@
+--- src/services/lastfm/LastFmServiceSettings.cpp
++++ src/services/lastfm/LastFmServiceSettings.cpp
+@@ -94,14 +94,12 @@
+ debug() << "username:" << QString( QUrl::toPercentEncoding( Ws::Username ) );
+
+ QString authToken = md5( ( m_configDialog->kcfg_ScrobblerUsername->text() + md5( m_configDialog->kcfg_ScrobblerPassword->text().toUtf8() ) ).toUtf8() );
+- QString sign_key = md5( ( "api_key" + QString( Ws::ApiKey ) + "authToken" + authToken + "methodauth.getMobileSession" + QString( Ws::SharedSecret ) ).toUtf8() );
+
+ // now authenticate w/ last.fm and get our session key
+ WsReply* reply = WsRequestBuilder( "auth.getMobileSession" )
+ .add( "username", m_configDialog->kcfg_ScrobblerUsername->text() )
+ .add( "authToken", authToken )
+ .add( "api_key", Ws::ApiKey )
+- .add( "api_sig", sign_key )
+ .get();
+
+ connect( reply, SIGNAL( finished( WsReply* ) ), SLOT( onAuthenticated( WsReply* ) ) );
+--- src/services/lastfm/LastFmService.cpp
++++ src/services/lastfm/LastFmService.cpp
+@@ -115,14 +115,12 @@
+ debug() << "username:" << QString( QUrl::toPercentEncoding( Ws::Username ) );
+
+ QString authToken = md5( ( m_userName + md5( password.toUtf8() ) ).toUtf8() );
+- QString sign_key = md5( ( "api_key" + QString( Ws::ApiKey ) + "authToken" + authToken + "methodauth.getMobileSession" + QString( Ws::SharedSecret ) ).toUtf8() );
+
+ // now authenticate w/ last.fm and get our session key
+ WsReply* reply = WsRequestBuilder( "auth.getMobileSession" )
+ .add( "username", m_userName )
+ .add( "authToken", authToken )
+ .add( "api_key", Ws::ApiKey )
+- .add( "api_sig", sign_key )
+ .get();
+
+ connect( reply, SIGNAL( finished( WsReply* ) ), SLOT( onAuthenticated( WsReply* ) ) );