summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-03 04:11:26 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-03 04:11:26 +0000
commitfd2b6fc74418e147b222a038f85c3912c9164c9c (patch)
tree166a3539cbea4f0d6c5accb03b42a63dbd8f88cc /media-sound/amsynth
parentmetadata.xml (Manifest recommit) (diff)
downloadgentoo-2-fd2b6fc74418e147b222a038f85c3912c9164c9c.tar.gz
gentoo-2-fd2b6fc74418e147b222a038f85c3912c9164c9c.tar.bz2
gentoo-2-fd2b6fc74418e147b222a038f85c3912c9164c9c.zip
Version bump closes bug #43496.
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/ChangeLog8
-rw-r--r--media-sound/amsynth/Manifest6
-rw-r--r--media-sound/amsynth/amsynth-1.0.0.ebuild54
-rw-r--r--media-sound/amsynth/amsynth-1.0_rc4.ebuild4
-rw-r--r--media-sound/amsynth/files/digest-amsynth-1.0.01
5 files changed, 69 insertions, 4 deletions
diff --git a/media-sound/amsynth/ChangeLog b/media-sound/amsynth/ChangeLog
index aa0e40dfd602..5b71005f0890 100644
--- a/media-sound/amsynth/ChangeLog
+++ b/media-sound/amsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amsynth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.4 2004/03/01 05:37:12 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.5 2004/03/03 04:11:26 eradicator Exp $
+
+*amsynth-1.0.0 (02 Mar 2004)
+
+ 02 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org> amsynth-1.0.0.ebuild,
+ amsynth-1.0_rc4.ebuild:
+ Version bump closes bug #43496.
*amsynth-1.0_rc4 (22 Jan 2004)
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
index b916514f6417..f4768f4562d2 100644
--- a/media-sound/amsynth/Manifest
+++ b/media-sound/amsynth/Manifest
@@ -1,4 +1,6 @@
-MD5 fcea3bc7da64516589b84ff9eb10daac ChangeLog 818
+MD5 615c7603afdc60031ed1c9b47a017f8d amsynth-1.0_rc4.ebuild 1585
+MD5 7bc8e391030952e1d78bc1a12b69627a amsynth-1.0.0.ebuild 1469
+MD5 2f63c89ddbc2aa4ae98a4c12d28ded42 ChangeLog 821
MD5 3be4f6e757e3057184136a002b0165f9 metadata.xml 221
-MD5 0d415c6d6856d914211fa23b4f17cc09 amsynth-1.0_rc4.ebuild 1564
MD5 bec083e8e27d21ba34cb61070ac11fea files/digest-amsynth-1.0_rc4 67
+MD5 d7a734ec324ae5b115669d858666fb58 files/digest-amsynth-1.0.0 65
diff --git a/media-sound/amsynth/amsynth-1.0.0.ebuild b/media-sound/amsynth/amsynth-1.0.0.ebuild
new file mode 100644
index 000000000000..b6a81f5e3705
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.0.0.ebuild,v 1.1 2004/03/03 04:11:26 eradicator Exp $
+
+MY_P=${P/_rc/-rc}
+MY_P=${MY_P/amsynth/amSynth}
+
+DESCRIPTION="A retro analogue - modelling softsynth"
+HOMEPAGE="http://amsynthe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/amsynthe/${MY_P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="oss alsa jack"
+
+# libsndfile support is actually optional, but IMHO this package should have it
+DEPEND="=dev-cpp/gtkmm-1.2* \
+ media-libs/libsndfile \
+ alsa? ( media-libs/alsa-lib \
+ media-sound/alsa-utils ) \
+ jack? ( virtual/jack )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAmmapAudioDriver.h
+ sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAAudioDriver.h
+}
+
+src_compile() {
+ econf `use_with oss` `use_with alsa` `use_with jack` || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "amSynth has been installed normally."
+ einfo "If you would like to use the virtual"
+ einfo "keyboard option, then do"
+ einfo "emerge vkeybd"
+ einfo "and make sure you emerged amSynth"
+ einfo "with alsa support (USE=alsa)"
+ einfo ""
+}
diff --git a/media-sound/amsynth/amsynth-1.0_rc4.ebuild b/media-sound/amsynth/amsynth-1.0_rc4.ebuild
index e10efcea3c89..f4139973d6c2 100644
--- a/media-sound/amsynth/amsynth-1.0_rc4.ebuild
+++ b/media-sound/amsynth/amsynth-1.0_rc4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.0_rc4.ebuild,v 1.1 2004/01/22 09:58:33 torbenh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.0_rc4.ebuild,v 1.2 2004/03/03 04:11:26 eradicator Exp $
MY_P=${P/_rc/-rc}
MY_P=${MY_P/amsynth/amSynth}
@@ -8,6 +8,8 @@ MY_P=${MY_P/amsynth/amSynth}
DESCRIPTION="A retro analogue - modelling softsynth"
HOMEPAGE="http://amsynthe.sourceforge.net/"
SRC_URI="mirror://sourceforge/amsynthe/${MY_P}.tar.gz"
+RESTRICT="nomirror"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
diff --git a/media-sound/amsynth/files/digest-amsynth-1.0.0 b/media-sound/amsynth/files/digest-amsynth-1.0.0
new file mode 100644
index 000000000000..93a4cb0d4430
--- /dev/null
+++ b/media-sound/amsynth/files/digest-amsynth-1.0.0
@@ -0,0 +1 @@
+MD5 9d212099735098ca39aee3789a52de62 amSynth-1.0.0.tar.gz 448974