summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-04-06 15:27:33 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-04-06 15:27:33 +0000
commit1363bba604f8847912826775671e3d3024131f95 (patch)
tree0a73d07aa6b6295569218edea011d3231c0cb29e /media-sound/cm
parentFix misplaced quote in make install line. (diff)
downloadgentoo-2-1363bba604f8847912826775671e3d3024131f95.tar.gz
gentoo-2-1363bba604f8847912826775671e3d3024131f95.tar.bz2
gentoo-2-1363bba604f8847912826775671e3d3024131f95.zip
add tcsh dep to make tests work
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-sound/cm')
-rw-r--r--media-sound/cm/ChangeLog5
-rw-r--r--media-sound/cm/cm-2.10.0.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/media-sound/cm/ChangeLog b/media-sound/cm/ChangeLog
index 7bddbb8d53f2..efecab5d7103 100644
--- a/media-sound/cm/ChangeLog
+++ b/media-sound/cm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/cm
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/ChangeLog,v 1.16 2007/02/14 17:59:38 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/ChangeLog,v 1.17 2007/04/06 15:27:33 hkbst Exp $
+
+ 06 Apr 2007; Marijn Schouten <hkBst@gentoo.org> cm-2.10.0.ebuild:
+ make tests work
14 Feb 2007; Marijn Schouten <hkBst@gentoo.org> cm-2.10.0.ebuild:
remove second compile completely
diff --git a/media-sound/cm/cm-2.10.0.ebuild b/media-sound/cm/cm-2.10.0.ebuild
index 9c15844841b9..c11f6debe5d0 100644
--- a/media-sound/cm/cm-2.10.0.ebuild
+++ b/media-sound/cm/cm-2.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/cm-2.10.0.ebuild,v 1.5 2007/02/14 21:09:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/cm-2.10.0.ebuild,v 1.6 2007/04/06 15:27:33 hkbst Exp $
inherit elisp-common
@@ -22,10 +22,11 @@ INTERPRETERS="dev-lisp/ecls
dev-scheme/gauche"
DEPEND="|| ( ${COMPILERS} ${INTERPRETERS} )
- emacs? ( virtual/emacs app-emacs/slime )"
+ emacs? ( virtual/emacs app-emacs/slime )
+ test? ( app-shells/tcsh )"
RDEPEND="${DEPEND}"
-IUSE="doc emacs"
+IUSE="doc emacs test"
S="${WORKDIR}/${PN}"
@@ -107,7 +108,7 @@ src_install() {
}
pkg_postinst() {
- # make compiled lisp code newer than source files to prevent recompilation
+ # make compiled lisp code newer than source files to prevent recompilation
sleep 1 && find ${ROOT}/usr/share/${PN}/bin/ -iname *fasl -exec touch '{}' \;
use emacs && elisp-site-regen
}