summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-29 05:07:14 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-29 05:07:14 +0000
commit67904938ea915a8fc824454df037210f90adb34c (patch)
tree8705cb2613810990106e7ff1f4dd0b6420b154f1 /media-sound/denemo
parentstable ppc, bug #434580 (diff)
downloadgentoo-2-67904938ea915a8fc824454df037210f90adb34c.tar.gz
gentoo-2-67904938ea915a8fc824454df037210f90adb34c.tar.bz2
gentoo-2-67904938ea915a8fc824454df037210f90adb34c.zip
Add missing header files to fix build with jack enabled (bug #436376 by Dominique Michel).
(Portage version: 2.2.0_alpha133/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/denemo')
-rw-r--r--media-sound/denemo/ChangeLog7
-rw-r--r--media-sound/denemo/denemo-0.9.6.ebuild3
-rw-r--r--media-sound/denemo/files/denemo-0.9.6-jack.patch66
3 files changed, 74 insertions, 2 deletions
diff --git a/media-sound/denemo/ChangeLog b/media-sound/denemo/ChangeLog
index baf45987a0c9..bf5ca9232da6 100644
--- a/media-sound/denemo/ChangeLog
+++ b/media-sound/denemo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/denemo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/denemo/ChangeLog,v 1.39 2012/09/22 00:49:21 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/denemo/ChangeLog,v 1.40 2012/09/29 05:07:14 radhermit Exp $
+
+ 29 Sep 2012; Tim Harder <radhermit@gentoo.org> denemo-0.9.6.ebuild,
+ +files/denemo-0.9.6-jack.patch:
+ Add missing header files to fix build with jack enabled (bug #436376 by
+ Dominique Michel).
*denemo-0.9.6 (22 Sep 2012)
diff --git a/media-sound/denemo/denemo-0.9.6.ebuild b/media-sound/denemo/denemo-0.9.6.ebuild
index dcb6cc66833d..a2bc533fff78 100644
--- a/media-sound/denemo/denemo-0.9.6.ebuild
+++ b/media-sound/denemo/denemo-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/denemo/denemo-0.9.6.ebuild,v 1.1 2012/09/22 00:49:21 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/denemo/denemo-0.9.6.ebuild,v 1.2 2012/09/29 05:07:14 radhermit Exp $
EAPI=4
inherit eutils fdo-mime
@@ -45,6 +45,7 @@ DOCS=( AUTHORS ChangeLog doc/{DESIGN{,.lilypond},GOALS,TODO} NEWS )
src_prepare() {
epatch "${FILESDIR}"/${P}-desktop.patch
epatch "${FILESDIR}"/${P}-alsa.patch
+ epatch "${FILESDIR}"/${P}-jack.patch
epatch "${FILESDIR}"/${P}-implicit-declarations.patch
}
diff --git a/media-sound/denemo/files/denemo-0.9.6-jack.patch b/media-sound/denemo/files/denemo-0.9.6-jack.patch
new file mode 100644
index 000000000000..93cc88db9c96
--- /dev/null
+++ b/media-sound/denemo/files/denemo-0.9.6-jack.patch
@@ -0,0 +1,66 @@
+--- src/jackbackend.h
++++ src/jackbackend.h
+@@ -0,0 +1,23 @@
++/*
++ * jackbackend.h
++ * JACK audio and MIDI backends.
++ *
++ * for Denemo, a gtk+ frontend to GNU Lilypond
++ * Copyright (C) 2011 Dominic Sacré
++ *
++ * This program is free software: you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation, either version 3 of the License, or
++ * (at your option) any later version.
++ */
++
++#ifndef JACKBACKEND_H
++#define JACKBACKEND_H
++
++#include "audiointerface.h"
++
++extern backend_t jack_audio_backend;
++extern backend_t jack_midi_backend;
++
++
++#endif // JACKBACKEND_H
+--- src/jackutil.h
++++ src/jackutil.h
+@@ -0,0 +1,37 @@
++/*
++ * jackutil.h
++ * JACK utility functions.
++ *
++ * for Denemo, a gtk+ frontend to GNU Lilypond
++ * Copyright (C) 2011 Dominic Sacré
++ *
++ * This program is free software: you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation, either version 3 of the License, or
++ * (at your option) any later version.
++ */
++
++#ifndef JACKUTIL_H
++#define JACKUTIL_H
++
++#include <glib.h>
++
++/**
++ * Returns a list of available JACK port names, that is, ports to which our
++ * own input/output ports can be connected.
++ *
++ * If the JACK server is not running or there are no available ports, this
++ * function returns NULL.
++ *
++ * @param midi if TRUE returns MIDI ports, otherwise audio ports.
++ * @param output if TRUE returns output ports, otherwise input ports.
++ */
++GList *get_jack_ports(gboolean midi, gboolean output);
++
++/**
++ * Frees a list returned by get_jack_ports()
++ */
++void free_jack_ports(GList *list);
++
++
++#endif // JACKUTIL_H