summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-29 23:16:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-29 23:16:04 +0000
commitbe773d604d99bbb0c6beb5e45263a69f6b958096 (patch)
tree809be5824d7c9a4f8258bc0f656168ce8ece45c4 /media-sound/easytag
parentAdd ~amd64-linux, bug 330427 (diff)
downloadgentoo-2-be773d604d99bbb0c6beb5e45263a69f6b958096.tar.gz
gentoo-2-be773d604d99bbb0c6beb5e45263a69f6b958096.tar.bz2
gentoo-2-be773d604d99bbb0c6beb5e45263a69f6b958096.zip
Include "load from txt" patch from Fedora wrt #329575 by Leonid Podolny.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/easytag')
-rw-r--r--media-sound/easytag/ChangeLog8
-rw-r--r--media-sound/easytag/easytag-2.1.6-r4.ebuild55
-rw-r--r--media-sound/easytag/files/easytag-2.1.6-load-from-txt.patch14
3 files changed, 76 insertions, 1 deletions
diff --git a/media-sound/easytag/ChangeLog b/media-sound/easytag/ChangeLog
index 67d7df2896dc..b82c8faefb6d 100644
--- a/media-sound/easytag/ChangeLog
+++ b/media-sound/easytag/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/easytag
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/easytag/ChangeLog,v 1.148 2010/07/04 09:27:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/easytag/ChangeLog,v 1.149 2010/07/29 23:16:04 ssuominen Exp $
+
+*easytag-2.1.6-r4 (29 Jul 2010)
+
+ 29 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +easytag-2.1.6-r4.ebuild, +files/easytag-2.1.6-load-from-txt.patch:
+ Include "load from txt" patch from Fedora wrt #329575 by Leonid Podolny.
04 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
easytag-2.1.6-r3.ebuild:
diff --git a/media-sound/easytag/easytag-2.1.6-r4.ebuild b/media-sound/easytag/easytag-2.1.6-r4.ebuild
new file mode 100644
index 000000000000..29b7deec1d88
--- /dev/null
+++ b/media-sound/easytag/easytag-2.1.6-r4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/easytag/easytag-2.1.6-r4.ebuild,v 1.1 2010/07/29 23:16:04 ssuominen Exp $
+
+EAPI=2
+inherit eutils fdo-mime
+
+DESCRIPTION="GTK+ utility for editing MP2, MP3, MP4, FLAC, Ogg and other media tags"
+HOMEPAGE="http://easytag.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="flac mp3 mp4 speex vorbis wavpack"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ mp3? ( >=media-libs/id3lib-3.8.3-r7
+ media-libs/libid3tag )
+ flac? ( media-libs/flac
+ media-libs/libvorbis )
+ mp4? ( >=media-libs/libmp4v2-1.9.0 )
+ vorbis? ( media-libs/libvorbis )
+ wavpack? ( media-sound/wavpack )
+ speex? ( media-libs/speex
+ media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop_entry.patch \
+ "${FILESDIR}"/${P}-new_libmp4v2.patch \
+ "${FILESDIR}"/${P}-cddb.patch \
+ "${FILESDIR}"/${P}-load-from-txt.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable mp3) \
+ $(use_enable mp3 id3v23) \
+ $(use_enable vorbis ogg) \
+ $(use_enable flac) \
+ $(use_enable mp4) \
+ $(use_enable wavpack) \
+ $(use_enable speex)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README THANKS TODO USERS-GUIDE
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }
diff --git a/media-sound/easytag/files/easytag-2.1.6-load-from-txt.patch b/media-sound/easytag/files/easytag-2.1.6-load-from-txt.patch
new file mode 100644
index 000000000000..ed86e58b6b2b
--- /dev/null
+++ b/media-sound/easytag/files/easytag-2.1.6-load-from-txt.patch
@@ -0,0 +1,14 @@
+http://cvs.fedoraproject.org/viewvc/rpms/easytag/devel/easytag-2.1.6-load-from-txt.patch?view=log
+http://bugs.gentoo.org/329575
+
+--- src/misc.c
++++ src/misc.c
+@@ -3327,7 +3327,7 @@ void Load_Filename_Set_Filenames (void)
+ g_free(list_text);
+ }
+
+- g_free(currentPath);
++ gtk_tree_path_free(currentPath);
+
+ Browser_List_Refresh_Whole_List();
+ ET_Display_File_Data_To_UI(ETCore->ETFileDisplayed);