summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-05-06 09:35:34 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-05-06 09:35:34 +0000
commit067582fa5dc117ffd5ac5a187d6504a053a10fdb (patch)
tree5579759b11415f4df1f86d9c7e72c5b7238445e3 /media-sound/ecasound
parentFix bug #50099. (Manifest recommit) (diff)
downloadgentoo-2-067582fa5dc117ffd5ac5a187d6504a053a10fdb.tar.gz
gentoo-2-067582fa5dc117ffd5ac5a187d6504a053a10fdb.tar.bz2
gentoo-2-067582fa5dc117ffd5ac5a187d6504a053a10fdb.zip
Version bump closes bug #50102.
Diffstat (limited to 'media-sound/ecasound')
-rw-r--r--media-sound/ecasound/ChangeLog8
-rw-r--r--media-sound/ecasound/Manifest2
-rw-r--r--media-sound/ecasound/ecasound-2.3.3.ebuild88
-rw-r--r--media-sound/ecasound/files/digest-ecasound-2.3.31
4 files changed, 98 insertions, 1 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 84a0f7d97b86..760665a4ce7f 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ecasound
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.15 2004/03/11 19:06:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.16 2004/05/06 09:35:34 eradicator Exp $
+
+*ecasound-2.3.3 (06 May 2004)
+
+ 06 May 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ ecasound-2.3.3.ebuild:
+ Version bump closes bug #50102.
11 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
ecasound-2.3.0.ebuild, ecasound-2.3.2.ebuild:
diff --git a/media-sound/ecasound/Manifest b/media-sound/ecasound/Manifest
index c74a5d9bc81d..ebe7b5d9dc13 100644
--- a/media-sound/ecasound/Manifest
+++ b/media-sound/ecasound/Manifest
@@ -1,3 +1,4 @@
+MD5 9ff182405bffdbfd238614b0caa8664f ecasound-2.3.3.ebuild 2747
MD5 8c811cac5009786f816dc6f58b473969 ecasound-2.3.0.ebuild 2994
MD5 9ff182405bffdbfd238614b0caa8664f ecasound-2.3.2.ebuild 2747
MD5 4a115143f314a177810cdd79456103fe ecasound-2.2.3.ebuild 3012
@@ -6,3 +7,4 @@ MD5 3be4f6e757e3057184136a002b0165f9 metadata.xml 221
MD5 3bb7f0619e719cccec8c69b4f84788c3 files/digest-ecasound-2.2.3 66
MD5 30dbf7e3da44712e8b824a5e89451188 files/digest-ecasound-2.3.0 66
MD5 e68dadbc41193dfa31762ee90a4b2271 files/digest-ecasound-2.3.2 66
+MD5 92bd0b879f6e514225f5db2a2d474688 files/digest-ecasound-2.3.3 66
diff --git a/media-sound/ecasound/ecasound-2.3.3.ebuild b/media-sound/ecasound/ecasound-2.3.3.ebuild
new file mode 100644
index 000000000000..fec86a7415af
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.3.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.3.3.ebuild,v 1.1 2004/05/06 09:35:34 eradicator Exp $
+
+IUSE="ncurses arts alsa python oss mikmod oggvorbis jack audiofile"
+
+DESCRIPTION="A package for multitrack audio processing"
+SRC_URI="http://ecasound.seul.org/download/${P}.tar.gz"
+HOMEPAGE="http://eca.cx/"
+LICENSE="GPL-2"
+
+SLOT="1"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ jack? ( virtual/jack )
+ media-libs/ladspa-sdk
+ audiofile? ( media-libs/audiofile )
+ alsa? ( media-libs/alsa-lib )
+ oggvorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ mikmod? ( media-libs/libmikmod )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )"
+
+# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
+# use flags for them.
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:map.h:map:g' configure
+}
+
+src_compile () {
+ local myconf
+
+ use jack || myconf="$myconf --disable-jack"
+ use alsa || myconf="$myconf --disable-alsa"
+ use arts || myconf="$myconf --disable-arts"
+ use ncurses || myconf="$myconf --disable-ncurses"
+ use audiofile || myconf="$myconf --disable-audiofile"
+ use oss || myconf="$myconf --disable-oss"
+
+ if use python; then
+ #
+ # ecasound is braindead about finding python includes/libdirs and
+ # about where to install modules. Luckily, it allows us to specify
+ # all this.
+ #
+ local python_version python_prefix python_includes python_modules
+ python_version="`python -c 'import sys; print sys.version[:3]'`"
+ python_prefix="`python -c 'import sys; print sys.prefix'`"
+
+ python_includes="$python_prefix/include/python$python_version"
+ python_modules="$python_prefix/lib/python$python_version"
+
+ # ecasound configure assumes `disable' if you pass
+ # --(enable|disable)-pyecasound. *sigh*
+ #myconf="$myconf --enable-pyecasound"
+
+ myconf="$myconf --with-python-includes=$python_includes"
+ myconf="$myconf --with-python-modules=$python_modules"
+ else
+ myconf="$myconf --disable-pyecasound"
+ fi
+
+ einfo "configuring with ${myconf}"
+ econf ${myconf} || die "configure failed"
+ make || die "build failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use python; then
+ cd pyecasound || die
+ python -c "import compileall; compileall.compile_dir('.')" || die
+ python -O -c "import compileall; compileall.compile_dir('.')" || die
+ python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
+ install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
+ cd ..
+ fi
+
+ dodoc INSTALL FAQ BUGS COPYING NEWS README TODO
+ dohtml `find Documentation -name "*.html"`
+ dodoc Documentation/edi-list.txt
+}
diff --git a/media-sound/ecasound/files/digest-ecasound-2.3.3 b/media-sound/ecasound/files/digest-ecasound-2.3.3
new file mode 100644
index 000000000000..ef6f9a6a5bb9
--- /dev/null
+++ b/media-sound/ecasound/files/digest-ecasound-2.3.3
@@ -0,0 +1 @@
+MD5 6db220e7d179e5a07ca27379ba23e517 ecasound-2.3.3.tar.gz 959967