summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-31 13:12:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-31 13:12:54 +0000
commite25400c4f0bb1f0a9cb2aef7ac49e4c90b3e3ac6 (patch)
treecf2f21a64162ce124a2c3db038ae90c76e3571a4 /media-sound/fluidsynth
parentVersion bump (diff)
downloadgentoo-2-e25400c4f0bb1f0a9cb2aef7ac49e4c90b3e3ac6.tar.gz
gentoo-2-e25400c4f0bb1f0a9cb2aef7ac49e4c90b3e3ac6.tar.bz2
gentoo-2-e25400c4f0bb1f0a9cb2aef7ac49e4c90b3e3ac6.zip
Version bump.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/ChangeLog8
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.3.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index 4b090834aac0..c7125ec03c3d 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.59 2010/10/13 06:18:29 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.60 2010/10/31 13:12:54 ssuominen Exp $
+
+*fluidsynth-1.1.3 (31 Oct 2010)
+
+ 31 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +fluidsynth-1.1.3.ebuild:
+ Version bump.
13 Oct 2010; Tim Harder <radhermit@gentoo.org> fluidsynth-1.0.9.ebuild,
fluidsynth-1.1.0.ebuild, fluidsynth-1.1.1.ebuild:
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.3.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.3.ebuild
new file mode 100644
index 000000000000..72b882153501
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.1.3.ebuild,v 1.1 2010/10/31 13:12:54 ssuominen Exp $
+
+EAPI=2
+inherit cmake-utils
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa dbus debug examples jack ladspa lash portaudio pulseaudio readline sndfile"
+
+RDEPEND=">=dev-libs/glib-2.6.5:2
+ alsa? ( media-libs/alsa-lib
+ lash? ( >=media-sound/lash-0.5 ) )
+ dbus? ( >=sys-apps/dbus-1.0.0 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.8 )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ readline? ( sys-libs/readline )
+ sndfile? ( >=media-libs/libsndfile-1.0.18 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use alsa enable-alsa)
+ $(cmake-utils_use dbus enable-dbus)
+ $(cmake-utils_use debug enable-debug)
+ $(cmake-utils_use jack enable-jack)
+ -Denable-ladcca=OFF
+ $(cmake-utils_use ladspa enable-ladspa)
+ $(cmake-utils_use sndfile enable-libsndfile)
+ $(cmake-utils_use portaudio enable-portaudio)
+ $(cmake-utils_use pulseaudio enable-pulseaudio)
+ $(cmake-utils_use readline enable-readline)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( $(cmake-utils_use lash enable-lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc AUTHORS NEWS README THANKS TODO doc/*.txt
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins doc/*.pdf
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/*.c
+ fi
+}