summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-27 19:29:46 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-27 19:29:46 +0000
commit4e68fe71a69383fdefaebfedf0524e491367d364 (patch)
tree59b9a757136d0b69171dfac46146918c10ff9b55 /media-sound/glmix/glmix-0.3.ebuild
parentClean up. (diff)
downloadgentoo-2-4e68fe71a69383fdefaebfedf0524e491367d364.tar.gz
gentoo-2-4e68fe71a69383fdefaebfedf0524e491367d364.tar.bz2
gentoo-2-4e68fe71a69383fdefaebfedf0524e491367d364.zip
Version bump.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'media-sound/glmix/glmix-0.3.ebuild')
-rw-r--r--media-sound/glmix/glmix-0.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/glmix/glmix-0.3.ebuild b/media-sound/glmix/glmix-0.3.ebuild
new file mode 100644
index 000000000000..0b87e23d4149
--- /dev/null
+++ b/media-sound/glmix/glmix-0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/glmix/glmix-0.3.ebuild,v 1.1 2007/07/27 19:29:46 drac Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A 3D widget for mixing up to eight JACK audio streams down to stereo"
+HOMEPAGE="http://devel.tlrmx.org/audio"
+SRC_URI="http://devel.tlrmx.org/audio/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-sound/jack-audio-connection-kit
+ >=x11-libs/gtkglext-1
+ >=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local libs="gtk+-2.0 gtkglext-1.0 jack pango"
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} $(pkg-config --cflags ${libs})" \
+ LDFLAGS="${LDFLAGS} $(pkg-config --libs ${libs})" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README TODO
+ make_desktop_entry ${PN} "GL Mixer"
+}